Backup de Configurações do MikroTik RouterOS

Publicado por Carlos Affonso Henriques. em 09/06/2019

[ Hits: 507 ]

 


Backup de Configurações do MikroTik RouterOS



A tarefa de fazer um backup das configurações do seu RouterOS, é extremamente simples. Você pode, inclusive, usar esse recurso para orquestrar um parque com várias Routerboards usando tão somente Shell Script.

Crie um arquivo de texto com uma extensão ".rsc" que conterá todo o seu setup.

Ex.: config-mkt-001.rsc

:for x from 1 to 10 do={/ip firewall filter remove numbers=$x}
/interface ovpn-client add name="ovpn0" connect-to="ip.ou.nome.do.seu.vpn.server" port="1194" auth=sha1 cipher=aes256 profile=default-encryption user="mkt-71AF08744B58" password="22887e754b75c5f409c67d1c6cad966d"
/user group add name="ovpnapi" policy=read,write,api
/user add name="ovpnapiloginname" password="5u453nh453cr3t4" group=ovpnapi
/user add name="adminsecreto" password="SuaSenhaSecreta" group=full

Explicação do exemplo acima:
  • A 1ª linha limpa todas as regras de Firewall na tabela filter.
  • A 2ª linha cria uma interface OVPN chamada "ovpn0" que conecta ao servidor OpenVPN com:
    • Login: mkt-71AF08744B58
    • Senha: 22887e754b75c5f409c67d1c6cad966d
  • A 3ª linha cria um grupo chamado "ovpnapi" com privilégios read,write,api, para que uma API possa manipular o RouterOS
  • A 4ª linha cria um usuário chamado "adminsecreto" com senha "SuaSenhaSecreta" com privilegios de administrador "full"

Agora copie o arquivo "config-mkt-001.rsc" para o diretório /flash do seu RouterOS através do SCP do SSH:

# scp -oStrictHostKeyChecking=no config-mkt-001.rsc admin@192.168.88.1:flash/

Conecte-se ao seu RouterOS via SSH:

# ssh -oStrictHostKeyChecking=no admin@192.168.88.1

Em seguida, execute o comando:

# import

...para que o Mikrotik aplique as configurações do arquivo "config-mkt-001.rsc /import flash/config-mkt-001.rsc".

Você pode também passar o comando diretamente via SSH para o MikroTik RouterOS a partir de sua máquina Linux:

# ssh -oStrictHostKeyChecking=no admin@192.168.88.1 /import flash/config-mkt-001.rsc

Se tudo correr bem, a saída será:

Script file loaded and executed successfully

Pronto! Sua Routerboard está configurada, com um arquivo de backup local e uma cópia no diretório /flash do RouterOS.

NOTA: apenas atente para a ordem dos comandos, comandos para trocar endereços IP ou derrubar serviços, como o SSH por exemplo, podem deixa-lo sem conexão antes da execução completa do script. Nesses casos, deixe-os por último.

Bom trabalho a todos!

Outras dicas deste autor

CentOS 6.5 (com Intel i915) - Erro após upgrade: "server terminated with error (2); no screens found" [Resolvido]

Conhecendo o printf

Sincronizando relógios de hardware e de sistema

[RESOLVIDO] Slackware 13.1.x sob CentOS/KVM não reconhece interface de rede

Raspberry PI 3: Wireless integrada funcionando no Slackware ARM

Leitura recomendada

Instalando o Flash Player no Debian Etch em máquinas 64 bits

Fedeasy - Script arredondador do Fedora

Solução para o problema ao iniciar o JACK no Kubuntu

Palestra sobre gerenciamento de memória virtual no kernel linux

Goggles Music Manager

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts