Atualizando o Java Runtime Enveronment (JRE) de um jeito bem fácil

Publicado por Glauber GF em 31/01/2012

[ Hits: 7.640 ]

Blog: http://www.vivaolinux.com.br/~mcnd2

 


Atualizando o Java Runtime Enveronment (JRE) de um jeito bem fácil



A procedimento descrito aqui foi o modo mais fácil que achei para deixar a versão do JAVA - JRE atualizado para o sistema GNU/Linux (Debian 6.0.3).

1) Adicione a linha de repositório abaixo, no arquivo 'sources.list' em '/etc/apt/':

deb http://www.duinsoft.nl/pkg debs all


Depois adicione a chave gpg:

# apt-key adv --keyserver keys.gnupg.net --recv-keys 5CB26B26

2) Execute a atualização do repositório com:

# apt-get update

Será exibida informações sobre a atualização dos repositórios.

3) Instalando o JRE - Java Runtime Enveronment atualizado (no momento "compilação 1.6.0_30-b12") com:

# apt-get install update-sun-jre

Será exibido várias informações referentes à instalação. Espere finalizar a instalação.

Prontinho!

Agora temos o "Java Runtime Environment" atualizado no sistema.

Só ressaltando, tentei do modo que o próprio site do 'Java' propõe ( http://java.com/pt_BR/download/help/linux_x64_install.xml ) mais não obtive êxito.
Linux: Atualizando o 'Java Runtime Enveronment' (JRE) de um jeito bem fácil

Fonte:

Outras dicas deste autor

Deixando o Firefox e Thunderbird do LMDE em português do Brasil

Instalar driver da Nvidia no Debian 5 Lenny Linux

Configurando contas do Hotmail e Yahoo no Evolution

Configurar internet via rádio e modem 3G no Debian Squeeze

Pastas compartilhadas entre "host Debian" e "guest Arch" no VirtualBox

Leitura recomendada

SSH: Somente usuários autorizados

Filtro de conteúdo com iptables

Ferramentas e informações para correção do bug do OpenSSL (HeartBleed)

Snort - Instalação e configuração

BIND: Ataque pode causar Negação de Serviço através do Dynamic Update

  

Comentários
[1] Comentário enviado por crf-rafa em 31/01/2012 - 11:25h

Eu tava escrevendo essa dica kkk
Mto bom Glauber (:

[2] Comentário enviado por mcnd2 em 31/01/2012 - 15:49h

Valeu @crf-rafa pelo comentário.

Tive muitos problemas com o java em relação a 'Internet Banking' e com isso encontrei esse procedimento para deixar o java mais atual instalado.

Abraço.

[3] Comentário enviado por VonNaturAustreVe em 31/01/2012 - 18:29h

Comecei a utilizar o open-jdk7 e sinceramente, não vejo mais motivos para continuar usando a jre da oracle, o desempenho do open-jdk está excelente, o projeto evoluiu muito! Me lembro que a uns 2 anos atrás fui utilizar o openjdk e só passei raiva.

Sem dúvidad o projeto atingiu a maturidade.

[]'s

[4] Comentário enviado por removido em 01/02/2012 - 17:56h

também compartilho da opinião do colega acima, também venho usando a versão OpenSource e não tenho do que reclamar.

lembrando que esse Java da Oracle só está disponível para o Lenny e o Squeeze, no Wheezy e no SID ele já foi removido, então no próximo Stable o jeito será usar ou o OpenJDK ou o binário da Oracle.

http://packages.debian.org/search?keywords=sun-java6-jre

no SID não existe o sun-java6-plugin e além disso o pacote sun-java6-jre depende de um inexistente sun-java6-bin



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts