Ativando o scroll do mouse

Publicado por Renato Michnik de Carvalho em 30/12/2002

[ Hits: 30.872 ]

Blog: http://www.rootlinux.com.br

 


Ativando o scroll do mouse



Para quem não sabe o que é o scroll do mouse, simplificando é aquela rodinha que alguns mouses possuem :-)

Para habilitá-la é muito fácil. Edite o seu arquivo XF86Config e procure pela linha parecida com:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/ttyS0"
Option "Protocol" "Microsoft"
Option "ZAxisMapping" "4 5"
EndSection
E troque a linha:

Option "Protocol" "Microsoft"

por:

Option "Protocol" "IntelliMouse"

se não funcionar coloque:

Option "Protocol" "IMPS/2"

Salve o arquivo, reinicie o seu servidor X e pronto, sua rodinha estará funcionando :-)

Fonte: http://www.xlinuxnews.com.br

Outras dicas deste autor

Acertando data/hora no Linux

Utilizando o KaZaA em GNU/Linux Debian

Leitura recomendada

Instalação do Debian em HD SATA

Debian Lenny 5.0 64Bits Lenny no Dell Vostro 1310

Placa Wireless Ralink RT3090 no Ubuntu 12.04

Driver ALPS touchpad em Slackware

Ligar e desligar touchpad no XFCE usando input-libinput

  

Comentários
[1] Comentário enviado por removido em 07/01/2004 - 17:49h

Hey cara não sei se é isso mas essa dica não funcionou aqui estou usando o Conectiva 9...

[2] Comentário enviado por hackwiz em 07/01/2004 - 17:56h

Vc alterou o arquivo XF86Config? Cuidado que o seu X pode estar usando o arquivo XF86Config-4 então vc alteraria ele.

Seguindo a dica, se não funcionar quando vc colocar "Protocol" "Microsoft" vc coloca: Option "Protocol" "IMPS/2"

o que faz realmente a rodinha funcionar é o: Option "ZAxisMapping" "4 5"

[3] Comentário enviado por dolfao em 04/05/2004 - 08:58h

para o kurumin tbm funciona????????

[4] Comentário enviado por hackwiz em 04/05/2004 - 09:38h

em qualquer distribuição pois não depende da distro e sim do XFree86 = )

[5] Comentário enviado por Xterminator em 13/05/2004 - 12:27h

No conectiva é muito simples , nem precisa editaro XF86Config-4

mouseconfig

para mouse serial escolha

Microsoft IntelliMouse(Serial)

PS2/USB

Microsoft IntelliMouse(PS/2)

Válido também já na hora da instalação :-)
Fonte Comunidade Conectiva Linux
http://www.ccl-br.com.br/forum/viewtopic.php?t=27

[6] Comentário enviado por cladorf em 01/06/2004 - 18:53h

Valeu. Tive um pouco de dificuldades, mas no final deu tudo certo.
Obrigado pela ajuda.


Cláudio

[7] Comentário enviado por amichels em 17/08/2004 - 22:27h

Tentei essa dica no meu slackware 10, mas não obtive sucesso... Alguém ai já conseguiu confirar o scroll no slackware???

PS: O slack 10 não usa mais XFree, e sim, XOrg.

valeu

[8] Comentário enviado por dagr9782 em 12/10/2004 - 19:41h

Para fazer funcionar no Slack 10, edite o arquivo:
/etc/X11/xorg.conf
altere a linha:
Option "Protocol" "PS/2"
para
Option "Protocol" "IMPS/2"
e adicione as linhas:
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

Ai eh so reiniciar o X.

[9] Comentário enviado por raton em 04/11/2005 - 17:19h

Eu tentei todas as sugestoes acima mas, soh consegui fazer funcionar modificando os campos para:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

{}`s
Raton

[10] Comentário enviado por cazealves em 28/11/2005 - 16:34h

D+!!! valeu pela dica!!!

Depois de tudo feito como vc falou, ainda tive que habilitar
____Option "ZAxisMapping" "4 5" ____
para que o scroll funcionasse...
o "intellimouse" deixa o ponteiro do PS2 louquinho, então usei o "IMPS/2"

Valeu mesmo, mano!

[11] Comentário enviado por m4we1s em 09/08/2006 - 10:19h

tentei tbm no slackware 10, mais não funcionou


abraço

[12] Comentário enviado por dbahiaz em 09/10/2006 - 23:26h

Pessaol me ajuda aqui, o quem de errado aqui, pois o cursor nao aparece

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"

[13] Comentário enviado por tardelli em 15/11/2007 - 23:36h

Acabei de testar aqui no slackware 11 e funcionou 100% !!!
testado e aprovado !!!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts