Arduino no Slackware

Publicado por Charles em 04/07/2012

[ Hits: 4.868 ]

 


Arduino no Slackware



A dica abaixo descreve como fiz para rodar a IDE do Arduino 1.0 no Slackware 13.37, vamos lá.

A primeira coisa que deve ser feita é baixar a IDE do Arduino:
Para a versão 64 bits, consulte o site do Arduino.

Instalação:

# cd Downloads
# installpkg arduino-1.0.1-linux.tgz


Depois de instalado, plugue sua placa Arduino em uma entrada USB, vá ao terminal e:

# tail -f /var/log/messages

Isso te mostrará o log recente de entrada do sistema, e você deverá ver logo de cara, o nome Arduino escrito.

Duas linhas abaixo estará a informação da porta de entrada, que normalmente é a ttyACM0, porém, se você checar em:

# ls /dev

Normalmente não haverá um registro para ttyACM0 (no meu caso não havia). Então:

# mknod /dev/ttyACM0 c 166 0

E por fim, defina 'ttyACM0' como porta serial do Arduino:

# vim /opt/arduino/lib/preferences.txt

Altere a linha "serial.port" de forma que fique:

serial.port = ttyACM0

Salve e verifique se a IDE do Arduino está rodando normal agora.

Esta dica foi baseada em um problema que aconteceu comigo, pode ser que vocês não tenham tido a necessidade de passar pelo mesmo processo.

Postem o resultado, em caso de erro.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Wget - Baixando sites inteiros

WINFF - front-end ffmpeg - conversor universal de áudio e vídeo

Apresentando o Quanta Plus

Clarkconnect - Gerencie seu servidor Linux pela web

OpenOffice.org utilizando programas externos

  

Comentários
[1] Comentário enviado por tsuriu em 16/01/2013 - 22:53h

Existe alguma dependência a ser resolvida...?!

[2] Comentário enviado por .chr em 17/01/2013 - 13:04h

tsuriu, não entendi sua pergunta, poderia esclarecer?

[3] Comentário enviado por tsuriu em 21/01/2013 - 21:42h

Perguntei se havia alguma dependência para a instalação da IDE, mas isso já descobri e resolvi...

Eu comprei um Arduino UNO R3, segui esse procedimento de nada...

Alguma dica...?!

[4] Comentário enviado por tsuriu em 21/01/2013 - 21:48h


[3] Comentário enviado por tsuriu em 21/01/2013 - 21:42h:

Perguntei se havia alguma dependência para a instalação da IDE, mas isso já descobri e resolvi...

Eu comprei um Arduino UNO R3, segui esse procedimento de nada...

Alguma dica...?!


Cara muito obrigado pela atenção, já encontrei a solução era só executar como root... Brigadão msm..



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts