Arduino - Porta serial não disponível na IDE [Resolvido]

Publicado por Lisandro Guerra em 26/04/2013

[ Hits: 71.088 ]

 


Arduino - Porta serial não disponível na IDE [Resolvido]



Tenho visto que várias pessoas têm enfrentado problemas para configurar a porta serial na IDE do Arduino e aqui mesmo no VOL, vejo o pessoal resolver o problema rodando a IDE como root.

Entretanto, o problema é apenas de grupos do usuário e a solução é bem simples.

Abra o terminal e inclua o usuário nos grupos "tty" e "dialout", com os comandos:

sudo usermod -a -G tty teu_usuario
$ sudo usermod -a -G dialout teu_usuario


Agora faça logout e em seguida, login novamente.

Para verificar se os grupos foram incluídos, use o comando:

groups

Na saída do comando tem que constar os grupos aos quais incluímos o usuário.

Tudo conferido? Agora é só abrir a IDE, conectar a placa Arduino e a configuração da serial estará disponível.
Linux: Arduino - Porta serial não disponível na IDE
Abraço.

Fontes:
Outras dicas deste autor

Wine 1.5.X - Instalação no Linux Mint 13 e Ubuntu 12.04

Como listar os maiores arquivos pelo terminal

Comandos mkdir e cd simultaneamente

Vim editor - inserir e retirar numeração de linhas

LAMP com PHP 7 no Linux Mint 17.3 e Ubuntu 14.04

Leitura recomendada

Arduino - Porta serial acessível a todos os usuários

Conectores e terminais para Raspberry Pi, Arduino e outros dispositivos

Como instalar Arduino no Fedora 25

qOrganizer - Agenda e organizador pessoal

A melhor e mais importante linguagem de programação

  

Comentários
[1] Comentário enviado por brincker em 21/12/2013 - 09:04h

Lisandro.
Parabens, seu tutorial salvou meu dia. Fiz exatamente como disse e resolveu. Muito obrigado

[2] Comentário enviado por tiglinux em 18/09/2014 - 15:25h

òtima ,dica !!! EU passei muito perrenque com falta de informação de como proceder para resolver o problema da porta serial no meu arduino... ele passava o mesmo problema :)

[3] Comentário enviado por ismarrussano em 24/11/2014 - 14:38h

Ola Lisandro,

Obrigado por publicar essas informaçoes. Salvou meus projetos com Arduino em Linux ( Ubuntu Studio 14 - 64bits).
Foi só ativar o usuario e funcionou normalmente a interface.

Grande abraço.

[4] Comentário enviado por Lisandro em 24/11/2014 - 21:03h


[3] Comentário enviado por ismarrussano em 24/11/2014 - 14:38h:

Ola Lisandro,

Obrigado por publicar essas informaçoes. Salvou meus projetos com Arduino em Linux ( Ubuntu Studio 14 - 64bits).
Foi só ativar o usuario e funcionou normalmente a interface.

Grande abraço.


Caro Ismar,
obrigado a você pelo comentário.
É muito gratificante saber que se pôde ajudar alguém.
Um abraço e bem-vindo à comunidade do VOL.

[5] Comentário enviado por gabrielvaghetti em 01/05/2015 - 02:36h

Bah meu amigo. Funcionou perfeito muito obrigado mesmo, estava quase a 4h tentando resolver isso. Sou leigo com Linux. Obrigado mesmo, abraço...

[6] Comentário enviado por valle em 23/05/2015 - 15:25h

Grande Lisandro!

Estou começando a estudar o Arduino e desde esta manhã tentando fazer o upload do famoso "pisca led" - o Hello Word do Arduino - e nada dava certo.
Muito obrigado pela dica!

Abraços,

Valle

[7] Comentário enviado por douglaslara em 02/01/2016 - 19:38h

Obrigado amigo, deu certo :)

[8] Comentário enviado por wandaymo em 06/11/2016 - 13:32h

Muito obrigado pela dica Lisandro Guerra!!!
Wandaymo

[9] Comentário enviado por Lisandro em 06/11/2016 - 13:39h


[8] Comentário enviado por wandaymo em 06/11/2016 - 13:32h

Muito obrigado pela dica Lisandro Guerra!!!
Wandaymo


Feliz em ajudar Wandaymo. Bem-vindo à comunidade VOL.

[10] Comentário enviado por wandaymo em 06/11/2016 - 13:52h

Obrigado!!!!
#VivaOLinux
Wandaymo

[11] Comentário enviado por Rodrigo_Orlando em 02/09/2017 - 15:17h

Obrigado pela ajuda amigo! Funcionou perfeitamente!

[12] Comentário enviado por Alpha-X em 25/03/2018 - 12:03h

Muito obrigado pela ajuda.

[13] Comentário enviado por alexsgono em 10/02/2019 - 20:24h

E aí pessoal beleza?
Não estava conseguindo habilitar de jeito maneira, daí tentei de outra forma e consegui aqui
Baixei a IDE direto do site da arduino, pois o da loja não estava dando boa, e então instalei o arquivo sh e funcionou certinho.
Abraço.

[14] Comentário enviado por Almeidadiego6095 em 07/05/2019 - 10:33h

Saudações a todos.
Estou usando linux mint e xubunto.
Não consigo "habilitá" na IDE do Arduíno a seleção da porta USB ou COM1.
Já tentei os procedimentos acima mas não consegui.
Já estou considerando trocá a distro.

[15] Comentário enviado por Lisandro em 07/05/2019 - 12:03h


[14] Comentário enviado por Almeidadiego6095 em 07/05/2019 - 10:33h

Saudações a todos.
Estou usando linux mint e xubunto.
Não consigo "habilitá" na IDE do Arduíno a seleção da porta USB ou COM1.
Já tentei os procedimentos acima mas não consegui.
Já estou considerando trocá a distro.

Ontem mesmo fiz este procedimento no Linux Mint e funcionou perfeitamente.
Você fez logout e login novamente para ter efeito, como está na dica?

Abraço



Contribuir com comentário