Antico: WM leve baseado em QT4

Publicado por Perfil removido em 08/09/2009

[ Hits: 7.007 ]

 


Antico: WM leve baseado em QT4



Antico é um gerenciador de janelas baseado na QT4 e sem nenhum vínculo direto com o KDE. O Antico é bom para ser usado em computadores antigos, no qual o usuário tenha vontade de conhecer QT4, mas não tem possibilidade de instalar o KDE4 devido às limitações da máquina.

Para instalar o Antico você precisará de alguns pacotes, sendo eles:
  • git
  • libqt4-devel
  • g++
  • qmake ou make
  • xorg-x11-server-extra

Para instalar os pacotes acima (no Debian Lenny), digite:

# apt-get install git-core
# apt-get install qt4-qmake


ou:

# apt-get install make
# apt-get install g++
# apt-get install libqt4-dev


O pacote xorg-x11-server-extra não existe nos repositórios do Debian, enquanto eu escrevia esse artigo. Mas parece que ele é utilizado para rodar o Antico dentro de outro ambiente gráfico.

Para baixar o binário: antico-0.2.tar.gz. Ou se preferir, pode baixar o código fonte e compilá-los com os seguintes comandos:

# git clone git://github.com/antico/antico.git
# cd /root/antico/
# make


Depois disso você precisa editar o arquivo install na linha de número 12, trocando o comando ln -s por mv. Caso não faça isso, o instalador criará um link simbólico do binário do diretório /root/antico para /usr/bin, tornando-o vulnerável - caso você exclua a pasta /root/antico sem querer.

Concluindo o passo acima, digite - ainda como root:

# chmod +x install
# ./install


Agora faça o logout na sua conta e escolha no GDM ou KDM a sessão Antico. Se tudo correr bem, o Antico estará funcionando. :D

Bom, essa foi minha dica de hoje, tirada do meu blog para o VOL. Espero que compreendam que isto só foi uma dica, e não dá para cobrir erros, ou bugs, aqui.

Espero que aproveitem!

Abraços.

Site oficial do Antico: http://www.antico.netsons.org

Fonte: Antico... WM leve baseado na QT4 « Blog do Jean Landim

Outras dicas deste autor

Criando LVM (Logical Volume Manager)

Instalando o Google Earth

Exibindo mensagens ao efetuar login

CUPS-PDF: erro "cups-pdf failed" [Ubuntu 9.04]

Detecção automática de impressora no Linux

Leitura recomendada

Ubuntu 12.04 - VirtualBox parou de funcionar? [Resolvido]

2nd Free Software Meeting

Instalando o Drop Down Terminal em ambiente gráfico GNOME

Mortal Kombat para Linux

Instalar Java no Debian

  

Comentários
[1] Comentário enviado por albfneto em 09/09/2009 - 01:18h

já conhecia ele.
Fiz vários testes com antico, em gentoo;
é muito pequeno e leve, mas é prático,mas é prático e muito bem, organizado, pq os aplicativos estão todos em ordem alfabética no menu, eé muioto estável.

[2] Comentário enviado por lcdsantos em 09/09/2009 - 13:05h

Legal, mas na página dele no qt-apps consta...

http://www.qt-apps.org/content/show.php/Antico?content=93778

Description:
*********************
ANTICO DEVELOPMENT IS ENDED (I SWITCHED TO MAC OS X).
I'M AVAILABLE TO PROVIDE ANY CLARIFICATION TO ALL INTERESTED DEVELOPERS TO CONTINUE THE PROJECT.
*********************

Nem chegou ao 0.3 e morreu?

E o cara troca o Linux pelo Mac OS X?

Francamente...

Nunca vou botar as mãos nisso...

[3] Comentário enviado por removido em 12/09/2009 - 02:27h

Pois é, cara... arquitetura do software era uma bosta.
Mas o que vale é a intenção!

[4] Comentário enviado por zezosc em 17/09/2009 - 01:09h

Também há o Antico Deluxe (http://qt-apps.org/content/show.php/Antico+Deluxe?content=95422&PHPSESSID=1d608bd9653e8ff3928fca7955855704), que é um fork do Antico. Entretanto, parece que não tem recebido atualizações recentes.

Vlw.

[5] Comentário enviado por nickmarinho em 05/01/2010 - 15:41h

Nem chegou ao 0.3 e morreu? #2
E o cara troca o Linux pelo Mac OS X? #2
Francamente... #2
Nunca vou botar as mãos nisso... #2

[6] Comentário enviado por jeanlandim em 12/01/2014 - 17:46h

O tempo voa, faz tempo que eu escrevi essa dica. Até fiz a infeliz ação de apagar a minha conta no VOL (por isso o usuário removido).

Apesar do fracasso do projeto, temos hoje variantes baseada em QT. Sendo eles o LXDE-QT:http://wiki.lxde.org/en/LXDE-Qt e o Razor-QT: http://razor-qt.org/.

Enjoy!!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts