Resolvendo problema de conexão a internet ADSL (Velox)

Ao se conectar com sucesso usando o comando adsl-start, você não consegue acessar nenhum site e o comando ping não retorna nada de resposta? Se você está passando por isso seus problemas acabaram, clique aqui e descubra a solução.

[ Hits: 56.728 ]

Por: Diogo Melo em 11/06/2004


O problema



Ao digitar o comando "adsl-start" como root no console eu obtia, como o esperado, a seguinte resposta que transcrevo abaixo:

# adsl-start
. Connected!

Porém ao digitar:

# ping www.veloxzone.com.br

Por mais que eu esperasse não obtia resposta de ping e não conseguia acessar o site de autenticação da Telemar e nem nenhum site disponível.

E ao digitar "adsl-status" eu obtia a resposta esperada como transcrevo abaixo:

# adsl-status
adsl-status: Link is up and running on interface ppp0
ppp0  Link encap:Point-to-Point Protocol
      inet addr:200.xxx.xxx.xxx  P-t-P:200.xxx.50.119  Mask:255.255.255.255
      UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
      RX packets:8 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0
      RX bytes:844 (844.0 b)  TX bytes:434 (434.0 b)


OBS: Para quem não sabe, os xxx acima, na verdade são números do endereço IP que omiti só por questões de segurança pessoal :P)

Poxa... o Velox havia conectado normalmente! O que estava acontecendo então?

Recaptulei os procedimentos que encontrei em alguns tutoriais como:
  • verificar os servidores DNS no arquivo /etc/resolv.conf.
  • verificar se a placa de rede estava funcionando (eth0).
  • verificar o ping no endereço numérico do www.veloxzone.com.br.

Tudo funcionava, porém eu não obtia sucesso.

    Próxima página

Páginas do artigo
   1. O problema
   2. A (simples) solução
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Vídeo e rádio no Firefox

Conceito de NAT detalhadamente

Mascarando conexões VPN com iptables

Transmission-CLI - Gerenciando torrents via CLI

Entendendo redes wireless

  
Comentários
[1] Comentário enviado por lamss em 11/06/2004 - 22:23h

Gostei da explicação...
Será que vc pode me ajudar com o meu problema...
Tenho o velox instalado aqui funcionando blz no Slack 9 só que meu modem é Speed Stream 5200 (firmware atualizado para ser Roteador), não preciso fazer esse procedimento que vc mencionou anteriormente. O modem como roteador só precisei colocar a rede como DHCP e o modem atribui um ip para a maquina automaticamente...
O que eu preciso é acessar essa maquina que esta sendo atribuido um ip de fora da minha rede por exemplo pela internet, pois essa maquina não tem ip valido na internet só para a minha rede interna.
Você tem alguma ideia de como fazer.

[2] Comentário enviado por dmelorj em 12/06/2004 - 00:33h

lamss,

Pra fazer isso voce precisará configurar o firewall que bem nesse modem para redirecionar diretamente para o ip mascarado, o acesso a determinadas portas que ele vai receber. Se voce tem um servidor web no seu micro, vc precisará redirecionar o acesso a porta 80. Essa é uma operação relativamente simples que vc encontra explicações sobre ela no site www.abusar.org.br

[3] Comentário enviado por removido em 12/06/2004 - 17:50h

sua explicacao e boa , mas isso acontece pq sua rede determina como padrao (gw) a rota da placa interna
nao seria melhor route del default antes do adsl-start ?
route del default apaga a rota padrao
ai quando conectar o adsl-start determina a rota padrao fora da rede, ai nao precisa de determinar a saida sempre

[4] Comentário enviado por dmelorj em 12/06/2004 - 18:43h

silver_bit,

Pode até ser melhor com esse comando.. honestamente nao o havia testado e não o testei, mas se funciona fica como uma segunda opção pra galera... Pra mim que não tenho uma rede interna, apenas configuando o loopback acho que fica melhor pois basta depois ser digitado um único comando :-)

[5] Comentário enviado por CapitainKurn em 13/06/2004 - 13:07h

Ha uma solucao mais simples e mais adequada, algumas distros tais como o Red Hat Linux nao permitem durante a instalacao que vc. deixe a rota padrao desabilitada entao vc. tem, que fazer isso na unha.
edit o arquivo /etc/sysconfig/network comente, apague ou simplesmente coloque GATEWAY= (Isso mesmo, em branco)

[6] Comentário enviado por removido em 07/07/2004 - 21:38h

como consiguo configurar meu velox no kurumin 3 via usb no modem speedstream 5200 atualizado com firmware para ser roteador? Tem um lugar lá no discador modo texto que configura o velox automático mas pede o login e a senha e quando digito o login e senha ele fala que não é válido e fecha. É realmente o login e senha ou número de telefone?
Por favor me AAAJJJUUUDDDEEE!!!!!

[7] Comentário enviado por liviocf em 01/10/2005 - 20:05h

Amigo gabrielcampos, acho que vc tem que colocar primeiro é o número do seu telefone tanto pra login como para senha, pois esse é o padrão da velox (telemar) quando instala um ponto na sua casa!! Depois você autentica no browser com seu login e senha do seu provedor de internet!!

[8] Comentário enviado por oheremita em 29/12/2005 - 00:02h

Grande artigo!
Graças a ele e ao comentário do liviocf, estou com meu Slack 10.2 conectado ao velox.

Uma coisa foi diferente:
Neste e outros tutoriais que lí falam dos comandos <adsl-setup - adsl-start - adsl-status - adsl-stop>
No meu caso só funcionou com <pppoe-setup - pppoe-start - pppoe-status - pppoe-setup>

Parabéns pelo artigo!
Obrigado pelos comentários!
Felicidades!!!
T+

[9] Comentário enviado por dmelorj em 29/12/2005 - 20:26h

oheremita,
Sim, esses comandos foram mudados de "adsl-...." para "pppoe-..." na versão 10.2.

Abraços...


[10] Comentário enviado por ed_matos em 27/05/2006 - 19:50h

Caro amigo,sou novato no linux, sera que vc poderia me ajudar, a configurar meu moden velox, para me conectar ussando o linux,pq não consegui ainda configurar ele.
desde ja agradeço e aguardo resposta suas.
obrigado....

[11] Comentário enviado por colpo em 29/07/2006 - 02:07h

Meu amigo estou precisando de de sua ajuda, pois não estou conseguindo configurar minha ADSL, possuo um modem DSLINK 220UE
eu estava tentado acessar com o cabo USB, mas não consegui, agora estou tentando com o cabo de rede, estou trabalho com o slack de kernel 2.4.
obrigado

[12] Comentário enviado por sombriks em 14/09/2006 - 02:21h

hehehehe... finalmente a razão de tantos outros companheiros meus non conseguirem botar o Slack no ar no "modo bridge".

esse vai pros favoritos, com certeza!

[13] Comentário enviado por juliowotl em 17/10/2006 - 02:43h

Olha só... Meu modem DSL é um Speed Stream 5200... E eu preciso ligar ele no meu pc pela usb... O linux que eu uso é
o Fedora 5, e não detectou o modem pela usb... pelo jeito
ele não tem o driver... e eu devo precisar do driver pra
fazer o fedora reconhecer o modem... Alguém pode me ajudar?
Driver do modem, como instalar, tutorial, o que for!! =)
Blz? Valeuz! =)

[14] Comentário enviado por 4b3lj4d50n em 25/10/2007 - 01:22h

Galera eu to começamdo a usar o linux kurumim agorae estou com um problema com meu kurumin 7.0
acabei de intalar e aparece a pergunta de configurar a conexão:

Conectar via rede local, cabo ou ADSL com modem roteador
conectar com wireless
conectar via ADSL com atutenticação de PPPoE
conectar via modem discado
outro tipo de conecção
sair sem configurar

e eu nao estou sabendo configurar e colocar a opção correta
meu modem e roteado e eu tenho uma rede domestica + é só pra jogos e compartinhamento e tranferencia de arquivos do PC para o Notebook, nao tenho servidor pois nao há necessidade, meu modem é um d-link dsl-500b.

desde ja agradeço a colaboração de todos.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts