Navegando em modo texto com imagens

Acho que muitos devem conhecer o Lynx, um navegador de internet em modo texto. Fuçando um pouco (em minha hora de almoço viu chefe!) consegui navegar na internet em modo texto. Que que tem demais?! Imagens! Sim, eu estava vendo as imagens.

[ Hits: 134.917 ]

Por: Augusto Hagiro Pascutti em 25/04/2005


Problemas!!!!?



Se você encontrou alguns erros durante o processo, não desanime. Aqui estão alguns erros que podem ser encontrados e suas devidas soluções:

1 - Quando você vai tentar abrir o links2 como um usuário comum, você recebe um erro de permissão negada. Isso acontece porque você não tem permissão de usar o frame buffer; por isso, vamos permitir!

# chmod 666 /dev/tty0

2 - Pode acontecer do mouse não funcionar, vamos dar permissão para usar o mouse então:

# chmod 666 /dev/<porta do mouse>

Na maioria dos casos a porta do mouse é /dev/psaux, que é a porta PS/2.

Página anterior    

Páginas do artigo
   1. Mas como!?
   2. Lynx ou Links
   3. Mão na massa!
   4. Problemas!!!!?
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Warsaw no Fedora 28 funcionando - Internet Banking

Webconferência com OpenMeetings no Debian 5.0

Fuja da pirataria, use Last.fm

Dynamips + Dynagen - Emulando Vlans com router on stick no Linux

Aircrack-ng e sua família para quebrar WEP e WPA1

  
Comentários
[1] Comentário enviado por jalexandre em 25/04/2005 - 15:45h

Boa!! Gostei do artigo. Pequeno, porem útil! Valeu!

[2] Comentário enviado por tarcio em 25/04/2005 - 15:45h

super artigo, funcionou BLZ

[3] Comentário enviado por tarcio em 25/04/2005 - 16:04h

No MODO GRÁFICO ele funciona blz e abre uma janela com o links com suporte às figuras. Tudo blz.
Não consegui funcionar em MODO TEXTO propriamente dito, ele aprensenta o seguinte erro:

Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified

Could not initialize any graphics driver

Tried the following drivers:
x:
Can't open display ":0.0"

----------
Este teste foi feito sobre o connectiva 10

[4] Comentário enviado por fernandus em 25/04/2005 - 16:46h

muito bom, funcionou direitinho...

[5] Comentário enviado por mnoveli em 25/04/2005 - 16:58h

ola aqui funcionou legal boa a dica gostei valeu
suse 9.3 professional :)

[6] Comentário enviado por agk em 25/04/2005 - 17:25h

Legal, já havia testado esse navegador antes, mas não tinha funcionado. Mas agora com a opção -g funcionou legal. Parabéns pelo artigo.

[7] Comentário enviado por removido em 25/04/2005 - 17:45h

OPa!,

boa!, quando penso ja ter visto tudo eis que aparece mais uma huhaahuah, essa é muito boa!.

--
Abs,
guinet gmail com

[8] Comentário enviado por birilo em 25/04/2005 - 19:31h

links -g
Unknown option -g


[9] Comentário enviado por bicalho em 25/04/2005 - 20:05h

Tentei usar o lynx várias vezes mas sempre faltou este ponto "-g" para tornar minha navegação mais :-P ...

[10] Comentário enviado por streetlinux em 26/04/2005 - 00:04h

Bom artigo eim kra! Bem simples e direto! Parabéns!

[11] Comentário enviado por jorg3 em 26/04/2005 - 01:10h

Rpz

Uso o Slack já faz alguns anos e sempre instalava pelo que vi esse suporte, percebi esse fato ao testar o comando links -g. Se não fosse vc nunca iria notar isso e descubrar como o modo consegue ser surpreendente.

sds,

[12] Comentário enviado por cvs em 26/04/2005 - 07:39h

olha, eu posso até estar enganado, pq tbm não me deu o trabalho de procurar a respeito, mas creio que não seja bem o framebuffer o responsavel por isso, porque veja bem um exemplo, no FreeBSD mesmo, instalado em minha maquina há alguns meses atras, sem suporte a FB, pois minha placa de video não era suportada pra isso, eu conseguia navegar pelo links -g tranquilamente mas claro que com todos os pacotes do links e suas dependencias instaladas pelo ports.

[13] Comentário enviado por removido em 26/04/2005 - 07:55h

Neste link aí tem informações adicionais sobre esse assunto e outra coisas.

http://www.guiadohardware.net/kurumin/dicas/013/index.php#05

[]s!

Wesley Caiapó

[14] Comentário enviado por skfk em 26/04/2005 - 11:23h

top.. no Debian fica 'facin facin'..

[15] Comentário enviado por fernandus em 26/04/2005 - 12:40h

precisa ter o xwindow-system instalado?

[16] Comentário enviado por Kalib em 26/04/2005 - 12:43h

Putz...boa fuçada ein??
hauahuha...
Para ver como a hora do almoço pode serproveitosa!
Belo artigo parabés.

[17] Comentário enviado por tr3t4 em 26/04/2005 - 17:15h

aeeee frmz esse teu artigo, eu sabia que o lynx tinha mais do que um somples navegador modo texto, mas tb nunca fui atras...
parabéns pelo artigo

[18] Comentário enviado por luizcarcerelli em 26/04/2005 - 18:02h

Tentei no Ubuntu 5.04 e no CDD-Br, naõ funcionou em nenhum dos dois, não conseguiram abrir /dev/fb0, Por acaso o Debian vem com suporte a FB por padão? Se não como ativa-lo?

[19] Comentário enviado por agk em 26/04/2005 - 20:03h

Comigo também aconteceu isso, daí eu fiz o que foi sugerido no artigo:
#chmod 666 /dev/tty0
E funcionou numa boa.

[20] Comentário enviado por salamandras em 26/04/2005 - 20:07h

não esta localizando o (make) porriso não estala o programa oque fazer...

[21] Comentário enviado por luizcarcerelli em 27/04/2005 - 09:22h

Fiz o sugerido pelo agk mas continuou retornado a mesma mensagem de erro

[22] Comentário enviado por dexforni em 27/04/2005 - 13:17h

Mt chique esse artigo, bastante interessante pra mim que trabalho em uma empresa onde nao se pode usar internet....

[23] Comentário enviado por removido em 27/04/2005 - 18:22h

Dica super legal, porém, tentando rodar aqui da faculdade não consegui. O erro foi:

# svgalib: Cannot get I/O permissions

A linha para obter permissão para o buffer não resolveu este erro. Mas parabéns pela dica, vou testar em casa.

[24] Comentário enviado por hellnux em 28/04/2005 - 20:53h

E ae

ótimo artigo, nunca pensei que tinha um browser com esse poder :)
isso vai me ser bem útil

Mas com o comando "links -g <site>" não funfa, então o comando certo é :

$ links2 -g <site>

Flws..........

[25] Comentário enviado por Eagle em 30/04/2005 - 14:59h

Aew.
Muito interessante. mas não consegui testar ainda.
O meu da o seguinte erro:

svgalib: Cannot get I/O permissions.

Porém, eu jah tentei "# chmod 666 /dev/tty0" e não resolve. Alguma sugestão?

[26] Comentário enviado por hmn3d em 20/05/2005 - 17:32h

Consegui compilar mas não consigo executar em modo gráfico, dá a seguinte mensagem:

[henrique@localhost henrique]$ links -g
Could not initialize any graphics driver. Tried the following drivers:
fb:
Could not get VT mode.
[henrique@localhost henrique]$

Alguem sabe o que pode ser isso??

[27] Comentário enviado por hellnux em 20/05/2005 - 18:47h

Olá hmn3d

O comando certo, pelo aqui em ksa é :
$links2 -g www.vivaolinux.com.br

E nao o links como pensamos....

Abraços....

[28] Comentário enviado por hmn3d em 20/05/2005 - 19:10h

o comando links2 -g não funciona, aqui em casa é o links -g mesmo, mas acho que tá faltando alguma lib. A única que ele pediu na instalação foi a libpng, eu instalei e foi na boa, mas eu não tenho a libsvga e ele instalou assim mesmo. Vou instalar essa lib e ver se funciona.




[29] Comentário enviado por hellnux em 20/05/2005 - 19:26h

Olá....

Quando do o comando o comando <links -g> retorna o seguinte:

##################
kurumin@hellnux:~$ links -g www.vivaolinux.com.br
Unknown option -g
##################

Instale essa lib que esta faltando, se mesmo assim nao der certo pode ser alguma coisa realciona ao seu módulo de vídeo e até mesmo o frammebuffer do kerenl, isso é apensa um palpite, se fosse vc tentaria usar o módulo apropiado da sua placa de vídeo ou o "fbdev" ou "vesa" que são módulos genéricos.

Abraços


Abraços

[30] Comentário enviado por tiagoarcosta em 25/05/2005 - 12:29h

Olá Augusto.

Qual é o nome do arquivo tar.gz da TIFF Library. Poderia informar o caminho completo (link) até esta library para baixá-lo.

[31] Comentário enviado por ihtraum em 29/04/2006 - 02:26h

funfou !!
decente. ideal pra quando a conexão tá ruim.
o linux é show !!! como é que ainda existam pessoas que falam que o rWindows é melhor. NUNCA !!!!
viva o linux !!

[32] Comentário enviado por mafe.ura em 05/01/2007 - 08:24h

Pessoal aqui no meu serviço este comando funcionou legal so queria saber onde o links salva os downloads??
pois estou montando uma rotina de atualização de módulos do meu sistema q todos os dias tenho q entrar no site do pessoal q desenvolve osistema e baisxar os módulos novos. entaum eu estava pensando em usar o links para fazer isso

[33] Comentário enviado por aps167 em 26/02/2007 - 11:21h

Amigão,

Tentei navegar com imagens no Debian e não deu digitei

#links2 -g www.terra.com.br

e retornou a seguinte mensagem de erro:

(*) Single Application Core. (with MMX support) (2005-01-31 07:23)
(*) DirectFB/misc/memcpy: using MMXEXT optimized memcpy()
(!) DirectFB/core/fbdev: Error opening `/dev/fb0'!
--> Dispositivo inexistente
(!) DirectFB/Core: Could not initialize 'system' core!
--> Not supported!
(!) DirectFB/Core: Error during initialization (Not supported!)
[svgalib: allocated virtual console #7]

Aguardo um retorno seu obrigado.

[34] Comentário enviado por augusto_hp em 27/02/2007 - 15:11h

Cara, isso ae é que o kernel não tem suporte a frammebuffer (/dev/fb0)o único jeito é compilando um kernel novo com suporte a fb.

Não é muito difícil achar isso na internet; você não vai ter dificuldades; nem pra compilar o kernel e muito menos pra habilitar o frame buffer nele !

;D

[35] Comentário enviado por skylane em 04/10/2007 - 15:39h

aki quando tento abrir da o seguinte erro

Cannot open /dev/svga Is svgalib_helper module loaded ?

algue sabe como posso resolver isso?

[36] Comentário enviado por Lian em 30/12/2007 - 15:09h

Skylane

roda um

# modprobe svgalib_helper

[37] Comentário enviado por xerxeslins em 11/02/2008 - 00:44h

Fiz tudo o que vc disse e funcionou PERFEITAMENTE aqui no meu Slackware 12.0

Dica nota 10!

vou favorita-la ^^

[38] Comentário enviado por staltux em 25/07/2008 - 02:24h

eu to usando o seguinte aqui:
bash-3.1$ links -g -mode 400x600x256 www.google.com.br

mais t respondendo:

Not running in a graphics capable console,
and unable to find one.
Using nvidia driver, 65536KB, Type: GeForce (NV 18).
svgalib 1.9.25
Not running in a graphics capable console,
and unable to find one.

[39] Comentário enviado por staltux em 25/07/2008 - 02:31h

opa...eu tentei no tty1 onde nao ta aberto o X e funcionou...mas no rxvt e no konsole aberto dentro do fluxbox nao funcionou nao...

[40] Comentário enviado por k4mus em 26/07/2008 - 11:50h

no novo Slack 12.1 ja vem tudo pronto. So dar o links -g e boa navegacao ! :)

bom artigo amigo!

abraco

[41] Comentário enviado por Marcelo_Reis em 16/09/2008 - 19:30h

Excelente dica!
Estou escrevendo este comentário em modo texto mas com imagens graças a dica do augusto_hp.
Parabéns!!!

[42] Comentário enviado por gpr.ppg.br em 18/10/2008 - 02:16h

o meu só entra no usuario normal.
queria entrar com outro usuario.

exemplo:
teclo control + alt + F2
e entro no modo texto (mesmo)
$ links2 -g www.google.com.br

svgalib: Cannot get I/O permissions.

Porém, eu jah tentei "# chmod 666 /dev/tty0"
e não resolve.
Alguma sugestão?

queria usar isso como outro usuario e ficar baixando coisas...

que se o meu usuario travar
eu reinicio apenas o meu usuario
e não perco meus downloads.







[43] Comentário enviado por andrellucz em 10/12/2008 - 11:55h

Mandou muito bem.

T+

[44] Comentário enviado por augustoschwartz em 08/06/2011 - 16:50h

\o/ Instalou -> Abri algumas páginas...
Fuça, fuça...

Não rolou as imagens!
:'(


No terminal:

Graphics not enabled when compiling

-------------------
Ah, uso ubuntu 10.04 LTS atualizado hoje!
Mesmo assim achei muito bom. Obrigado pela sugestão!
-------------------


Já conhecem o "MC" navegador de arquivos em modo texto?

# aptitude install mc

É muito bom estou usando!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts