Instalando plugin do Java no Firefox 0.8

Quem nunca teve problemas ao acessar o site do Banco do Brasil pelo Firefox 0.8? Neste artigo espero ajudar estes que ainda tem problemas ao acessar sites com plugin Java.

[ Hits: 23.099 ]

Por: Wagner Ronieri França Costa em 04/07/2004


Introdução



Bom pessoal, este assunto sobre plugin do Java já está meio batido, mas nunca tinha conseguido instalar o bendito no meu Firefox 0.8. Já havia tentado vários tutoriais e artigos (inclusive alguns aqui do Viva o Linux), então fui tentando até conseguir.

Primeiro baixei o arquivo j2sdk-1_4_2_04-linux-i586.rpm.bin no site:
Depois foi só fazer o seguinte:

# chmod 777 j2sdk-1_4_2_04-linux-i586.rpm.bin

O próximo passo foi:

# ./j2sdk-1_4_2_04-linux-i586.rpm.bin

Dê enter até que ele peça para você digitar "yes", daí você verá que ele virou um pacote .rpm, então digite:

# rpm -ivh j2sdk-1_4_2_04-linux-i586.rpm

Ele instalará o pacote. Agora é só entrar no diretório do Firefox (que no meu caso está no /) e depois entrar no diretório plugins (exemplo: /firefox/plugins). Estando lá, crie o link para o plugin Java da seguinte maneira:

# ln -s /usr/java/j2sdk1.4.2_04/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so libjavaplugin_oji.so

Depois é só reiniciar o Firefox e acessar sites como o do Banco do Brasil normalmente.

Espero ter ajudado.
   

Páginas do artigo
   1. Introdução
Outros artigos deste autor

Instalando o Kylix 3 Open Edition no Red Hat 9

Cygwin, um Linux dentro do Windows

Leitura recomendada

Como traduzir Software Livre - Um método fácil

Proteja seu website ou página html com encriptaçâo

IBM apresenta Maqetta, uma contribuição open source para HTML5

Camada de Transporte TCP/IP e Aplicação

RSS - O antes e o depois já nas bancas!

  
Comentários
[1] Comentário enviado por y2h4ck em 04/07/2004 - 11:31h

Ae cara ... joga esse arquivo do J2sdk em algum lugar pq eu nao consegui achar esse que vc usou no site que vc passou nao ...
:/

[2] Comentário enviado por y2h4ck em 04/07/2004 - 11:35h

ah achei ... pqp o bagulho tem 33mb ahuahua :P

[3] Comentário enviado por wronieri em 04/07/2004 - 11:36h

em http://java.sun.com/ em popular donwloads clique em - J2SE 1.4.2 SDK

[4] Comentário enviado por jose_maria em 05/07/2004 - 09:38h

Cara, eu instalei o jsdk direitinho e fiz o link. Mas depois que eu fiz isso o firefox paraou de funcionar, eu clicava no link e ele não carregava. Depois eu apaguei o link que eu tinha feito, na pasta plugins, e tudo voltou ao normal. Alguem teve esse mesmo problema?

[5] Comentário enviado por cvs em 05/07/2004 - 11:22h

Só falo uma coisa :P
http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=806


[6] Comentário enviado por canaman em 05/07/2004 - 17:44h

Mas não dá pra acessar o banco do brasil usando certificaçao digital! Ainda não consegui no firefox nem no mozilla.

[7] Comentário enviado por deusdara em 08/07/2004 - 10:58h

Olá

A informação ficaria mais completa sobre a instalação do java se o colega informasse qual distro está usando.
A única informação que fica claro é que sua distro aceita instalar rpm.

E se é só para instalar o plugin java no firefox existe outro arquivo bem menor. Veja na página de download da Sun.

Abraços

Deusdará

[8] Comentário enviado por pools em 13/08/2004 - 20:32h

É o seguinte, no firefox 9.1 em Portugues, eu não consegui fazer o link simbólico, aliás consigo, só q o mesmo não funciona. Já com o firefox em inglês, versão 9.3, fazendo os mesmo passos, funciona.

[9] Comentário enviado por wronieri em 13/08/2004 - 23:47h

Legal pool não havia testado em outras versões valeu pelo toque vou testar...

[10] Comentário enviado por removido em 15/12/2004 - 18:38h

wronieri, brigado pela dica pois já estava quebrando a cabeça mas finalmente consegui acessar o site do bb, valeu!

[11] Comentário enviado por thiamolo-muito em 07/06/2005 - 11:59h

Meu firefox (peguei no help->about):
Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Meu sdk (peguei com java -version):
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-b09)
Java HotSpot(TM) Client VM (build 1.5.0_02-b09, mixed mode, sharing)

com comando (considerendo que eu to no dir de plugins do firefox):
ln -s /usr/java/jdk1.5.0_02/jre/plugin/i386/ns7-gcc29/libjavaplugin_oji.so ./libjavaplugin_oji.so

tava dando o problema de quando reiniciava firefox, nada dele aparecer e se deletava o link tudo voltava ao normal então procurei e achei este outro arquivo em outr dir
ln -s /usr/java/jdk1.5.0_02/jre/plugin/i386/ns7/libjavaplugin_oji.so ./libjavaplugin_oji.so

reiniciei e tudo oks agora funfando blz

(note que o pode ser utilizado somente o JRE, que é a maquina virtual do java, que roda os progamas em java, nao é preciso baixar o sdk que é pra quem quer desenvolver aplicacoes em java, com compilador e outras coisas desnecessarias) se a JRE do java ja vem instalado, como root de o comando:
find / -name *java*.so
isso ira retornar os arquivos de que contenham a palavra java com extencao de arquivo .so provavelmente sera um dos arquivos retornados (no meu caso:
/usr/java/jdk1.5.0_02/jre/plugin/i386/ns7-gcc29/libjavaplugin_oji.so
/usr/java/jdk1.5.0_02/jre/plugin/i386/ns7/libjavaplugin_oji.so
dai é só fazer o comando que mencionei acima que deu certo para mim ........ logico colocando o nome correto do arquivo .......
espero ter ajudado........falows ................

ps: aaaaaaahhhhhhhhhhhhh tem que fazer cadastro ....... que demora .............. só pq eu ja tinha escrito tudop antes de me ligar disse ;)

[12] Comentário enviado por gangrel171 em 24/10/2005 - 21:49h

Po estou com o debian sarge mais ainda não consegui instalar esse plugin, já instalei e reinstalei mas não sei por que algo deve estar errado, se alguém pude me ajudar a resolver esse pequeno problema de B.I.O.S. ( bixin ignorante operando sistema), me passando um tutorial voltado pro Debian eu agradeceria. PAZ!!!

[13] Comentário enviado por leandrorfb em 10/08/2006 - 11:51h

eu tenho o mesmo problema, estou usando o suse 10.1, eu estou tentando instalar o jova pelo smart, jogo o nome java e ele me da um monte de opções so que eu nao sei qual delas instalar?
e tambem nao sei se a necessidade de criar esse link simbolico se eu estiver instalando pelo smart....
obrigado

[14] Comentário enviado por alexside em 12/09/2006 - 14:08h

Boa tarde a todos,

segue:
p4 gigabyte, suse 10.1, flah (ok). segui os passos e não obtive sucesso... a página do bb não abre o teclado virtual e também na própria sun o teste não roda.

Sou iniciante, porém com o estudo e ajuda venho tendo sucesso.
Agradeço quem possa ajudar


Contribuir com comentário