Instalando o bugzilla no OpenSuSE 10.2

O Bugzilla é uma ferramenta Web para controle do ciclo de vida de erros (bugs) e de melhorias que vão surgindo ao longo do desenvolvimento de um projeto de software. Mostrarei neste artigo como instalar o bugzilla no OpenSuSE 10.2.

[ Hits: 25.953 ]

Por: Marcone Gledson de Almeida em 30/04/2007


Configurando o Apache



Caso não tenha o Apache instalado no seu servidor, execute o Yast e escolha a opção Serviços de rede ->Servidor http.

Será aberto um assistente (wizard) para configuração do seu servidor http (Apache), marque as seguintes opções:
  • Habilitado
  • Adicionar portas
  • Abrir as porta do firewall.

Escolha o item do Módulos do servidor e marque as opções:
  • CGI
  • PHP5
  • Perl

Agora escolha o item Host Principal e insira as informações do seu servidor como nome, e-mail, documento raiz (/srv/www/htdocs/), Directory (/srv/www/cgi-bin/).

Conclua a instalação pelo Yast e volte para um terminal (shell).

Crie o arquivo bugzilla.conf em /etc/apache2:

# touch /etc/apache2/bugzilla.conf

Insira o seguinte código no arquivo bugzilla.conf, utilizando qualquer editor de texto, no meu caso utilizo o vi.

# vi /etc/apache2/bugzilla.conf

<Directory /srv/www/htdocs/bugzilla>
  AddHandler cgi-script .cgi
  Options +Indexes +ExecCGI  +FollowSymLinks
  DirectoryIndex index.cgi
  AllowOverride Limit
</Directory>

Utilize o vi para abrir o arquivo httpd.conf:

# vi /etc/apache2/httpd.conf

Insira a seguinte linha no arquivo httpd.conf:

Include /etc/apache2/bugzilla.conf

Reinicie o Apache:

# rcapache2 restart

Página anterior     Próxima página

Páginas do artigo
   1. Requerimentos
   2. Configurando o Apache
   3. Instalando o bugzilla
   4. Instalando o bugzilla - parte II
Outros artigos deste autor

Gerenciando os seus códigos-fonte com um sistema CVS

Leitura recomendada

Ubuntu 7.10 "levinho" para PCs antigos

Apache 2.0 + PHP + PostgreSQL no Slackware

VPN com PPTP + DDCLIENT em Debian 5.0 Lenny com IP dinâmico

Configuração de uma impressora Z35 Lexmark usando o CUPS no Slackware 9.1

Deixando a inicialização do Slackware com kernel 2.6 totalmente gráfica

  
Comentários
[1] Comentário enviado por brunols em 02/05/2007 - 15:32h

Estou tendo este erro quando tendo rodar o checksetup:

Perl 5.008 required--this is only version 5.00503, stopped at ./checksetup.pl line 46.
BEGIN failed--compilation aborted at ./checksetup.pl line 46.
Caso alguem possa me ajudar me envia um e-mail [email protected]

[2] Comentário enviado por baxman em 02/05/2007 - 15:55h

Isto é porque a versão do Perl que você está utilizando é a 5.00503, sendo que, é necessário utilizar a Perl 5.008 ou superior.

Atualize os repositórios da SuSE (que já foi postado aqui no VOL) para depois via YAST, atualizar o seu Perl.

[3] Comentário enviado por brunols em 03/05/2007 - 08:58h

Baxman bom dia,

Atualizei a versão (This is perl, v5.8.7 built for sun4-solaris), sendo que, continuo com o mesmo problema: Perl 5.007 required--this is only version 5.00503, stopped at ./checksetup.pl line 46.
BEGIN failed--compilation aborted at ./checksetup.pl line 46.

Pode me ajudar ?


[4] Comentário enviado por baxman em 03/05/2007 - 09:26h

Bruno,

Você continua com o mesmo problema de incompatibilidade de versão do Perl.

Existem alguns versões do Perl que não são estáveis, por isso tente baixar a versão mais atual e estável do Perl em http://www.perl.com/download.csp.

Depois de baixar o arquivo, compile-o utilizando os comandos configure, make e make install.


[5] Comentário enviado por shocker em 03/05/2007 - 19:08h

Artigo muito bom. Parabéns!

[6] Comentário enviado por brunols em 08/05/2007 - 10:15h

Bom dia Galera !!

Agora estou apanhando devido ao erro: Illegal Instruction (core dumped) - Alguem já pegou este problema???


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts