Instalando o Qmail no RedHat 9

O compilador utilizado no RH9 é incompatível com versões anteriores, por isso para compilar o Qmail precisamos aplicar vários patches que serão descritos com detalhes. Vamos configurar contas POP3 com domínios virtuais e usuários duplicados, como: [email protected] e [email protected]

[ Hits: 79.459 ]

Por: ivan em 04/08/2003


Qmailadmin



O Qmailadmin é utilizado pelo nosso cliente para criar novas contas de e-mail do domínio, dentro do limite estabelecido pelo administrador, no painel do vqadmin. Mais detalhes do qmailadmin em http://inter7.com.

Com o qmailadmin criamos novos alias, redirecionamentos, bots, autoresponders, contas de e-mail pop, e varias outras funções.

cd /caminho/para/qmailrocks
tar zxvf qmailadmin-1.0.6.tar.gz
cd qmailadmin-1.0.6
./configure (./configure --help para mais opções)
make
make install-strip

As imagens são instaladas em /var/www/html/images, o meu domínio aqui, onde instalei o painel do qmailadmin fica em /var/www/html/painel e foi necessário mover a pasta de /var/www/html/images para /var/www/html/painel/images. Nenhuma imagem funciona dentro de cgi-bin. Provavelmente você mantenha os domínios virtuais dentro dos diretórios dos usuários /home/~user/www e somente o painel em /var/www.

Agora vamos abrir o navegador neste endereço:
  • http://seudominio.com.br/cgi-bin/qmailadmin
e você terá a tela de login do qmailadmin. Agora efetue login utilizando usuário postmaster e o domínio que foi criado no painel do vqadmin, crie novas contas de e-mail para o domínio, alias e forwards.

Tudo beleza até aqui... na próxima etapa vamos remover o sendmail, e criar links simbólicos para um "falso" sendmail do Qmail, assim outros programas que continuam utilizando o sendmail continuarão funcionando normalmente.

Página anterior     Próxima página

Páginas do artigo
   1. Download do pacote
   2. Mailing list EZmlm
   3. Autoresponder
   4. Vpopmail
   5. vqadmin
   6. Qmailadmin
   7. Removendo o sendmail
   8. Finalizando com o Qmail
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Integrando o Postfix + SpamAssassin + Fetchmail + Procmail + MS Exchange

Utilizando o pine com o fetchmail

Mutt - o melhor amigo do homem

Como acessar contas do Hotmail no seu cliente de e-mail Linux

Recuperando senhas de e-mails esquecidas usadas no Claws-Mail

  
Comentários
[1] Comentário enviado por ivan21 em 15/10/2003 - 22:32h

Para autenticar SMTP utilize o seguite script em /var/qmail/supervise/qmail-smtpd/run substituindo o atual do artigo.


#!/bin/sh
QMAILDUID=`id -u vpopmail`
NOFILESGID=`id -g vpopmail`
MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
LOCAL=`head -1 /var/qmail/control/me`
if [ -z "$QMAILDUID" -o -z "$NOFILESGID" -o -z "$MAXSMTPD" -o -z "$LOCAL" ]; then
echo QMAILDUID, NOFILESGID, MAXSMTPD, or LOCAL is unset in
echo /var/qmail/supervise/qmail-smtpd/run
exit 1
fi
if [ ! -f /var/qmail/control/rcpthosts ]; then
echo "No /var/qmail/control/rcpthosts!"
echo "Refusing to start SMTP listener because it'll create an open relay"
exit 1
fi
exec /usr/local/bin/softlimit -m 2000000 \
/usr/local/bin/tcpserver -v -R -l "$LOCAL" -x /etc/tcp.smtp.cdb -c "$MAXSMTPD" \
-u "$QMAILDUID" -g "$NOFILESGID" 0 smtp \
/var/qmail/bin/qmail-smtpd seudominio.com.br \
/home/vpopmail/bin/vchkpw /usr/bin/true 2>&1

[2] Comentário enviado por davialberto em 08/12/2003 - 10:02h

Eai, otimo artigo, parabens ....
cara travei nessa passagem:

Agora, o patch de autenticação SMTP:
mv qmail-smtpd.c qmail-smtpd.c.bak
cp /caminho/para/qmailrocks/patches/qmail-smtpd.c ./

Não consegui achar qmal-smtpd.c, dentro de /mnt/qmailrocks/patches, vc saberia me dar uma ajuda?????

[3] Comentário enviado por ivan21 em 08/12/2003 - 13:31h

Pode ter sido na hora de extrair os arquivos. utilize

tar -zxvf arquivo.tar.gz

novamente.

Observe que o arquivo antigo, foi renomeado para .bak, mas podera ser excluido.

Ivan

[4] Comentário enviado por ra.info em 13/12/2003 - 14:33h

$ dig @ns.servidor.com.br mail.dominiovirtual.com.br MX

você deverá ter algo como:

;; ANSWER SECTION:
ns.servidor.com.br. 81611 IN A 100.200.111.120


Vc poderia me indicar alguma coisa... esta linha não funciona

Fiz os procedimentos acima esta blz mais parou no qmailctl da erro no ´cade "$1" in ´PATH --- não consigo start e nem stop


Na linha de cima tentei digitar MX ou $ e o Red Hat 9 não esta respondendo .. o que faço ...fico no aguardo de alguma luz...

[5] Comentário enviado por ivan21 em 16/12/2003 - 10:08h

ra.info:

o comando é

dig @servidordns.com.br mail.dominio.com.br MX

para procurar por registros MX

não digite somente MX ou $.

use também:

man dig

para ver mais detalhes do dig...

[6] Comentário enviado por ra.info em 18/12/2003 - 11:19h

Estou com problema no qmailctl não consigo start,stop,cdb

quando digito sh qmailctl da a seguinte linha:

:comando not found
´:not a valid identifier `PATH
:comando not found
´mailctl: line 16: syntax error near unexpected token ´in
´mailctl: line 16: ´case "$1" in

Se for algum problema relacionado a DNS poderia me sugerir algum material para DNS/QMAIL

[7] Comentário enviado por jcsbarreto em 01/01/2004 - 17:55h

Não consigo achar até agora o arquivo para ser modificado: "Para autenticar SMTP utilize o seguite script em /var/qmail/supervise/qmail-smtpd/run substituindo o atual do artigo. "

Até agora está tudo dando perfeitamente. Estarei continuando a instalar o webmail e depois colocarei minha opinião.

Obrigado

Julio Cesar

[8] Comentário enviado por jcsbarreto em 01/01/2004 - 18:00h

Ao executar "http://www.seudominio.com/cgi-bin/vqadmin/vqadmin.cgi"

Apareceu os seguintes comentários na página web:

invalid language file d language file d language file d language file d language file d language file d language file d language file d language file d language file d language file d language file d language file d langua


vqadmin 2.3.2
(Este link leva para : "http://www.inter7.com/vqadmin.html")

vpopmail 5.2.1
(Este link leva para: "http://www.inter7.com/vpopmail.html"

O que fazer?

[9] Comentário enviado por jcsbarreto em 01/01/2004 - 19:11h

Não consigo encontrar o arquivo "E configurar RELAYING editando o arquivo /etc/tcp.smtp. Adicione a seguinte linha abaixo, substituindo o número ip pelo ip da sua máquina. "

Aonde encontro?

[10] Comentário enviado por ronner em 02/01/2004 - 22:02h

O artigo e muito bom, mais mesmo que vc preste muita atenção nos comandos sugeridos pelo autor, vc não conseguirar instalar o Qmail e deixar ele funcionando sugiro ao autor mais uma duas ou tres revisões e pronto, td dara certo.

[11] Comentário enviado por ivan21 em 20/02/2004 - 12:35h

não é possivel revisar, por isso colei alguns comentarios aqui, veja o arquivo qmail-smtpd/run por ex. que tem uma correção essencial anti-relay!

[12] Comentário enviado por neudimar em 18/03/2004 - 08:46h

Conforme o artigo instalando o Qmail tudo funcionau blz. menos o qmailadmin que da esse erro ai, alguem pode me ajudar.
meu email: [email protected]

[[email protected] qmailadmin-1.2.0]# make
make all-am
make[1]: Entering directory `/usr/local/src/qmailrocks/qmailadmin-1.2.0'
source='alias.c' object='alias.o' libtool=no \
depfile='.deps/alias.Po' tmpdepfile='.deps/alias.TPo' \
depmode=gcc3 /bin/sh ./depcomp \
gcc -I. -I/home/vpopmail/include -I. -I. -I. -g -O2 -c `test -f 'alias.c' || echo './'`alias.c
alias.c: In function `show_dotqmail_lines':
alias.c:81: `MAXALIASESPERPAGE' undeclared (first use in this function)
alias.c:81: (Each undeclared identifier is reported only once
alias.c:81: for each function it appears in.)
alias.c:209: `CGIPATH' undeclared (first use in this function)
alias.c: In function `show_dotqmail_file':
alias.c:291: `CGIPATH' undeclared (first use in this function)
alias.c:304: `IMAGEURL' undeclared (first use in this function)
make[1]: *** [alias.o] Error 1
make[1]: Leaving directory `/usr/local/src/qmailrocks/qmailadmin-1.2.0'
make: *** [all] Error 2

[13] Comentário enviado por neudimar em 18/03/2004 - 08:46h

Conforme o artigo instalando o Qmail tudo funcionau blz. menos o qmailadmin que da esse erro ai, alguem pode me ajudar.
meu email: [email protected]

[[email protected] qmailadmin-1.2.0]# make
make all-am
make[1]: Entering directory `/usr/local/src/qmailrocks/qmailadmin-1.2.0'
source='alias.c' object='alias.o' libtool=no \
depfile='.deps/alias.Po' tmpdepfile='.deps/alias.TPo' \
depmode=gcc3 /bin/sh ./depcomp \
gcc -I. -I/home/vpopmail/include -I. -I. -I. -g -O2 -c `test -f 'alias.c' || echo './'`alias.c
alias.c: In function `show_dotqmail_lines':
alias.c:81: `MAXALIASESPERPAGE' undeclared (first use in this function)
alias.c:81: (Each undeclared identifier is reported only once
alias.c:81: for each function it appears in.)
alias.c:209: `CGIPATH' undeclared (first use in this function)
alias.c: In function `show_dotqmail_file':
alias.c:291: `CGIPATH' undeclared (first use in this function)
alias.c:304: `IMAGEURL' undeclared (first use in this function)
make[1]: *** [alias.o] Error 1
make[1]: Leaving directory `/usr/local/src/qmailrocks/qmailadmin-1.2.0'
make: *** [all] Error 2

[14] Comentário enviado por felizate em 06/04/2004 - 17:39h

Ai pessoal instalei tudo mas quando faço qmailctl stop aparece as seguintes mensagens

[[email protected] qmailrocks]# qmailctl stop
Stopping qmail...

qmail-smtpd
svc: warning: unable to chdir to /service/qmail-smtpd: file does not exist
svc: warning: unable to chdir to /service/qmail-smtpd/log: file does not exist
qmail-send
svc: warning: unable to chdir to /service/qmail-send: file does not exist
svc: warning: unable to chdir to /service/qmail-send/log: file does not exist
qmail-pop3d
svc: warning: unable to chdir to /service/qmail-pop3d: file does not exist
svc: warning: unable to chdir to /service/qmail-pop3d/log: file does not exist

e quando faço qmailctl start

[[email protected] qmailrocks]# qmailctl start
Starting qmail...

svok: fatal: unable to chdir to /service/qmail-send: file does not exist
qmail-send supervise not running
svok: fatal: unable to chdir to /service/qmail-smtpd: file does not exist
qmail-smtpd supervise not running
svok: fatal: unable to chdir to /service/qmail-pop3d: file does not exist
qmail-pop3d supervise not running

Por favor estou desesperado

[15] Comentário enviado por felizate em 06/04/2004 - 17:39h

Ai pessoal instalei tudo mas quando faço qmailctl stop aparece as seguintes mensagens

[[email protected] qmailrocks]# qmailctl stop
Stopping qmail...

qmail-smtpd
svc: warning: unable to chdir to /service/qmail-smtpd: file does not exist
svc: warning: unable to chdir to /service/qmail-smtpd/log: file does not exist
qmail-send
svc: warning: unable to chdir to /service/qmail-send: file does not exist
svc: warning: unable to chdir to /service/qmail-send/log: file does not exist
qmail-pop3d
svc: warning: unable to chdir to /service/qmail-pop3d: file does not exist
svc: warning: unable to chdir to /service/qmail-pop3d/log: file does not exist

e quando faço qmailctl start

[[email protected] qmailrocks]# qmailctl start
Starting qmail...

svok: fatal: unable to chdir to /service/qmail-send: file does not exist
qmail-send supervise not running
svok: fatal: unable to chdir to /service/qmail-smtpd: file does not exist
qmail-smtpd supervise not running
svok: fatal: unable to chdir to /service/qmail-pop3d: file does not exist
qmail-pop3d supervise not running

Por favor estou desesperado

[16] Comentário enviado por micfer em 12/04/2004 - 09:23h

socorro, quando dou um start, aparece essa mensagem:
[[email protected] bin]# qmailctl start
Starting qmail
svok: fatal: unable to chdir to /var/qmail/bin/qmail-send: not a directory
qmail-send supervise not running
svok: fatal: unable to chdir to /var/qmail/bin/qmail-smtpd: not a directory
qmail-smtpd supervise not running

[17] Comentário enviado por sormany em 13/04/2004 - 18:16h

RESPONDENDO A ESTES ERROS:

[[email protected] qmailrocks]# qmailctl stop
Stopping qmail...

qmail-smtpd
svc: warning: unable to chdir to /service/qmail-smtpd: file does not exist
svc: warning: unable to chdir to /service/qmail-smtpd/log: file does not exist
qmail-send
svc: warning: unable to chdir to /service/qmail-send: file does not exist
svc: warning: unable to chdir to /service/qmail-send/log: file does not exist
qmail-pop3d
svc: warning: unable to chdir to /service/qmail-pop3d: file does not exist
svc: warning: unable to chdir to /service/qmail-pop3d/log: file does not exist


RESPOSTA:

Falta fazer os links que a apostila nao diz:

#ln -s /var/qmail/supervise/* /service/

[18] Comentário enviado por micfer em 15/04/2004 - 18:59h

Eu fiz tudo como diz, funcionou, consigo receber email, porém, não consigo enviar, quando tento enviar alguma msg, aparece isso:
Não foi possível conectar-se ao servidor. Conta: 'pop.witurbo.com.br', Servidor: 'smtp.witurbo.com.br', Protocolo: SMTP, Porta: 25, Segura (SSL): Não, Erro de soquete: 10061, Nº do erro: 0x800CCC0E

alguém pode me ajudar?

[19] Comentário enviado por ivan21 em 15/04/2004 - 21:34h

Parece que vc precisa desativar "Fazer logon usando autenticação de senha de segurança." na maquina cliente (outlook?).


[20] Comentário enviado por micfer em 16/04/2004 - 05:19h

sim, outlook, porém, não estava ativada, ativei somente por curiosidade agora, e não funcionou da mesma forma... não imagino oque seja...

[21] Comentário enviado por lechim em 23/04/2004 - 08:41h

Estou com a seguinte duvida, o qmail levanta o serviço mas se tento ultilizar o webmail do servidor não consigo logar as contas criadas.
A maneira pela qual tento logar é: [email protected] e a senha que inserir para este e-mail, ele sempre volta para a tela de autenticação.
O Webmail que ultilizo é o squirrelmail, alguem tem alguma sugestão?

[22] Comentário enviado por mario_mps em 23/04/2004 - 11:28h

Caros amigos, fiz todos os procedimentos necessarios para configurar o mesmo no redhat 9
porem qd executo o comando

[[email protected] qmail-1.03]#make setup check

ele apresenta o segunte erro

( ( ./compile tryvfork.c && ./load tryvfork ) >/dev/null \
2>&1 \
&& cat fork.h2 || cat fork.h1 ) > fork.h
rm -f tryvfork.o tryvfork
./compile qmail-local.c
./compile: line 3: exec: cc: not found
make: ** [qmail-local.o] Erro 127
[[email protected] qmail-1.03]#

oq esta acontecendo, alguem pode me dizer ???

Mario_MPS/RO

[23] Comentário enviado por niltongoliveira em 10/06/2004 - 03:16h

Quando fui testar o pop3 ele me deu a seguinte mensagem:
telnet mail.portaldascachoeiras.com.br 110
trying 200.97.21.10
Connected to portaldascachoeiras.com.br
Escape character is '^]'.
+OK POP3 [200.97+21.
.
10] v2001.78rh server ready
user [email protected]
+OK User name accepted, password please
pass teste
-ERR Bad login
Então ele não consegue fazer a autenticação...
A senha eu tenho certeza que está correta. Abri o arquivo e lá está a senha perfeita. O Interessante é que eu consigo enviar email, mas não consigo receber.
Obrigado
Nilton .'.
A.'.G.'.D.'.G.'.A.'.D.'.U.'.

[24] Comentário enviado por neudimar em 11/06/2004 - 11:26h

Ola Pessoal. devido a uma grande quantidade de pessoas que tiveram o mesmo problema que eu tive instalando o qmailadmin-1.2.0 resolvi postar isso aqui.
e so instalar a versao do qmailadmin-1.2.1 que o problema sera resolvido essa versao anteriror deve estar com bug.

aproveito para pedir para o autor postar uma dica de como instalar o sqwebmail pois estou tendo dificuldades ou se alguem tiver alguma dica por vavor envia no meu email. [email protected] Abraços.

[25] Comentário enviado por neudimar em 15/06/2004 - 09:55h

[[email protected] sqwebmail-3.5.0.20030301]# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK POP3 S2 v2001.78rh server ready
user [email protected]
+OK User name accepted, password please
pass teste
-ERR Bad login


ai pessoal reinstalei o qmail e tudo mais mas quando tento conecatar via telnet da esse erro ai -ERR bad login mas o usuario existe e a senha tambem.
e ta tudo certo a principio alguem pode me ajudar.

[26] Comentário enviado por serverfast em 20/08/2004 - 16:44h

Amigos, eu fiz a instalação deu tudo certinho.
só que realmente o arquivo smtpd.c não estava no qmailrock's
fiz uma busca no google e baixei de um site qualquer..

então instalei o vqadmin
tudo certinho no apache, fiz Htpasswd mudei o .ACL só deixei o admin * admin

mais o que acontece é o seguinte.
quando eu entro no sistema cgi-bin/vqadmin/vqadmin.cgi

ele fica pedindo a senha
eu coloco user: admin
e a senha que eu cadastrei mais não rola..

então não sei mais o que eu faço.

tem como eu deixar isso livre...
sei lá..
mudando no apache... ou em algo parecido !!

Atenciosamente.

Daniel...
Server Fast Solution's Provider

[27] Comentário enviado por serverfast em 20/08/2004 - 18:21h

COMO FAZER AUTENTICAR O SMTP ?

Att

Daniel

o primeiro comentário não funcionou !

[28] Comentário enviado por ezdn em 18/09/2004 - 22:33h

valeu ivan por ter postado este script
é um otimo script
eu gostaria de saber mais sobre as configurações avançadas do RedHat
para poder quem sabe postar artigos como o seu no futuro
pois vejo muito pouco material sobre configuração de serviços no RedHat
valeu cara
obrigada.

[29] Comentário enviado por mayconrem em 18/01/2005 - 16:13h

boa tarde ivan, eu possuo aqui na minha empresa qmail mas não consigo habilitar o protocolo imap para diminuir o fluxo da minha rede

vc sugere que eu faça alguma coisa?

obrigado

[30] Comentário enviado por removido em 07/05/2006 - 23:30h

Muito bom o artigo, mas acredito que ficou algumas coisa obscuras. Por exemplo, tive que instalar duas vezes. Na primeira vez que instalei estava tudo certo, porém, depois de 12 horas que havia instalado o tudinho o meu servidor estava sendo utilizado por algum hacker, estava enviando e-mails pelo meu servidor de e-mail. Tudo bem, por via das dúvidas instalei novamente tudinho e parou o problema, por enquanto. Agora o vqadmin não tém permissão para criar dominios, contas, etc. Estou fazendo isso através da conexão ssh, outrou problema é que só estou conseguindo enviar mensagens para e-mails do meu domínios, quando tento enviar mensagens para outro domínio por exemplo "[email protected]". A mensagem que o outlook dá é que o servidor recusou usuário... E o comentário sobre o smtp autenticado não funcionou não.... Obrigado e até mais....

[31] Comentário enviado por luisbertocco em 30/08/2006 - 16:35h

Estou instalando o qmail, quando eu rodo o comando,
chown -R qmail:root /var/log/qmail
Aparece um erro: usuario inválido
Sera que esta certo esse comando.

[32] Comentário enviado por cleitão em 28/12/2006 - 14:48h

Boa tarde pessoal,

gostaria de saber se alguém conseguiu acertar o problema do vqadmin que da as mensagens invalid language file d quando é feito o login....

Valeu a atenção!!!!!

[33] Comentário enviado por removido em 02/09/2007 - 23:06h

Este tutorial não está atualizado, e com alguns erros de procedimento. Eu segui este tutorial na minha distribuição (utilizei no Suse e no fedora) por 2 vezes e sempre dava erro... Depois que eu segui o tutorial do próprio site do qmailrocks (www.qmailrocks.org) tudo ocorreu prefeitamente bem e não houve um só erro. Estou com um servidor funcionando com 4 domínios e todos com seus e-mails em prefeito funcionamento... Aconselho a todos!

[34] Comentário enviado por derekbsb em 02/03/2009 - 09:36h

Bem Também segui o tutorial do qmailrocks e está funcinando, mas estou com um, problema pois já tinha um servidor que funcionava e tinha algumas listas de distribuições e gostaria de aproveitar alguém sabe como posso fazer isto?

[35] Comentário enviado por infortecpfz em 17/09/2009 - 14:08h

Parabéns pelo Artigo!

Me esclareça uma dúvida por favor! Eu preciso configurar um grupo de e-mail para meu domínio,
semelhante aos grupos do Yahoo! e Google Grupos, para quando eu enviar um e-mail para
@meudominio.com.br todos que tiveram conta cadastrada neste domínio receba a mesma
mensagem, poderia me auxiliar no mesmo por favor? Muito obrigado :wq



Fernando Santorsula

[36] Comentário enviado por derekbsb em 26/11/2010 - 13:16h

Olá estou com o seguinte erro, alguém pode me ajudar?
supervise: fatal: unable to acquire send/supervise/lock: temporary failure


Valeu galera do VOL


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts