Instalando o MySQL no Zope/Plone e criando uma pequena aplicação

Neste artigo aprenderemos como instalar o MySQL no Zope/Plone e acompanharemos a criação de uma aplicação usada para fazer consultas ao banco de dados.

[ Hits: 62.384 ]

Por: Fabio Rizzo Matos em 01/09/2004 | Blog: http://www.vindula.com.br


Instalando o MySQL-Python



Como o Zope/Plone utilizam a linguagem Python de desenvolvimento, é necessário instalar a API-DB do MySQL.

Acesse:
http://prdownloads.sourceforge.net/.../MySQL-python-1.0.0.tar.gz?download

Baixe o arquivo no diretório /tmp e execute os seguintes comandos:

$ cd /tmp
$ tar xvf MySQL-python-1.0.0.tar.gz
$ cd MySQL-python-1.0.0
$ export mysqlversion="4.0.20"

# Ou a sua versão instalada

$ export mysqlclient="mysqlclient_r"
$ export mysqloptlibs="ssl crypto"
$ python setup.py build
$ su
# python setup.py install


Pronto, se nenhum erro ocorreu, você já esta com o suporte do MySQL no Python. Vamos instalar agora o suporte no Zope/Plone.

Página anterior     Próxima página

Páginas do artigo
   1. Pré-requisitos
   2. Instalando o MySQL
   3. Instalando o MySQL-Python
   4. Instalando o ZMySQLDA
   5. Conectando ao banco de dados MySQL
   6. Rodando um SELECT simples
   7. Rodando um SELECT com critério
   8. Finalizando
Outros artigos deste autor

Criando formulários no Zope/Plone utilizando o banco de dados MySQL

Gerenciando registros em banco de dados com Zope

Introdução ao Python (parte 1)

Introdução ao Jython

Customizando o layout do plone

Leitura recomendada

Utilizando as bibliotecas do Java usando o Jython

Introdução ao Python (parte 2)

CMS Plone 4.1.6 com invólucro Virtualenv + Buildout + Mount Point + BLOB Storage + Unicode UTF-8

Escreva poemas com a sua linguagem de programação

Introdução ao Python (parte 1)

  
Comentários
[1] Comentário enviado por gmnvh em 14/02/2008 - 13:21h

Estou querendo instalar o zpopyda (que teoricamente serve para acessar o Postgre) no Zope 3.

Alguma idéia de como fazer isso ?

Valeu.

[2] Comentário enviado por gmnvh em 14/02/2008 - 14:09h

Na verdade meu Zope não é 3, errei !!! É o 2.10.5 ... Mas mesmo assim não consegui instalar o ZMySQLDA. Fiz conforme o artigo mas só aparece o Z Gadfly Database Connection.

Alguma idéio do porquê ?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts