Instalando o MySQL no Zope/Plone e criando uma pequena aplicação

Neste artigo aprenderemos como instalar o MySQL no Zope/Plone e acompanharemos a criação de uma aplicação usada para fazer consultas ao banco de dados.

[ Hits: 61.461 ]

Por: Fabio Rizzo Matos em 01/09/2004 | Blog: http://www.vindula.com.br


Pré-requisitos



Para utilizarmos o MySQL como banco de dados do Zope/Plone devemos instalar:
  • Python - Linguagem Para Execução do Zope
  • Zope - Servidor de Aplicação Web
  • Plone - Framework de CMS
  • MySQL - Banco de Dados
  • Python-MySQL - Interface para o Python acessar o MySQL
  • ZMySQLDA - Database Adapter para o Zope acessar o MySQL

O artigo Instalando um servidor Zope/Plone ensina como se instalar um Servidor com Python, Zope e Plone. Então caso tenha dúvidas de como instalar esse trio, acesse-o.

Neste artigo ensinarei como instalar o MySQL, o Python-MySQL e o ZMySQLDA, que são componentes necessários para executar aplicativos Python/Zope/Plone.

Vamos a instalação do MySQL!

    Próxima página

Páginas do artigo
   1. Pré-requisitos
   2. Instalando o MySQL
   3. Instalando o MySQL-Python
   4. Instalando o ZMySQLDA
   5. Conectando ao banco de dados MySQL
   6. Rodando um SELECT simples
   7. Rodando um SELECT com critério
   8. Finalizando
Outros artigos deste autor

Gerenciando registros em banco de dados com Zope

Introdução ao Jython

Utilizando as bibliotecas do Java usando o Jython

Instalando um servidor Zope/Plone

Criando formulários no Zope/Plone utilizando o banco de dados MySQL

Leitura recomendada

Customizando o layout do plone

FreeBSD + Zope/Plone, uma idéia frustrante?

Python, o curso (parte 1)

wxPython, uma biblioteca GUI multi-plataforma (parte 1)

Instalação básica do Plone 3 com Buildout no Linux

  
Comentários
[1] Comentário enviado por gmnvh em 14/02/2008 - 13:21h

Estou querendo instalar o zpopyda (que teoricamente serve para acessar o Postgre) no Zope 3.

Alguma idéia de como fazer isso ?

Valeu.

[2] Comentário enviado por gmnvh em 14/02/2008 - 14:09h

Na verdade meu Zope não é 3, errei !!! É o 2.10.5 ... Mas mesmo assim não consegui instalar o ZMySQLDA. Fiz conforme o artigo mas só aparece o Z Gadfly Database Connection.

Alguma idéio do porquê ?


Contribuir com comentário