GSlapt - Gerenciando os pacotes de seu Slackware

GSlapt é um front-end do slapt-get, com ele poderemos gerenciar, atualizar, instalar e principalmente se livrar da dor de cabeça que as dependências nos causam.

[ Hits: 23.792 ]

Por: Rafael Freitas em 19/01/2007


Instalação



Os requisitos básicos:
  • slapt-get
  • atk
  • glib2
  • gtk+2
  • pango
  • x11

1. Baixe o programa em:
2. Para instalar:

# installpkg gslapt-0.3.16-i386-1.tgz

Na próxima página veremos como o "bicho" funciona.

    Próxima página

Páginas do artigo
   1. Instalação
   2. Conhecendo os recursos do programa
   3. Instalando, atualizando e etc
Outros artigos deste autor

Atualizando o Slackware com SlackGrade

Como atualizar o Ubuntu Linux 8.04 (Hardy Heron) para 8.10 (Intrepid Ibex)

Leitura recomendada

RSS com o Superkaramba

Entendendo os codecs, os containers formats e por que o Ogg é tão bom

SeamlessRDP - Executando aplicações Windows

Personalizando seu lilo no Debian

Aprisionamento Tecnológico

  
Comentários
[1] Comentário enviado por wendelhp em 19/01/2007 - 15:02h

Cara, show de bola.

Estava pensando em utilizar o slap-get. Com este 'add-on', agora vou de vez. Abraços

[2] Comentário enviado por riick em 19/01/2007 - 18:26h

Muito bom o artigo, fica melhor pra fazer o update.

abraço.

[3] Comentário enviado por rgmmelo em 20/01/2007 - 01:59h

cara legal o seu artigo. eu estava pensando no final de semana passado em procurar algo parecido com o synapitc para o slack, dai lembrei que o slapt-get num funciona legal aqui, pois sempre que eu coloco os mirros do linux packages nunca acha nada, no entanto vou lá e baixo manualmente. No entanto vc já me popou de uma pesquisa, so falta descobrir porq não funciona legal o slapt-get no 10.2. alguem saberia, ou isso so ocorre comigo?

[4] Comentário enviado por rafaelfreitas em 20/01/2007 - 09:23h

primeiramente quero agradecer a todos que postaram os seus comentários, essa ferramenta realmente é incrível...

Para rgmmelo:

eu não conheço essa mirror do linuxpackages, mas como eu mencionei uso o site www.slacky.it ... kra os italianos atualizam mais rápido os pacotes do que o site do linuxpackages.
e como vc usa o slack .10.2 vc tem apontar para o endereço

http://www.slacky.it/download

se vc tmb usa o Gnome tmb tem q adcionar o endereço:

http://www.slacky.it/repository/gnome-gware

Qualquer dúvida de como configurar com as mirros de atualização entre no endereço:

http://www.slacky.it/index.php?option=com_content&task=view&id=125&Itemid=58

Lembrando... para quem vai usar o GSlapt não precisa configurar o slapt-get, basta adicionar as mirros como eu mencionei no artigo.

[5] Comentário enviado por removido em 20/01/2007 - 10:34h

thx cara!

[6] Comentário enviado por hakaguramercado em 20/01/2007 - 10:50h

cara só naw te dou um beijo pq naw tou te vendo!!,mas esse teu artigo é do caralho isso me deixa mais tarado pelo slackware!!!!!(quem usa a primeira vez nunca mais deixa ele isso é uma praga cuidado!!!)

[7] Comentário enviado por removido em 21/01/2007 - 12:46h

bom dia !!! gostei tanto do artigo q resolvi fazer aki no meu pc mas deu erro :

root@darkstar:/home/danilo# gslapt
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(gslapt:8156): Gtk-WARNING **: cannot open display:
root@darkstar:/home/danilo#


Estou usando Slack 11.0 e a instalação foi padrão


fala nisso meu sobrenome tem "Freitas" tbm, será q somos parentes ???

há, instalei o slapt-get e está tudo em ordem com ele,quer dizer até onde testei


fuiiiiiiiiiiiii

[8] Comentário enviado por rafaelfreitas em 21/01/2007 - 16:01h

Para eldred:

é quem sabe nós somos parentes... o sobrenome é do meu pai e a família dele é bem grande... moro em Duque de Caxias - Rio de Janeiro...

vou tentar t ajudar...
se vc instalou o slack 11, full(com todos os pacotes)???
dificilmente dará erro...
é só instalar o slapt-get - http://www.slacky.it/index.php?option=com_remository&Itemid=29&func=fileinfo&id=783

e depois o Gslapt - ver no artigo o link...

agora se vc instalou o slack 11 full parece q está dando um erro no GTK, eu mostro no artigo quais são as dependências para instalar o GSlapt..
uma delas é o gtk+2 que tem nos cd's de instalação do Slack 11 o nome do arquivo é gtk+2-2.8.20-i486.tgz

E SÓ FUNCIONA O PROGRAMA NO MODO GRÁFICO, OU SEJA, ABRA O KDE,FLUX,ETC E TAL... DEPOIS ABRA UM TERMINAL E DIGITE gslapt

tenta aê qualquer coisa mande um comentário... ok???

e não desista não, com o slack é assim mesmo.. é só ter paciência e força de vontade...

Abraços,

[9] Comentário enviado por rafaelfreitas em 21/01/2007 - 16:03h

para hakaguramercado:

qqq isso companheiro???
a ferramenta é muito foda mesmo, fico feliz em poder contribuir e tornar o slack mais fácil para quem está começando...

Abração kra...

[10] Comentário enviado por spawnlook em 21/01/2007 - 22:36h

só tem uma coisa q nunca vou entender:
pq o cara nao usa debian de vez? um slacker de verdade nao brinca de emular apt-get..

[11] Comentário enviado por pools em 22/01/2007 - 17:34h

Para o elred:
Pra executar a aplicação gráfica não pode ser como root! dê um exit que vai funcionar...

Para o spawnlook:
Pq o slackware com o o Gslap não tem dependência recursiva... e facilita para qualquer pessoa ter o slacky sem ter o requisito de ser um nerd.

[12] Comentário enviado por bcysne em 22/01/2007 - 21:33h

Eu tô com o mesmo problema do eldred, com o root dá o erro do gtk, com o meu usuário dá gslapt: command not found. Será que tem a ver com o PATH?

[13] Comentário enviado por bcysne em 22/01/2007 - 21:45h

Olha só, resolvi o meu problema de maneira bem simples:

1.- o gslapt fica no diretório /usr/sbin, ou edita-se o $PATH do usuário e digita o gslapt direto no prompt ou digita o caminho todo, /usr/sbin/gslapt.

2.- daí ele vai dizer que o seu usuário não tem permissão pra criar o diretório slapt-get no /var, então tem que alterar as permissões do /var pra funcionar.

Ah, outra coisinha, também tem que se ter permissão de escrita no diretório /etc/slapt-get, que é onde ficam as configurações dos mirrors, por exemplo.

Alterei o meu aqui e tá funcionando.

[14] Comentário enviado por rgmmelo em 23/01/2007 - 01:33h

para eldred:
cara sempre que eu queria abrir algo como root a partir do xterm dava ess prob, dai um dia me arreti e fui procurar na net como resolver isso, a causa eu não sei, no entanto, a solução sim(ao menos pro 10.2).
vamos à solução: como user normal, vc digita no terminal, xhost local:root . Dai vai aparecer essa mensagem " non-network local conections being control list
espero que tenha resolvido o seu problema!

[15] Comentário enviado por Grobsch em 23/01/2007 - 07:27h

Recentemente montei um repositório para o GoblinX e usei muitos dos scripts do Slacky.it para construir meus pacotes, eles são hoje um dos melhores sites sobre Slackware, é possível achar muitos programas.
Apenas quero acrescentar que as dependências ficam listadas no PACKAGES.TXT de alguns repositórios, nos padrões do Slackware este arquivo não traz dependências por isso tais repositórios NÃO podem ser usados para atualizações com checagem de dependências.
No repositório do GoblinX uso um PACKAGES.TXT com todas as dependências, e até agora tem funcionado bem melhor que o apt-get original, mas precisa ter mais testes.

[16] Comentário enviado por removido em 23/01/2007 - 20:52h

Aeee galera, valeu mesmo, tá funcionando legal !!!!!!

[17] Comentário enviado por lord_roxton em 02/02/2007 - 15:02h

Caro Rafael,
Pelos arquivos de instalação é possível ver que ele tem o locale para pt_BR, mas a interface não fica em português! Vc saberia como alterar isso?

[18] Comentário enviado por Warheart em 23/07/2007 - 02:32h

spawnlook

a única vantagem do debian em cima do slackware é essa: apt-get!

se os slackusers tiverem o privilégio de conseguir isso através do gslapt, não há mais o que o comparar com o debian!

bom, você deu sua opinião. A minha é essa ;)

[19] Comentário enviado por removido em 27/12/2007 - 00:50h

Existe alguma motivo para o Gslapt baixar os softwares selecionados a somente 8 k/s? Gostaria de saber se isso acontece somente aqui.

[20] Comentário enviado por rafaelfreitas em 27/12/2007 - 08:16h

Para wdmatheus,
cara tenta mudar o mirror aonde o GSlapt baixa os arquivos...
desabilite os q vem por default e coloque esse aqui

http://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.0/

OBS: se vc usa versão 12 do Slack

Qualquer coisa tem mais mirror's no link:

http://repository.slacky.eu/slapt-get.txt

Espero ter ajudado....

Feliz Ano Novo pra geral

Rafael Freitas.

[21] Comentário enviado por removido em 27/12/2007 - 13:18h

Muito obrigado pela ajuda Rafael, problema de velocidade resolvido. Somente os mirrors que apontam para os repositórios do Gnome Slack dão erro, todos eles, e gostaria de utiliza-los também pois tenho o Gnome instalado em meu PC.

Novamente muito obrigado por sua atenção e rapidez na ajuda Rafael.

Feliz Ano Novo.

[22] Comentário enviado por rafaelfreitas em 27/12/2007 - 16:51h

Blz Wendel, mas brother como vc instalou o Gnome?

Eu lembro q eu tmb tinha problemas para atualizar via GSlapt, como eu instalei o Gnome via Dropline os problemas com a lentidão foram para o lixo.

Tranqüilo qualquer dúvida manda um post ou email.. pode perturbar q estamos aqui pra isso....

Geral bombando com o pinguim em 2008!!!!!!!

[23] Comentário enviado por removido em 27/12/2007 - 17:52h

Então Rafael, instalei o Gnome-2.20.0 usando uma imagem iso, o GSlacky, projeto dos Italianos do Slacky.eu. Inclusive escrevi um artigo abordando a instalação:

http://vivaolinux.com.br/artigos/verArtigo.php?codigo=7345

Porém mesmo utilizando o projeto dos Italianos para instalar o Gnome, nem o mirror de repositório do Gnome para Slack do slaky.eu atualiza no gslapt. Sei lá, vou tentar deixar só o mirror para Gnome dos Italianos e atualizar pelo próprio slapt-get. Se resolver volto a postar um comentário.

Abraços.

[24] Comentário enviado por clodoaldops em 01/10/2012 - 22:12h

-cara, vou instalar o salix.os e esta dica me ajudou muito!
-brigaduuuuuuuuuuuuuu


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts