Flash 9 com som OSS

Você atualizou seu plugin Flash para o novo Adobe Flash 9 e descobriu que perdeu o áudio porque o plugin só funciona com ALSA? Se por algum motivo você utiliza drivers OSS, está feliz com eles e não gostaria de atualizar o kernel para obter o som novamente, esse é o caminho.

[ Hits: 17.826 ]

Por: Gabriel Knepper Mendes em 03/01/2007


Instalação do libflashpupport.so



Local do fonte:
Comando para puxar o fonte:

$ wget http://www.kaourantin.net/flashplayer/flashsupport.c

Comando para compilar:

$ cc -shared -O2 -Wall -Werror -licuuc -lssl flashsupport.c -o libflashsupport.so

(não deve emitir mensagem nenhuma)

Ver se todas as dependências estão satisfeitas:

$ ldd libflashplayer.so

Copiar para o /usr/lib:

$ sudo cp libflashplayer.so /usr/lib

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Instalação do libflashpupport.so
   3. Teste de São Tomé
Outros artigos deste autor

Balanceamento de carga entre 2 placas de rede

Leitura recomendada

Monitorando as conversas do MSN com SCANHILL

Conhecendo e testando vários navegadores de Internet

Configurando roteador Linux com Velox

Acesso remoto pela Internet de forma simples usando TeamViewer

Instalando o Asterisk no CentOS 5.3

  
Comentários
[1] Comentário enviado por crodrigo22 em 04/01/2007 - 00:52h

Mais eu uso Kubuntu tem alguma coisa para me ajudar estou sem som a meses e eu reinstalo o som ai vou ver um video ou jogar o som some alguém ai pode me ajudar por favor..

[2] Comentário enviado por hosmon em 26/04/2007 - 02:13h

Sou leigo em linux...
como sei se as dependências estão satisfeitas... ta... vc passo o comando, mas qual deveria ser o retorno para estar tudo certo?

[3] Comentário enviado por edirlf em 01/08/2007 - 20:22h

Amigo, não sei se pode me ajudar, mas quero fazer com que o som do flash saia em estações ltsp. Usando oss resolveria o problema? Já tenho todas as outras aplicações funcionando, só falta essa.

Um abraço.

[4] Comentário enviado por duda_syn em 10/05/2010 - 01:03h

cara atualizei pro flash 10 , ficou sem som meu google chrome ai usei tua dica voltou a funcionar o som... vlw show..
ab;ss


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts