Configurando o Slackware 12

Nesse artigo vou mostrar como configurar o Slackware 12.1. Dentre os itens descritos no artigo estão: driver de vídeo, som, reconhecimento de partições NTFS etc.

[ Hits: 39.903 ]

Por: Renato Leite em 16/08/2008 | Blog: http://www.vivaolinux.com.bbr


Configurando o idioma usado pelo KDE e driver de vídeo ATI/Nvidia



Configurando o idioma usado pelo KDE

Primeiro coloque o CD/DVD do Slackware no driver.

Entre no terminal e siga os passos:

"Entre" no CD/DVD:

# cd /media/cdrom

Entre no seguinte diretório:

# cd slackware/kdei

Instale o pacote com a tradução:

# installpkg kde-i18n-pt_BR-3.5.9-noarch-1.tgz

Depois de instalado, entre no centro de controle abra Regional & Acessibilidade e depois Pais/Região mande adicionar um idioma e escolha "Português do Brasil", selecione ele, salve e reinicie o Slackware, seu KDE vai iniciar em português.

Driver de vídeo ATI/Nvidia

Estou usando uma ATI x200 neste artigo.

Primeiro faça download do driver no site do fabricante com a extensão *.run". Depois basta dar permissão no driver:

# chmod 777 driver-*.run

E em seguida instalar:

# ./driver-*.run

Abrirá uma janela, agora basta ir escolhendo as opções que você acha apropriadas para sua placa de vídeo.

Pronto, reinicie seu Slackware e o driver já estará instalado.

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Configurando o idioma usado pelo KDE e driver de vídeo ATI/Nvidia
   3. Som e reconhecendo partições NTFS
   4. Adicionando usuários, fontes do Windows e interface no login
   5. Slackpkg
Outros artigos deste autor

Configurando o Arch Linux

Arch Linux + NetBeans + MySQL + Oracle 10g

Leitura recomendada

UNR (Ubuntu Netbook Remix) 9.04 no Acer Aspire One (AA1)

Guia do Desktop Redondo - Fedora 7

Dúvidas freqüentes após instalação do Linux

Driver Nvidia atual + Ubuntu + Beryl

Aplicações Windows em ambiente Linux com SeamlessRDP

  
Comentários
[1] Comentário enviado por tekmania em 16/08/2008 - 20:45h

Muito bom o artigo, mas faltou isso:

# xauth merge /home/~seu_usuário/.Xauthority

isso faz resolve esse problema:
Xlib: connection to ":0.0" refused by serve

[2] Comentário enviado por removido em 16/08/2008 - 22:52h

muito bom !!!!!!!!!

[3] Comentário enviado por fco em 16/08/2008 - 23:04h

Bom mesmo!!!

Mas já que estou comentando :), acho que é bom deixar claro que a escolha de repositórios do slackpkg deve (preferencialmente) ser de acordo com a versão que se está usando. Ex. se esta usando o 12.1, escolhe-se

ftp://ftp.slackware-brasil.com.br/slackware-12.1/

Não há nada de errado em se usar o -current, desde que se tenha em mente que está é uma versão de testes - nem tudo pode funcionar perfeitamente (mas eu, particularmente nunca tive problemas :)).

[4] Comentário enviado por mafioso em 17/08/2008 - 03:31h

ótimo artigo, kra! O slackware tá cada vez mais fácil de usar, pois cada novo lançamento, melhor ele vem ficando. E artigos como o seu são ótimos para espantar o "fantasma" que todos acham que é o slackware. Instalou e utilizou suas dicas, o usuário já estará com o Slack prontinho para funcionar.

[5] Comentário enviado por renato.leite em 17/08/2008 - 08:38h

Vlw aew pessoal, espero ajudar muitos usuários com esse artigo xD

[6] Comentário enviado por kalib em 18/08/2008 - 09:14h

Show de bola amigo..parabéns pelo artigo. ;]

A propósito..alguém mais aqui viu a nova logomarca do slackware? E alguém mais aqui não gostou dela? Ou fui apenas eu...achei péssima a idéia de mudar uma logomarca que já tem tantos anos de estrada..e ainda mais para uma tão diferente...achei feia..e poluída...pouco legível.. :/

[7] Comentário enviado por gleison/slack em 20/08/2008 - 11:17h

Gostei do artigo , simples e direto como o slack , parabens !


[8] Comentário enviado por grandmaster em 25/08/2008 - 21:03h

Gostei tb

Bem direto

Renato de Castro Henriques
CobiT Foundation 4.1 Certified ID: 90391725
http://www.renato.henriques.nom.br

[9] Comentário enviado por carlinhus em 29/08/2008 - 18:49h

Boa noite a todos,

Estou tentando instalar a o drive mais recente da Nvidia (NVIDIA-Linux-x86-173.14.12-pkg1.run) no slack 12.1 recem formatado mas esta ocorrendo erros durante o inicio da instacao.
Abaixo descrevi como fiz se estiver errado por favor me corrijam.
1. baixei o drive do site da nvidia.
2. apertei ctrl+Alt F2 e em seguida digitei o logim e a senha de root
3.digitei init 3
4. fui para o diretorio onde encontra o arquivo .rum e executei o comando ( sh NVIDIA-Linux-x86-173.14.12-pkg1.run , tentei tambem sh NVIDIA-Linux-x86-173.14.12-pkg1.run -q ) mas me retornou o seguinte erro:
5. ERROR: You appear to be running an X server; please exit X before installing. For
further details, please see the section INSTALLING THE NVIDIA DRIVER in the
README available on the Linux driver download page at http://www.nvidia.com.
6. ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log'
for details. You may find suggestions on fixing installation problems in the
README available on the Linux driver download page at http://www.nvidia.com.
7. fui em /var/log/nvidia-installer.log e abri-lo mas como sou novo em linux entendi que esta tudo errado, mas nao sei o que. o arquivo e esse:
(nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Aug 29 20:35:10 2008
installer version: 1.0.7

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : true
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '3026'
of a runnning X server.)

E mesmo apos fazer o que vc diz acima retorna o mesmo erro.

Se alguem puder me ajudar agradeco muito. Vlw...

[10] Comentário enviado por renato.leite em 30/08/2008 - 09:51h

cara faz o seguinte... quando for instalar o driver não saia do X, ou seja instale o driver pelo terminal...

ai voce fica dentro do X normal abre o terminal e executa o driver assim ./driver.run

que ele ja vai funcionar... se não funcionar posta aew x]

[11] Comentário enviado por corvolino em 05/09/2008 - 08:52h

So achei esquisito algumas coisas.. quando se instala o slack ele vem em us, na parte de configuração do teclado você
diz o caminho em pt_BR =P

e na parte de reconhecer ntfs você utiliza o ntfs-3g e em nenhum momento nem cita o nome dele no tutorial :P

No demais ta rlx ;D

[12] Comentário enviado por zunity em 28/09/2008 - 19:05h

aqui deu certo....

vlw...


Contribuir com comentário