Configuração de impressora Lexmark Z25-35

Sempre utilizei impressoras Lexmark, a única exceção à esta regra foi uma LX300 que não era jato de tinta e tinha um bom motivo para utilizá-las: o suporte a Linux. Sim, parece brincadeira, mas o suporte a Linux vem estampada nas caixas dessas impressoras, pelos menos em alguns modelos.

[ Hits: 27.131 ]

Por: Ricardo Rabelo Mota em 06/05/2006


Descompactando e instalando



Descompacte o arquivo com um:

# tar -xvzf CJLZ35LE-CUPS-2.0-1.tar.gz

Cuidado! Não será criado nenhum diretório. Os arquivos serão extraídos diretamente no diretório corrente. Caso ache melhor, crie um diretório vazio, copie o arquivo compactado para ele e depois faça a extração.

Serão descompactados dois arquivos, um executável com extensão .sh e outro .txt. O txt possui algumas informações sobre o arquivo e método de instalação. O com extensão .sh pode ser executado com:

# ./lexmarkz35-CUPS-2.0-1.gz.sh
ou
# sh lexmarkz35-CUPS-2.0-1.gz.sh

Espera-se dois resultados distintos: um instalador gráfico, feito em TCL/TK, que poderá funcionar ou não, dependendo se você tiver as bibliotecas TCL e TK instaladas. Depende também da versão das bibliotecas, pois mesmo instaladas, o instalador gráfico poderá não funcionar.

Pode acontecer de ser executado um instalador em modo texto, por isso recomenda-se a execução desses passos em um terminal dentro de um ambiente gráfico, para evitar problemas. Tanto o instalador gráfico ou texto são bem simples de utilizar. Fazem poucas perguntas, tipo se você quer utilizar a impressora como padrão, localização (Brasil) e oferece para imprimir páginas de teste.

Página anterior     Próxima página

Páginas do artigo
   1. Obtendo o driver
   2. Descompactando e instalando
   3. Problemas...
   4. Mais problemas (Mandriva 2006)
   5. Debian e últimos detalhes
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

HOWTO - Usando PSP no Gentoo Linux

Fedora Core 1 :: Starter Kit

Instalando Cacti no Debian 5.0

Slapt-get 0.10.2s - Conceitos Básicos

Criando mirror do Debian Lenny e Debian Lenny Security em sua rede local

  
Comentários
[1] Comentário enviado por removido em 06/05/2006 - 08:59h

libstdc++5 - http://rpm.pbone.net/index.php3/stat/4/idpl/2761820/com/libstdc++5-3.3.6-2mdk.i586.rpm.html
================
"Pode acontecer de, na instalação, reclamar de alguma dependência. Se você tiver certeza de que os arquivos instalados estão no seu sistema, utilize: " - se isto acontecer, INSTALE as dependencias pois os pacotes existentes no sistema não atenderão ao driver.
==============================

[2] Comentário enviado por mpinho em 06/05/2006 - 15:42h

No Mandriva 2006 basta instalar o pacote libstdc++5 com

urpmi libstdc++5

Esse pacote está na mídia contrib e basta ela estar configurada no sistema. Como fazer isso ? Veja

http://www.mandrivabrasil.org/site/content/view/13/29/

[3] Comentário enviado por ricardorrm em 06/05/2006 - 22:01h

Quanto às dependências, acvsilva, a única que senti realmente falta foi a da libstdc++5. Fora isso, nunca tive problemas em outras distros que já experimentei, com exceção para a Biglinux 2.1. Já no Mandriva, consegui a dica no clube. Lá não falava diretamente sobre a libstdc++5, mas ensinava um comando (o qual não me lembro mais) para executar o cups e conferir se a instalação tinha sido ok. Ao executar esse comando, surgiu a mensagem da libstdc++5. Depois que a instalei, ainda com o Mandriva 2005, funcionou beleza.
Manoel, nos quatro cd's do Mandriva (2005) do clube, acredito que já tinha o arquivo. Acho que não foi preciso configurar a mídia contrib. Um abraço.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts