Como configurar o dispositivo Wireless LG LW2110P chipset rtl8180 no Slackware 10

Esse artigo mostrará, de forma simplificada, como configurar o dispositivo Wireless LG LW2110P chipset rtl8180 (Realtek) no Linux. Essa é uma tarefa onde muitos usuários ainda tem muitas dúvidas acerca da correta configuração. Então vamos lá!

[ Hits: 37.089 ]

Por: Humberto Silva Galiza em 14/11/2004


Conectando ao provedor pelo PPPoE



Amigos, na minha cidade uso autenticação via wireless, não sei se é o caso de vocês, mas irei mostrar como faço.

Como uso o Slackware, ele já vem com o pacote PPPoE, mas se não tiver baixei-o em:

http://www.roaringpenguin.com/penguin/pppoe/rp-pppoe-3.5.tar.gz

$ tar -zxvf rp-pppoe-3.5.tar.gz
$ cd rp-pppoe
$ make
$ su
# make install
# adsl-conf


Aqui começa a configuração do PPPoE.

É so ir seguindo as instruções e colocar: nome de usuário, senha e o gateway do seu provedor.

Após isso digite:

# adsl-start

Isso fará iniciar o serviço e use "adsl-stop" para parar.

Para o processo ficar automático coloque o comando "adsl-start" no arquivo /etc/rc.d/rc.local.

Espero ter ajudado.

Abraços!!!

Página anterior    

Páginas do artigo
   1. Arquivos necessários e instalação
   2. Conectando ao provedor pelo PPPoE
Outros artigos deste autor

Macromedia Studio 8 (Dreamweaver + Flash + Fireworks) no Debian usando o WINE

Leitura recomendada

Como Instalar Seu Adaptador WiFi RTL8821 No GNU-Linux

Como instalar driver da placa wireless no notebook Asus Eeepc com Ubuntu / KUbuntu

Explorando a máquina sem abrí-la

Utilização de termômetro de ambiente com conexão USB no Debian

Clonagem de Hardware Hotline em Software Livre

  
Comentários
[1] Comentário enviado por removido em 15/11/2004 - 18:38h

Arrebentou a boca do balão, o jovem!!! ;-))

[2] Comentário enviado por removido em 09/12/2004 - 12:41h

Wopa
Funcionou perfeito numa placa Plannet WL-3553 que usa esse chipset da rtl8180.
O ndiswrapper funciona apenas com placas PCMCIA ou com outros dispositivos?

[3] Comentário enviado por alluring em 19/12/2004 - 19:50h

cara... muito bom o artigo, foi o primeiro artigo que conseguir fazer para minha placa pegar sinal de internet, porém eu uso uma placa planet wl-8303, e n consegui navegar na net mesmo com sinal...
o utilitario de configuração de wifi fica lá dando as informações q ta com sinal conectado na rede: setorial, mas só q n navega na net. vc poderia me ajudar ????

[4] Comentário enviado por DiegoR0dr1gu3s em 31/12/2004 - 16:04h

era o que eu precisava!!! instalei internet via rádio aqui em casa e só acessava pelo rwindows xp, estava procurando o driver para a placa com chipset realtek que veio no kit pra conectar via linux. graças a sua ajuda consegui achar o driver, instalá-lo e acessar tranquilamente, porém, como eu ainda estava baixando o slack 10 pelo rwindows, todo o procedimento foi feito no mandrake 10.1 e tudo deu certo. ah! só para informar, no adsl-setup, usei a interface wlan0 e funcionou corretamente.

quanto ao comentário enviado por alluring em 19/12, provavelmente deve ser configuração de firewall ou dns. no adsl-setup (ou config) escolha a opção "server" para DNS.

[5] Comentário enviado por andre2005 em 16/01/2005 - 19:02h

blz
fiz ate onde vc disse mas e agora? onde configuro o ssid? a chave de rede?
alguem me ajuda por favor...
grato pela atenção desde ja

[6] Comentário enviado por r3dh0t em 19/01/2005 - 07:25h

Andre 2005, cara o ssid e a chave de rede vc configura no wlan.conf. O meu aqui está na pasta /etc/wlan/wlan.conf.
Espero ter ajudado.

r3dh0t

[7] Comentário enviado por kaapaa em 26/02/2005 - 00:51h

Gentem,

qual seria o erro (ou comida de bola minha) se qdo entro
com o comando
# modprobe ndiswrapper

nada acontece?????

obrigado!

[8] Comentário enviado por santananeto em 27/02/2005 - 16:33h

Quando digito #modprobe ndiswrapper nada acontece tambem, outra coisa no /etc/modules.conf: eu adiciono a linha com eth0 ou wlan0?
Obrigado

[9] Comentário enviado por steel_dragon em 14/03/2005 - 13:49h

Comigo também quando eu dou #modprobe ndiswrapper nada acontece e eu estou usando o versão 1.1 dele ! Alguém pode me ajudar a configurar essa placa corretamente no Slackware 10 ?


Muito obrigado a todos :-)

[10] Comentário enviado por santananeto em 22/03/2005 - 02:09h

Ainda continuo com o problema:
Quando digito #modprobe ndiswrapper nada acontece tambem, outra coisa no /etc/modules.conf: eu adiciono a linha com eth0 ou wlan0?
Quem puder me ajudar, to tentando migrar de vez pro linux, mas o que me prende ao rwindows é a internet.
Agradeço se puderem me ajudar.

[11] Comentário enviado por removido em 14/04/2005 - 15:32h

Olá, aproveitando o ndiswrapper, seria interessante se desse também para emular drivers do windows para estes winmodems e softmodems que têm por aí. Isto com certeza acabaria com muita dor de cabeça de quem usa acesso discado. Se alguém souber de alguma coisa, por favor me avise.

[12] Comentário enviado por Mister_Sevla em 22/10/2005 - 14:39h

Tentei fazer o procedimento no CTIVA 10 mas parei no seguinte erro: (sou newbie)

infra
./wlanup: line 23: /sbin/iwpriv: Arquivo ou diretório não encontrado

./wlanup: line 24: /sbin/iwpriv: Arquivo ou diretório não encontrado

./wlanup: line 54: /sbin/iwpriv: Arquivo ou diretório não encontrado

./wlanup: line 55: /sbin/iwpriv: Arquivo ou diretório não encontrado

./wlanup: line 121: /sbin/iwpriv: Arquivo ou diretório não encontrado

./wlanup: line 129: /sbin/iwpriv: Arquivo ou diretório não encontrado

SIOCSIFADDR: Dispositivo inexistente
wlan0: interface desconhecida:
Dispositivo inexistente
wlan0: erro obtendo informações da interface:
Dispositivo não encontrado

Além disso o comando MAKE INSTALL ou mesmo só o MAKE não funcionado dá isso aí:

[root@crop ndiswrapper-0.11]# make INSTALL
bash: make: command not found




[13] Comentário enviado por c065718 em 05/01/2006 - 08:46h

Será que serve para o Kurumin?

[14] Comentário enviado por r3dh0t em 05/01/2006 - 09:06h

rpz ja testei do debian-sarge com kernel 2.4...provavelmente sirva no kurumindows ehehehe
nota: com kernel 2.6 n funfou no debian...
abraço!

[15] Comentário enviado por PeQuEnO_TuX em 02/02/2006 - 08:05h

A respeito do comando modprob ndiswrapper, tambem tive o mesmo problema mas fui dentro da pasta no meu caso /home/regin e dei o comando a partir dai q deu certo, ou seja so vcs da o comando a partir de onde esta a pasta do ndiswrapper. espero ter ajudado...


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts