Balanceamento de carga com 2 links no MikroTik

Olá pessoal, como o MikroTik vem se destacando na parte de gateway e tem muita gente que usa dois ou mais links de internet, vou postar uma maneira de balancear estes links de maneira a ter um melhor desempenho.

[ Hits: 188.490 ]

Por: Raniel Guimaraes em 19/05/2008


Testando se o nosso balanceamento está trabalhando direitinho



Terminada a configuração do MikroTik, vamos tirar a prova se está mesmo com queremos.

Num cliente configurado para acessar a partir do grupo A, façamos o seguinte teste:

Em um terminal: c:\>tracert -d 200.221.2.45 (ip da uol.com.br, mas pode ser um de sua escolha).

Verifique se ele retorna o ip do isp #1

Tipo:

C:\>tracert -d 200.221.2.45
Tracing route to 200.221.2.45 over a maximum of 30 hops

  1     2 ms     2 ms     2 ms  192.168.10.254
  2    10 ms     4 ms     3 ms  isp #1

Façamos um mesmo teste num cliente configurado para o grupo B:

C:\>tracert -d 200.221.2.45
Tracing route to 200.221.2.45 over a maximum of 30 hops

  1     2 ms     2 ms     2 ms  192.168.10.254
  2    10 ms     4 ms     3 ms  isp #2 

É isto aí, qualquer coisa...

Página anterior    

Páginas do artigo
   1. Cenário de nosso artigo
   2. Criando as rotas para os grupos
   3. Testando se o nosso balanceamento está trabalhando direitinho
Outros artigos deste autor

MikroTik + Squid 2.6 com cache full

Instalando o gerenciador de Lan House no Linux

Café com leite, gerenciador de lan house e cyber café

Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio)

Leitura recomendada

"Usando" 2 Slackwares instalados no mesmo HD - O problema: vmlinuz

Instalação e configuração do Bacula com interface web (Bweb/Brestore)

NFS sem segredos

Impressora Lexmark USB no Slackware 10.2

Apache 2.0 + PHP + PostgreSQL no Slackware

  
Comentários
[1] Comentário enviado por foxl em 20/05/2008 - 10:32h

ok.
imagine a seguinte situacao.
tenho um link A e o link B.

quero um script que der um downnn no link quando cair.
ex: se o A cair logicamente ficara so o B quando o link A voltar queria que ele desse um down entendeu?

[2] Comentário enviado por foxl em 20/05/2008 - 10:35h

e e aa principioo te um erro no teus grupos.

No nosso caso, como queremos dividir em apenas dois grupos, ficará desta forma:

* Group A: 192.168.10.0/25 que será de 192.168.10.0 - 192.168.10.127;
* Group B: 192.168.10.128/25 que será de 192.168.10.128 192.168.10.255.





[3] Comentário enviado por walteramelo em 23/08/2008 - 23:00h

Ola me ajuda pelo amor de deus quando instala o hotspot para tudo,
ajuda-me a fazer para usar com hotspot estou
tentando há semanas e não funciona. Grato.

email: joao3333@bol.com.br

[4] Comentário enviado por Stayling em 05/10/2008 - 04:28h

Não sei se o que fiz está correto, mas andei lendo, pesquisando e acabei fazendo o que achei mais correto em balanceamento de LINKS... ADSL/ADSL.. Desta forma que vou postando as imagens não se divide em GRUPO A ou GRUPO B, determinando de tal a tal ip será GRUPO A e de tal a tal IP será o grupo B...

Bom, vejam ai, caso queiram dpois faço o script...

http://img509.imageshack.us/img509/1193/mk1xz3.th.jpg

http://img504.imageshack.us/img504/3536/mk2rg4.th.jpg

http://img508.imageshack.us/img508/1060/mk3ih8.th.jpg


[5] Comentário enviado por fabiozero em 08/06/2009 - 00:20h

bom o artigo,

preciso do seguinte:

tenho um link ( eth1 - telefonica )
rede local ( eth2 - rede local )
eth3 desabilitada

queria colocar mais um link em eth3 e realizar um balanceamento de carga com o eth1

tipo:eth 2 rede local ( range 10.0.1.1 - 10.0.1.254 ) gw link eth1
eth2 rede local ( range 10.1.1.1 - 10.1.1.254 ) gw link eth3

mas quando o link eth1 cair, passar direto para o eth3, e se ele voltar, continuar no eth1.

se der p ajudar msn: fabiozeronunes@gmail.com

[6] Comentário enviado por valteirsf em 01/07/2009 - 21:14h

Olá pessoal.
Será se daria pra colocar por exemplo 5 links de 1mb, tranformar esses 5 links em apenas 1 link de 5mb?

[7] Comentário enviado por Ronny_Santos em 14/01/2010 - 06:39h

Quando uso o cache full (web proxy), este balanceamento nao funciona;

[8] Comentário enviado por winnet em 17/07/2010 - 20:06h

Amigo preciso muito de uma ajuda sua!
Vc esta de parabens pelo post.
O balanceamento funcionou 100% aqui no meu teste, o problema é o seguinte: Preciso criar no mikrotik dois discadores de VPN
CLIENTE PPTP so que depois que fecho o loadbalance dessa forma o mikrotik nao pinga mais em nenhum endereço externo de internet,
somente as estaçoes conseguem pingar nos sites e no ip do servidor que preciso conectar. Gostaria de saber se tem alguma forma
de fazer com que cada discador PPTP CLIENTE conecte saindo por ISP'S diferentes no mikrotik.
EX: PPTP_1 SAINDO PELO ISP_1
&
PPTP_2 SAINDO PELO ISP_2.

Se puder me ajudar, agradeço muito pois ja estou atraz de uma soluçao pra isso a dias.
Desde ja agradeço pela atençao.



[9] Comentário enviado por maiconovic em 01/02/2014 - 10:16h

Amigo fiz tudo q esta no link muito bom funciona perfeitamente mais o meu RB nao navega não pinga fora só os pc navegam ele dar a MSG "no route to host" o que pode ser ou como resolver isso?

[10] Comentário enviado por jhony.masetto em 14/06/2016 - 08:44h

Raniel sua ideia é simples e muito útil, muito obrigado pela dica.

Aproveitei e criei uma complementação para meu caso aqui, compartilho caso seja útil para mais alguém:

Utilizando da ideia do manual http://wiki.mikrotik.com/wiki/ECMP_Failover_Script

# substititua o ip_do_ips_* pelo endereço do gateway ou algum ip que só pode ter ping por aquele link.

/tool netwatch

add host=ip_do_isp_1 timeout=5s interval=30s up-script=\"/ip route set routing-mark=Grupo_A [find comment=WAN1]; /ip route set routing-mark=Grupo_B [find comment=WAN2]\"
add host=ip_do_isp_2 timeout=5s interval=30s up-script=\"/ip route set routing-mark=Grupo_B [find comment=WAN2]; /ip route set routing-mark=Grupo_A [find comment=WAN1]\"

add host=ip_do_isp_2 timeout=5s interval=30s down-script=\"/ip route set routing-mark=main [find comment=WAN2]; /ip route set routing-mark=main [find comment=WAN1]\"
add host=ip_do_isp_1 timeout=5s interval=30s down-script=\"/ip route set routing-mark=main [find comment=WAN1]; /ip route set routing-mark=main [find comment=WAN2] \"

Este script faz nada mais do que ping a cada tantos segundos para um ip a ser definido e em caso de não conseguir ele retira a tag de grupo A e B de cada link fazendo com que tudo seja escoada para o link que estiver ativo.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts