Alterando as imagens de splash no Ubuntu

Fala galera! Nesse artigo vou mostrar como alterar a imagem do splash no Ubuntu, aquela mostrada quando ele está levantando os módulos, dispositivos e interfaces durante o boot. E a outra é aquela logo após você logar.

[ Hits: 90.151 ]

Por: Thiago Gomes em 06/07/2006


Splash no GRUB



Então vamos começar!

Primeiro crie um arquivo chamado "imagens" em /boot/grub/:

# mkdir /boot/grub/imagens

Agora baixe o arquivo que servirá de "background". No meu caso:
Salve-o na pasta que você criou.

OBS: Deixe o arquivo compactado.

Aplique as permissões no arquivo:

# chmod 644 nome-do-arquivo

Edite o menu.lst:

# cp /boot/grub/menu.lst /boot/grub/menu.lst_backup
# gedit /boot/grub/menu.lst


Procure por:

# menu.lst - See: grub(8), info grub, update-grub(8)
#      grub-install(8), grub-floppy(8),
#      grub-md5-crypt, /usr/share/doc/grub
#      and /usr/share/doc/grub-doc/.

...

E adicione em seguida:

splashimage (hd0,2)/boot/grub/images/nome-do-arquivo

OBS: No meu caso o boot do Ubuntu é em "hda3", ficando então "hd0,2", já que começa a contar a partir do "zero".

Salve o arquivo, e pronto! Reinicie o micro para ver como ficou!

    Próxima página

Páginas do artigo
   1. Splash no GRUB
   2. Splash quando está levantando o Linux
   3. Splash ao logar
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Exiv2 - Manipulando Metadados de Arquivos de Imagens

Alguém aí falou em deformação?

Trabalhando com foto usando Cheese + GIMP + Xmorph

Instalando o Corel Draw 9 no Slack 10.2

Slamd64 + ATI Radeon + AIGLX + Beryl

  
Comentários
[1] Comentário enviado por removido em 06/07/2006 - 18:01h

Farof, valeu!! Desde que instalei o kubuntu-desktop ficou aquele splash de carregamento azul-mar-sujo e não arranjei um jeito de voltar sem tirar o KDE.
Obrigado pela ajuda!

[2] Comentário enviado por _Luks em 06/07/2006 - 20:56h

ae cara
o "levantar" do linux deu pau, não ficou colorido.
Tem como desfazer esse processo ?
valeu!

[3] Comentário enviado por faroffiuts em 06/07/2006 - 23:23h

Ola _Luks,
tente alterar a paleta de cores do "usplash-artwork.c", e repita os procedimentos. Ou então, baixa aki a imagem:
(esse eh o splash do meu ubutnu 6.10)
http://www.sendspace.com/file/1xi9h3

Use esse arquivo e repita os procedimentos, creio que vai dar certo.
esse arquivo fika localizado em: /usr/lib/usplash

qualquer coisa posta aew!
vlw!!

[4] Comentário enviado por RedFoot em 07/07/2006 - 08:11h

Muito bom Farof, acho que o Ubuntu tem se tornado um projeto muito interessante, entretanto desde quando o conheci pela primeira vez, não fui muito com a parte gráfica (telas), acho que esse processo pode ajudar a torná-lo mais interessante desse ponto de vista.

Abraco
Red Foot


[6] Comentário enviado por removido em 07/07/2006 - 12:23h

:/

[7] Comentário enviado por agnelpovoa em 08/07/2006 - 17:12h

Olá,

O dah um erro no grub, então manda eu pressionar qualquer tecla, e a tela de inicialização fica tudo escura, soh funciona aquela telinha bunitinha quanto reinicio o micro...
Que q eu faço????

[8] Comentário enviado por zackshinra em 09/08/2006 - 01:11h

Caro faroffiuts
Notei o seguinte problema no seu artigo:
Vc diz "Primeiro crie um arquivo chamado "imagens" em /boot/grub/:"
Vc pede que a pasta/arquivo se chame "imagens".
Porém na linha que será adcionada, que direciona o local onde esta a imagem ("splashimage (hd0,2)/boot/grub/images/nome-do-arquivo") esta dizendo que a pasta se chama "images".
Para a dica funcionar tem que ficar assim:
"splashimage (hd0,2)/boot/grub/imagens/nome-do-arquivo"

[9] Comentário enviado por faroffiuts em 09/08/2006 - 10:16h

oi zackshinra,
realmente vc está certo, houve um erro de digitação de minha parte!!
Na verdade você tem que criar uma pasta, e não um arquivo. Dae eh soh nomea-lo para imagens ou images, desde que o caminho esteja correto!! abraços!

[10] Comentário enviado por edie em 21/10/2006 - 18:58h

olá faroffiuts,
deu erro aqui. a tela fica toda preta não aparece splash algum. Na parte de logon volta ao normal
o que pode ser?
tem como eu retornar pro splash default do Ubuntu?

abraços

[11] Comentário enviado por engdoug em 09/01/2007 - 02:03h

to tendo o err:
/boot/grub/imagens# gcc -Os -g -I/usr/include/bogl -fPIC -c usplash-artwork.c -o usplash-artwork.o
usplash-artwork.c:1: error: syntax error before ‘opening’


alguem ai ajuda eu? rs

vlw

[12] Comentário enviado por engdoug em 09/01/2007 - 02:05h

aqui ficou so uns riscos nao aparece mais nada hehe

to como o edie,.como volto a default?

[13] Comentário enviado por micaelfis em 29/04/2007 - 21:45h

Caro Thiago.
Primeiramente, parabéns pelo artigo. Bem, estou tentando molocar um splsh na inicialização do sistema. Segui todos os passos referidos no artigo. Porém, quando teclo:
$ dpkg-reconfigure linux-image-$(uname -r)
ele informa que nenhuma tela de splash foi localizada (Searching for splash image ... none found, skipping ...). Já vi que os links foram realmente criados com o "update-alternatives" e tudo o mais, no entanto, nada. Vc tem alguma idéia do que seria? Uso o Debian com o kernek 2.6.18-4-486.
Abraços e obrigado

[14] Comentário enviado por rnightmare4 em 29/06/2007 - 21:07h

Olá to tentando seguir as dicas mas da o seguinte erro:

[email protected]:~# gcc -Os -g -I/usr/include/bogl -fPIC -c usplash-artwork.c -o usplash-artwork.o
bash: gcc: comando não encontrado

Me ajudem sou novo com linux

[15] Comentário enviado por rnightmare4 em 29/06/2007 - 21:28h

desculpe galera por postar mensagens seguinas mas olha meu erro:

Pacote `linux-images-2.6.15-28-386' não está instalado e não há informações disponíveis.
Use dpkg --info (= dpkg-deb --info) para examinar arquivos do pacote,
e dpkg --contents (= dpkg-deb --contents) para listar seu conteúdo.
/usr/sbin/dpkg-reconfigure: linux-images-2.6.15-28-386 não está instalado

[16] Comentário enviado por rnightmare4 em 30/06/2007 - 11:50h

Kra muito bom esse post gostei muito soh que to com um probleminha aqui, fiz tudo que vc falow deu certo, soh q so fica uma tela preta e mais nada
como faço? Se alguem já resolveu isso me ajuda vai


[17] Comentário enviado por thiagoccabr em 19/07/2007 - 13:48h

Thiago muito bom esse tutorial gostei muito! Parabéns! Segui tudo direitinho, mas ao invés de aparecer minha imagem so fica uma tela preta como faço? Se alguem já resolveu pode me ajudar?

[18] Comentário enviado por unixgeek em 18/09/2007 - 13:18h

Faltou indicar no artigo que o texto não era seu, e a fonte de onde retirou.

[]s

[19] Comentário enviado por itaulos em 07/07/2008 - 21:33h

Eu fiz no meu e deu certo, mas a barra que aparece para se selecionar o sistema que se qr entra nao aparece nao...como eu faço para ela poder aparecer...??

flw's

[20] Comentário enviado por murderb13 em 10/08/2009 - 12:38h

alguem poderia me ajuda..
/home/oxigenio# update-alternatives --install /usr/lib/usplash/usplash-artwork.so usplash-artwork.so /boot/grub/imagens/loading-splash.so 55
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "pt_BR:pt:en",
LC_ALL = "pt_BR",
LC_MESSAGES = "pt_BR",
LANG = "pt_BR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
aparece esse erro

[21] Comentário enviado por zelauro em 26/11/2009 - 11:31h

farof,

Parabéns pelo artigo!

Mas no meu computador a imagem não aparece. Somente mostra os processos iniciando...
o que será que aconteceu?

obrigado.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts