apt-get install não funciona [RESOLVIDO]

1. apt-get install não funciona [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 01/07/2017 - 13:36h

e aí pessoal, beleza?
eu estou tentando instalar o google chrome e mas estou tendo problemas, aí o que acontece:


sudo apt-get install chromium-browser
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
chromium-browser : Depende: chromium-codecs-ffmpeg-extra (= 58.0.3029.110-0ubuntu0.16.04.1281) mas não será instalado ou
chromium-codecs-ffmpeg (= 58.0.3029.110-0ubuntu0.16.04.1281) mas não será instalado
Recomenda: chromium-browser-l10n mas não será instalado
google-chrome-stable : Depende: libappindicator1 mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução)

tentei instalar a antiga central de programas e também não consegui:

sudo apt install ubuntu-software
$ sudo apt install ubuntu-software
[sudo] senha para abel:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
google-chrome-stable : Depende: libappindicator1 mas não será instalado
ubuntu-software : Depende: gnome-software (= 3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1) mas 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 está para ser instalado
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Duplicate sources.list entry https://dl.google.com/linux/chrome/deb stable Release
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).

se alguem puder me ajudar agradeço desde já, tá me dando muito trabalho
eu acabei de instalar o ubuntu 16.04 abraçossss!!!




  


2. MELHOR RESPOSTA

francisco silva
silvadfrancisco

(usa Linux Mint)

Enviado em 01/07/2017 - 13:50h

boa tarde. Andei procurando tutoriais para saber o que o "apt-get -f install" faz ou serve, descobri que serve para procurar pacotes pendente que não foi encontrado pelo apt-get, minha sugestão é no terminal como root, digite:
apt-get update
apt-get -f install
Caso não resolva digite:
dpkg -i --force-all
dpkg --configure -a
Rode novamente o "apt-get -f install". Caso ele não resolva, experimente o "apt-get -f remove", que tem uma função similar à do "-f install", mas dá preferência a remover os pacotes com problemas, ao invés de tentar corrigir a instalação.
fonte desses procedimentos:
http://www.hardware.com.br/tutoriais/tutorial-completo-apt-get/parte-1.html na parte 3.
espero ter ajudado.

3. Re: apt-get install não funciona [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 01/07/2017 - 13:45h

abelbezerra escreveu:

e aí pessoal, beleza?
eu estou tentando instalar o google chrome e mas estou tendo problemas, aí o que acontece:


sudo apt-get install chromium-browser
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
chromium-browser : Depende: chromium-codecs-ffmpeg-extra (= 58.0.3029.110-0ubuntu0.16.04.1281) mas não será instalado ou
chromium-codecs-ffmpeg (= 58.0.3029.110-0ubuntu0.16.04.1281) mas não será instalado
Recomenda: chromium-browser-l10n mas não será instalado
google-chrome-stable : Depende: libappindicator1 mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução)

tentei instalar a antiga central de programas e também não consegui:

sudo apt install ubuntu-software
$ sudo apt install ubuntu-software
[sudo] senha para abel:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
google-chrome-stable : Depende: libappindicator1 mas não será instalado
ubuntu-software : Depende: gnome-software (= 3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1) mas 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 está para ser instalado
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:1 and /etc/apt/sources.list.d/google.list:1
W: Duplicate sources.list entry https://dl.google.com/linux/chrome/deb stable Release
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).

se alguem puder me ajudar agradeço desde já, tá me dando muito trabalho
eu acabei de instalar o ubuntu 16.04 abraçossss!!!



Velho ... não adianta vc querer atropelar o apt pq não rola ... veja bem ... 1° ele diz q vc tem que dar um "apt apt-get -f install' para tentar corrigir ... depois ele te fala que vc tem entradas duplicadas ... então o q vc tem que fazer a principio seria retirar as entradas duplicadas .... depois vc da um "apt apt-get -f install' ..


------------------------------------------| Linux User #621728 |-----------------------------------------
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"
------------------------------------------| Linux User #621728 |-----------------------------------------



4. Re: apt-get install não funciona

Perfil removido
removido

(usa Nenhuma)

Enviado em 01/07/2017 - 14:15h

Tente executar os seguintes comandos :
sudo rm /var/lib/apt/lists/lock

sudo rm /var/lib/dpkg/lock


5. Re: apt-get install não funciona [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/07/2017 - 14:19h

Prineiro desbloqueie
sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade

Depois os comandos
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
sudo apt-get update
sudo apt-get upgrade



6. Re: apt-get install não funciona [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 02/07/2017 - 09:43h

silvadfrancisco escreveu:

boa tarde. Andei procurando tutoriais para saber o que o "apt-get -f install" faz ou serve, descobri que serve para procurar pacotes pendente que não foi encontrado pelo apt-get, minha sugestão é no terminal como root, digite:
apt-get update
apt-get -f install
Caso não resolva digite:
dpkg -i --force-all
dpkg --configure -a
Rode novamente o "apt-get -f install". Caso ele não resolva, experimente o "apt-get -f remove", que tem uma função similar à do "-f install", mas dá preferência a remover os pacotes com problemas, ao invés de tentar corrigir a instalação.
fonte desses procedimentos:
http://www.hardware.com.br/tutoriais/tutorial-completo-apt-get/parte-1.html na parte 3.
espero ter ajudado.


valeu consegui resolver com o apt-get -f install no root
depois dei um sudo apt-get upgrade



7. Re: apt-get install não funciona [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 02/07/2017 - 09:47h

e finalmente consegui o google chrome instalando o gdebi:

sudo apt-get update && sudo apt-get upgrade

sudo apt-get install gdebi

wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

sudo gdebi google-chrome-stable_current_amd64.deb






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts