Tor não abre

1. Tor não abre

n0t3x #H4X0R
teamowaha

(usa Arch Linux)

Enviado em 22/01/2022 - 15:44h

Boa noite, nao consigo iniciar meu tor ele da o seguinte erro:
Jan 22 15:37:43.221 [notice] Tor 0.4.6.9 running on Linux with Libevent 2.1.12-stable, OpenSSL 1.1.1m, Zlib 1.2.11, Liblzma 5.2.5, Libzstd 1.5.1 and Glibc 2.33 as libc.
Jan 22 15:37:43.221 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jan 22 15:37:43.221 [warn] Tor was compiled with zstd 1.5.0, but is running with zstd 1.5.1. For safety, we'll avoid using advanced zstd functionality.
Jan 22 15:37:43.221 [notice] Read configuration file "/etc/tor/torrc".
Jan 22 15:37:43.226 [notice] Opening Socks listener on 127.0.0.1:9050
Jan 22 15:37:43.226 [notice] Opened Socks listener connection (ready) on 127.0.0.1:9050
Jan 22 15:37:43.226 [warn] Error setting groups to gid 43: "Operation not permitted".
Jan 22 15:37:43.226 [warn] If you set the "User" option, you must start Tor as root.
Jan 22 15:37:43.226 [notice] Closing partially-constructed Socks listener connection (ready) on 127.0.0.1:9050
Jan 22 15:37:43.226 [warn] Failed to parse/validate config: Problem with User value. See logs for details.
Jan 22 15:37:43.226 [err] Reading config failed--see warnings above.



  


2. Re: Tor não abre

rafael
ogro33

(usa Debian)

Enviado em 22/01/2022 - 19:20h


teamowaha escreveu:

Boa noite, nao consigo iniciar meu tor ele da o seguinte erro:
Jan 22 15:37:43.221 [notice] Tor 0.4.6.9 running on Linux with Libevent 2.1.12-stable, OpenSSL 1.1.1m, Zlib 1.2.11, Liblzma 5.2.5, Libzstd 1.5.1 and Glibc 2.33 as libc.
Jan 22 15:37:43.221 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jan 22 15:37:43.221 [warn] Tor was compiled with zstd 1.5.0, but is running with zstd 1.5.1. For safety, we'll avoid using advanced zstd functionality.
Jan 22 15:37:43.221 [notice] Read configuration file "/etc/tor/torrc".
Jan 22 15:37:43.226 [notice] Opening Socks listener on 127.0.0.1:9050
Jan 22 15:37:43.226 [notice] Opened Socks listener connection (ready) on 127.0.0.1:9050
Jan 22 15:37:43.226 [warn] Error setting groups to gid 43: "Operation not permitted".
Jan 22 15:37:43.226 [warn] If you set the "User" option, you must start Tor as root.
Jan 22 15:37:43.226 [notice] Closing partially-constructed Socks listener connection (ready) on 127.0.0.1:9050
Jan 22 15:37:43.226 [warn] Failed to parse/validate config: Problem with User value. See logs for details.
Jan 22 15:37:43.226 [err] Reading config failed--see warnings above.


Eu tive um erro parecido quando instalei o tor no debian. Não entendo nada de Arch, mas se tiver alguma semelhança, eu consegui resolver meu problema após rodar um apt purge nos pacotes do tor e depois reinstala-lo pelo Software Center.

Eu notei que ele está acusando ai pra você dois erros. O primeiro se refere a uma digergencia entre a versão do zstd na qual o tor foi compilado(1.5.0) e na qual ele está rodando(1.5.1). Talvez recompilando o mesmo com a nova versão do zstd ou fazendo o downgrade do zstd pra verão anterior não resolva?

E o outro erro esta relacionado as permissões. Já tentou rodar o tor como root pra ver se funciona?


Enfim, não entendo nada de Arch, mas pelas informações que você postou foi isso que consegui "pescar". Espero que ajude!