Processos estranhos no Sendmail

1. Processos estranhos no Sendmail

Thiago Andrey Ferreira
chipsites

(usa Slackware)

Enviado em 29/11/2011 - 09:28h

A um tempo recebi a mensagem de que o sendmail não podia enviar porque estava ocupado. Percebi então que havia varios processo filhos dele rodando no meu servidor de e-mail conforme abaixo:

Mserver:~ # ps ax | grep cmd
21665 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21671 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21714 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21720 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21721 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21736 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21749 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21753 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21754 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21771 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21786 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
21789 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
23290 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
23411 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
23412 ? S 0:00 sendmail: server localhost [127.0.0.1] cmd read
23414 pts/0 S+ 0:00 grep cmd

Eu achei que fosse o ASSP e mudei pra uma versão mais antiga, mas não resolveu.
Reparei também que esses processos vão morrendo e começando outros. E cada um deles gera a seguinte mensagem nos logs de e-mail:

Nov 29 09:24:57 Mserver sendmail[23501]: pATBOuHl023501: localhost [127.0.0.1] did not issue MAIL/EXPN/VRFY/ETRN during connection to Daemon0

Pesquisei na internet toda sobre algo parecido com isso mas não achei nada. Não sei mais o que fazer. Almentei o MaxDaemonChildren no Sendmail.cf para 20, evitando assim que chegue ao maximo o numero do processos, mas mesmo assim esse processos chegam a 20, é impressionante. Já olhei outros logs, matei o apache (pensando que era o webmail), mas nada.!
Alguem com algum conhecimento pode me iluminar nessa questão?


  


2. Re: Processos estranhos no Sendmail

Thiago Andrey Ferreira
chipsites

(usa Slackware)

Enviado em 30/11/2011 - 08:31h

ninguém? To quase configurando outro servidor já.


3. Re: Processos estranhos no Sendmail

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 30/11/2011 - 10:51h

eu nunca usei o sendmail
mas já deu uma olhada na documentação
para ver se tem alguma pista do que esta havendo ?


4. Re: Processos estranhos no Sendmail

Thiago Andrey Ferreira
chipsites

(usa Slackware)

Enviado em 30/11/2011 - 12:09h

chequei e não tive nenhum luz.

Eu sei que que esses processo malucos são processos filho do sendmail, e que se eu der um telnet localhost 25 ele abriria um processo desse. Mas eu não to dando telnet, muito menos 20. também não tem nenhum outro processo estranho rodando na maquina.