FSTAB-Leitura e Escrita não to conseguindo

1. FSTAB-Leitura e Escrita não to conseguindo

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 02/11/2007 - 16:15h

Boa tarde galera, to aqui com o ubunut 7.10, queria colocar uma partição EXT3 em modo de leitura e escrita, meu fstab estava assim:

# /dev/sda9
UUID=6d9835b5-438c-49a1-8c0f-a3e5f1d08443 /media/sda9 ext3 defaults 0 2

Editei e ficou assim:

# /dev/sda9
UUID=6d9835b5-438c-49a1-8c0f-a3e5f1d08443 /media/sda9 ext3 defaults,user,rw 0 2

Alguem pode me dizer como faço para deixar em modo leitura e escrita?

Desde já agradeço


  


2. Re: FSTAB-Leitura e Escrita não to conseguindo

Jefferson Diego
Diede

(usa Debian)

Enviado em 02/11/2007 - 17:48h

Acho que tem algo errado aí! pelo parâmetro "defaults", a unidade já deveria estar em modo leitura-escrita... visto que está com o parâmetro "user", é o "dono" da partição é que a monta, se mesmo o root é impedido de escrever, tente adicionar um umask=000, e vê no que dá.
Daí ficaria assim a linha no fstab:
UUID=6d9835b5-438c-49a1-8c0f-a3e5f1d08443 /media/sda9 ext3 defaults,user,rw,umask=000 0 2
PS: verifique primeiro se ao menos o root tem direito de escrita


3. umask=000

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 04/11/2007 - 01:45h

ai cara nem com o umask=000 to conseguindo, sera que tem como me dar mais alguma dica?


4. Sumiu

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 04/11/2007 - 10:42h

Opa, quando eu acrecentei o umask=000 eu so reiniciei o X (CTRL + ALT + Backspace) e não mudou nada, mas quando eu reiniciei o pc a partição sumiu e agora?


5. Re: FSTAB-Leitura e Escrita não to conseguindo

Jefferson Diego
Diede

(usa Debian)

Enviado em 04/11/2007 - 15:28h

Ok... Reiniciar o X não tem influencia. Para "reaver" os pontos de montagem, só desmontando e montando novamente (no caso "umount /dev/sda9" seguido de "mount /dev/sda9"). E como assim a partição sumiu?
Tipo... é porque o /media/sda9 está vazio, certo? tente montar manualmente com o comando mount /dev/sda9 e veja no que dá. E se não funcionar, tente com:
mount /dev/sda9 -t ext3 -o rw,umask=000 /media/sda9


6. Re: FSTAB-Leitura e Escrita não to conseguindo

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 04/11/2007 - 17:04h

Bem amigo, com a opção umask=000, depois do mount retorna isso:

mount: wrong fs type, bad option, bad superblock on /dev/sda9,
missing codepage or helper program, or other error
Em alguns casos informações úteis são encontradas no syslog - tente
"dmesg | tail" ou algo do tipo

tentei o sugerido
#dmesg | tail
resposta:

[ 443.466739] wlan0: RX too short data frame payload
[ 456.054259] wlan0: RX too short data frame payload
[ 500.138794] wlan0: RX too short data frame payload
[ 515.382334] wlan0: RX too short data frame payload
[ 546.281064] wlan0: RX too short data frame payload
[ 562.035437] wlan0: RX too short data frame payload
[ 587.303711] wlan0: RX too short data frame payload
[ 623.938720] wlan0: RX too short data frame payload
[ 633.740952] EXT3-fs: Unrecognized mount option "umask=000" or missing value
[ 669.354030] wlan0: RX too short data frame payload

com a outra forma que você indicou, depois do mount retornou isso:

mount: não foi possível localizar /dev/sda9 em /etc/fstab ou /etc/mtab

E ai amigo tem mais alguma coisa a ser feita?


7. Re: FSTAB-Leitura e Escrita não to conseguindo

Jefferson Diego
Diede

(usa Debian)

Enviado em 04/11/2007 - 17:23h

Ok... erro meu... o "umask" não funciona com ext3...
Mas, esse funciona:

mount /dev/sda9 /media/sda9/ -o rw,owner,users

Esse tenho quase certeza que irá funcionar... eu fiz um teste aqui e funcionou... com acesso completo (leitura e escrita)



8. Re: FSTAB-Leitura e Escrita não to conseguindo

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 04/11/2007 - 17:35h

da mesma forma amigo

minha linha completa:
# /dev/sda9
UUID=6d9835b5-438c-49a1-8c0f-a3e5f1d08443 mount /dev/sda9 /media/sda9/ -o rw,owner,users

mount /dev/sda9
[mntent]: linha 16 em /etc/fstab tem inválido(a)
mount: não foi possível localizar /dev/sda9 em /etc/fstab ou /etc/mtab


a coisa pra mim ta complicado meu jovem (heheheh)



9. Re: FSTAB-Leitura e Escrita não to conseguindo

Jefferson Diego
Diede

(usa Debian)

Enviado em 04/11/2007 - 17:42h

OK... é que isso era para digitar como comando... hehe... mas, funciona digitando?
(mount /dev/sda9 /media/sda9/ -o rw,owner,users)
???

Caso funcione, para finalizar, é só ir no fstab, e trocar:

# /dev/sda9
UUID=6d9835b5-438c-49a1-8c0f-a3e5f1d08443 mount /dev/sda9 /media/sda9/ -o rw,owner,users

por

# /dev/sda9
/dev/sda9 /media/sda9 ext3 users,rw,owner 0 2

Se o comando:
mount /dev/sda9 /media/sda9/ -o rw,owner,users

Funcionar, daí pra frente funciona.


10. Re: FSTAB-Leitura e Escrita não to conseguindo

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 04/11/2007 - 19:52h

Amigo desde ja te agradeço pela atenção e ajuda, mas não deu certo não amigo, se tiver mais algu a ser feito...

Mas acho que pode ser eu que estou meio ...




11. Re: FSTAB-Leitura e Escrita não to conseguindo

Jefferson Diego
Diede

(usa Debian)

Enviado em 04/11/2007 - 19:56h

Nossa... achei que com o comando acima funcionaria...
Mas, dessa vez, ele não monta mais, ou ainda monta, porém em somente leitura?


12. Monta

Ailton Fernandes
red_slack

(usa Slackware)

Enviado em 04/11/2007 - 21:08h

monta cara, mas somente leitura...

já tentei isso tudo que você indicou e outras coisas a mais e nada... ja não sei mais o que fazer, o pior é que preciso dessa partição com um certa urgencia.



01 02 03



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts