Erro de verificação no Yaourt [RESOLVIDO]

1. Erro de verificação no Yaourt [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 15/04/2014 - 14:52h

Olá galerinha! Como corrigir esse erro no Yaourt?

==> Compilando e instalando pacote
==> AVISO: Compilar pacotes como root é perigoso.
Por favor execute yaourt como um usuário não privilegiado.
==> Criando o pacote: multisystem 1.0292-1 (Ter Abr 15 14:41:22 UTC 2014)
==> Verificando as dependências de tempo de execução...
==> Verificando as dependências de tempo de compilação...
==> Obtendo fontes...
-> Encontrado multisystem.tar.bz2
==> Validando arquivos fonte com md5sums...
multisystem.tar.bz2 ... FALHOU
==> ERRO: Um ou mais arquivos não passaram na verificação de validade!
==> ERRO: Makepkg não conseguiu compilar multisystem.
==> Reiniciar a compilação de multisystem ? [s/N]
==> ---------------------------------------------


Já me aconteceu isso em vários outros pacotes que tentei instalar pelo Yaourt, como posso forçar uma instalação que contenha esse erro? Já executei o Yaourt com a opção --force mas dá no mesmo!




  


2. MELHOR RESPOSTA

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/04/2014 - 04:09h

Nada a ver com o Assunto....

Mas está rodando o yaourt como root, isso é um erro tremendo.

Usando o yaourt corretamente: yaourt -S pacote

Deixe o vício do sudo ou su de lado, na hora certa ele pede sua senha. Outra coisa se for usar o Aur não salve senha no chaveiro de seção.


Tudo a ver com o Assunto....

tente um: $ yaourt -Syua

isso sincroniza a sua base do Aur, resolvi esse problema assim.

Rodar um: # pacman -optimize

pode ajudar



3. Re: Erro de verificação no Yaourt [RESOLVIDO]

Glauber Santos
Glauber07

(usa Fedora)

Enviado em 16/04/2014 - 02:37h

Cara! Estou com esse mesmo tipo de problema quando vou instalar o "jre"

==> Compilando e instalando pacote
==> Criando o pacote: jre 8u0-1 (Qua Abr 16 02:33:52 BRT 2014)
==> Verificando as dependências de tempo de execução...
==> Verificando as dependências de tempo de compilação...
==> Obtendo fontes...
-> Baixando jre-8-linux-x64.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 54.3M 100 54.3M 0 0 1755k 0 0:00:31 0:00:31 --:--:-- 1819k
-> Encontrado java-policy-settings.desktop
-> Encontrado javaws-launcher
-> Encontrado jre.csh
-> Encontrado jre.sh
==> ERRO: Verificações de integridade (md5) diferem em tamanho do vetor de fontes.
==> ERRO: Makepkg não conseguiu compilar jre.
==> Reiniciar a compilação de jre ? [s/N]
==> -------------------------------------
==>

Alguém pode nos ajudar?


4. Re: Erro de verificação no Yaourt [RESOLVIDO]

Glauber Santos
Glauber07

(usa Fedora)

Enviado em 16/04/2014 - 17:09h

Obrigado Tropper!

Resolvi meu problema com o java instalando dos repositórios oficiais.
Sobre o comando que você sugeriu, rodei e foram atualizados alguns pacotes e inclusive o java que instalei dos repositórios oficiais.

Comando:

$ yaourt -Syua

Tudo funcionando perfeitamente!


5. Re: Erro de verificação no Yaourt [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 16/04/2014 - 19:37h

tropper escreveu:

Nada a ver com o Assunto....

Mas está rodando o yaourt como root, isso é um erro tremendo.

Usando o yaourt corretamente: yaourt -S pacote

Deixe o vício do sudo ou su de lado, na hora certa ele pede sua senha. Outra coisa se for usar o Aur não salve senha no chaveiro de seção.


Tudo a ver com o Assunto....

tente um: $ yaourt -Syua

isso sincroniza a sua base do Aur, resolvi esse problema assim.

Rodar um: # pacman -optimize

pode ajudar



Cara, valeu pela dica e vou dar como resolvido, mas a verdade é que voltei pro Debian! Não por esse problema no Arch ou nada parecido, simplesmente não consigo ficar longe do Debian. O Arch Linux é uma excelente distribuição, principalmente pelo fato de existir o AUR (onde se encotra quase todos os pacotes que existem pra Linux). Enfim, o Debian é a minha cara, não tem jeito! Mas valeu pela dica!


6. Re: Erro de verificação no Yaourt [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/04/2014 - 18:10h

juliano_vatre escreveu:

tropper escreveu:

Nada a ver com o Assunto....

Mas está rodando o yaourt como root, isso é um erro tremendo.

Usando o yaourt corretamente: yaourt -S pacote

Deixe o vício do sudo ou su de lado, na hora certa ele pede sua senha. Outra coisa se for usar o Aur não salve senha no chaveiro de seção.


Tudo a ver com o Assunto....

tente um: $ yaourt -Syua

isso sincroniza a sua base do Aur, resolvi esse problema assim.

Rodar um: # pacman -optimize

pode ajudar



Cara, valeu pela dica e vou dar como resolvido, mas a verdade é que voltei pro Debian! Não por esse problema no Arch ou nada parecido, simplesmente não consigo ficar longe do Debian. O Arch Linux é uma excelente distribuição, principalmente pelo fato de existir o AUR (onde se encotra quase todos os pacotes que existem pra Linux). Enfim, o Debian é a minha cara, não tem jeito! Mas valeu pela dica!



Isso é bom, parabens pelo teste. E parabens por adotar a distro que te faz feliz. Esse é um dos pontos que amo no Linux, sempre temos distros que são a nossa cara.








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts