Dúvida na instalação adaptador USB wireless tp-link no Linux?

1. Dúvida na instalação adaptador USB wireless tp-link no Linux?

André Luis Barros
raptor.x

(usa Mandriva)

Enviado em 18/05/2011 - 13:55h

Bom dia a todos,
Comprei um adaptador USB wireless tp-link modelo TL-WN722N
Para configura-lo, estou seguindo as dicas do seguinte post -> http://www.vivaolinux.com.br/dica/Placa-wireless-USB-Multilaser-Atheros-Communications-Inc.-AR9271-8...
O caso é que ao final do comando make, 2 erros são acusados e não estou conseguindo identificar a causa. Segue as ultimas linhas da saída do comando make.
include/linux/kernel.h:363:1: warning: this is the location of the previous definition
/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless/libertas/if_cs.c: In function ‘if_cs_ioprobe’:
/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless/libertas/if_cs.c:827: error: implicit declaration of function ‘lbs_pr_err’
/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless/libertas/if_cs.c: At top level:
/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless/libertas/if_cs.c:1078: warning: initialization discards qualifiers from pointer target type
make[4]: ** [/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless/libertas/if_cs.o] Erro 1
make[3]: ** [/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless/libertas] Erro 2
make[2]: ** [/home/raptor/Download/compat-wireless-2011-05-16/drivers/net/wireless] Erro 2
make[1]: ** [_module_/home/raptor/Download/compat-wireless-2011-05-16] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-2.6.31.14-desktop586-1mnb'
make: ** [modules] Erro 2

Segue também a saída do comando lsusb
Bus 002 Device 004: ID 0cf3:9271 Atheros Communications, Inc.

Alguém poderia me dar alguma dica do que pode estar acontecendo?
Grato!

Kernel 2.6.31.14 - Mandriva 2010-1


  


2. Re: Dúvida na instalação adaptador USB wireless tp-link no Linux?

Daniel Roque
tiekookeit

(usa Debian)

Enviado em 20/05/2011 - 09:04h

tentei achar alguma coisa a respeito do erro e não encontrei nada, aparentemente existe um conflito entre uma função utilizada no driver que parece que ele não encontra nos heders do kernel, você tem os headers do teu kernel instalado?, eu na sua posição, trocaria a versão do kernel, mas não sei te dizer se isto é simples no madriva.


3. Consegui resolver!

André Luis Barros
raptor.x

(usa Mandriva)

Enviado em 20/05/2011 - 13:12h

Ola,
Então colega, baixei este pacote http://ufpr.dl.sourceforge.net/project/ath9k-htc/ath9k_htc-installer/ath9k_htc-installer_1-0_all.deb , que apesar de estar em formato deb, eu o descompactei, e consegui compilar normal.
Ta funcionando.... Grato!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts