Atualizações com o 'aptitude upgrade' [RESOLVIDO]

1. Atualizações com o 'aptitude upgrade' [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 05/09/2013 - 08:55h

Olá turma do VoL!

Quando dou um 'aptitude full-upgrade' ou 'apt-get upgrade' surge o seguinte impasse abaixo, devo ou não dar um 'yes', pois aí diz que vai remover o xorg e outros componentes do ambiente gráfico...

###
[email protected]:~# apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
perl perl-base perl-modules
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.

###
[email protected]:~# aptitude full-upgrade
Os NOVOS pacotes a seguir serão instalados:
libarchive-extract-perl{a} libmodule-pluggable-perl{a}
libpod-latex-perl{a} libterm-ui-perl{a} libtext-soundex-perl{ab}
Os pacotes a seguir serão atualizados:
perl perl-base perl-modules
3 pacotes atualizados, 5 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 8.903 kB de arquivos. Depois do desempacotamento, 2.877 kB serão usados.
Os pacotes a seguir possuem dependências não satisfeitas:
libpango-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libnet-ssleay-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libnet-dbus-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
perlmagick : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libuuid-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libperl5.14 : Depende: perl-base (= 5.14.2-21) mas 5.18.1-2 será instalado.
libtext-charwidth-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libhtml-parser-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libxml-libxml-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libpurple0 : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libtext-iconv-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libgtk2-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libglib-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
lsof : Depende: libperl4-corelibs-perl mas não vai ser instalado. ou
perl (< 5.12.3-7) mas 5.18.1-2 será instalado.
liblocale-gettext-perl : Pré-Depende: perlapi-5.14.2 o qual é um pacote virtual.
libtext-soundex-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libopengl-xscreensaver-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libsdl-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libdbd-mysql-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libopengl-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libsocket-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libxml-parser-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
pidgin : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libcairo-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
libdbi-perl : Depende: perlapi-5.14.2 o qual é um pacote virtual.
aberto: 177; fechado: 315; atrasado: 164; conflito: 249 .As seguintes ações resolverão estas dependências:

Remover os pacotes a seguir:
1) aspell
2) aspell-en
3) aspell-pt-br
4) console-setup
5) console-setup-linux
6) debconf-i18n
7) dictionaries-common
8) dizzy
9) enchant
10) gimp
11) hunspell-en-us
12) ibrazilian
13) inkscape
14) ispell
15) keyboard-configuration
16) libapache2-mod-php5
17) libcairo-perl
18) libdbd-mysql-perl
19) libdbi-perl
20) libenchant1c2a
21) libglib-perl
22) libgtk2-perl
23) libgtkspell0
24) libhtml-form-perl
25) libhtml-format-perl
26) libhtml-parser-perl
27) libhtml-tree-perl
28) libio-socket-ssl-perl
29) liblocale-gettext-perl
30) liblwp-protocol-https-perl
31) libmailtools-perl
32) libnet-dbus-perl
33) libnet-smtp-ssl-perl
34) libnet-ssleay-perl
35) libopengl-perl
36) libopengl-xscreensaver-perl
37) libpango-perl
38) libperl5.14
39) libpurple-bin
40) libpurple0
41) libsdl-perl
42) libsocket-perl
43) libtext-charwidth-perl
44) libtext-iconv-perl
45) libtext-wrapi18n-perl
46) libuuid-perl
47) libwebkitgtk-1.0-0
48) libwebkitgtk-3.0-0
49) libwww-perl
50) libxml-libxml-perl
51) libxml-parser-perl
52) libxml-sax-expat-perl
53) libxml-twig-perl
54) linux-base
55) linux-image-3.10-2-amd64
56) linux-image-3.9-1-amd64
57) linux-image-amd64
58) lsof
59) metacity
60) metacity-themes
61) myspell-pt-br
62) mysql-client
63) mysql-client-5.5
64) perlmagick
65) php5
66) php5-cli
67) php5-common
68) php5-json
69) pidgin
70) pidgin-skype
71) pidgin-skype-common
72) task-brazilian-portuguese
73) tasksel
74) tasksel-data
75) texinfo
76) wbrazilian
77) xorg
78) xscreensaver
79) xscreensaver-data
80) xscreensaver-data-extra
81) xscreensaver-screensaver-bsod
82) xscreensaver-screensaver-dizzy
83) xscreensaver-screensaver-webcollage
84) xserver-xorg
85) xserver-xorg-core
86) xserver-xorg-input-all
87) xserver-xorg-input-evdev
88) xserver-xorg-input-mouse
89) xserver-xorg-input-synaptics
90) xserver-xorg-input-vmmouse
91) xserver-xorg-input-wacom
92) xserver-xorg-video-all
93) xserver-xorg-video-apm
94) xserver-xorg-video-ark
95) xserver-xorg-video-ati
96) xserver-xorg-video-chips
97) xserver-xorg-video-cirrus
98) xserver-xorg-video-fbdev
99) xserver-xorg-video-i128
100) xserver-xorg-video-intel
101) xserver-xorg-video-mach64
102) xserver-xorg-video-mga
103) xserver-xorg-video-neomagic
104) xserver-xorg-video-nouveau
105) xserver-xorg-video-openchrome
106) xserver-xorg-video-r128
107) xserver-xorg-video-radeon
108) xserver-xorg-video-rendition
109) xserver-xorg-video-s3
110) xserver-xorg-video-s3virge
111) xserver-xorg-video-savage
112) xserver-xorg-video-siliconmotion
113) xserver-xorg-video-sis
114) xserver-xorg-video-sisusb
115) xserver-xorg-video-tdfx
116) xserver-xorg-video-trident
117) xserver-xorg-video-tseng
118) xserver-xorg-video-vesa
119) xserver-xorg-video-vmware
120) xserver-xorg-video-voodoo
121) zenity

Manter os pacotes a seguir em suas versões atuais:
122) libtext-soundex-perl [Não Instalado]

Deixar as seguintes dependências por resolver:
123) perl-modules recomenda libtext-soundex-perl
124) libaspell15 recomenda aspell-en | aspell-dictionary | aspell6a-dictiona
125) debconf recomenda debconf-i18n
126) gimp-data recomenda gimp
127) libhunspell-1.3-0 recomenda hunspell-en-us | hunspell-dictionary | mysp
128) inkscape recomenda aspell
129) inkscape recomenda perlmagick
130) ispell recomenda iamerican | ispell-dictionary
131) kbd recomenda console-setup | console-data
132) libnet-http-perl recomenda libio-socket-ssl-perl (>= 1.38)
133) libproxy0 recomenda libmozjs10d | libwebkitgtk-1.0-0
134) libwww-perl recomenda libhtml-form-perl
135) libwww-perl recomenda libhtml-format-perl
136) libwww-perl recomenda libmailtools-perl
137) libxml-sax-perl recomenda libxml-sax-expat-perl
138) libxml-twig-perl recomenda libtext-iconv-perl
139) libxml-twig-perl recomenda libwww-perl
140) libxml-twig-perl recomenda libhtml-parser-perl
141) synaptic recomenda libgtk2-perl (>= 1:1.130)
142) task-brazilian-portuguese recomenda ibrazilian
143) task-brazilian-portuguese recomenda aspell-pt-br
144) task-brazilian-portuguese recomenda wbrazilian
145) unicode-screensaver recomenda xscreensaver | gnome-screensaver
146) xdg-utils recomenda libnet-dbus-perl
147) xfce4 recomenda xorg
148) xfce4-dict recomenda aspell | ispell
149) xfce4-session recomenda xscreensaver
150) xinit recomenda xserver-xorg | xserver
151) xserver-xorg-input-all recomenda xserver-xorg-input-wacom
152) iceweasel-l10n-pt-br recomenda myspell-pt-br | myspell-pt


Aceitar esta solução? [Y/n/q/?]


  


2. MELHOR RESPOSTA

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 05/09/2013 - 09:46h

Não use o aptitude para fazer upgrade pois ele é falho para este uso.

Tente :

apt-get dist-upgrade


3. Re: Atualizações com o 'aptitude upgrade' [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 05/09/2013 - 10:04h

andrecanhadas escreveu:

Não use o aptitude para fazer upgrade pois ele é falho para este uso.

Tente :

apt-get dist-upgrade


Então... acontece o mesmo!
Gostaria de saber o porquê da remoção do 'xorg' e demais pacotes. Detalhe: estou usando a versão testing do Debian.


4. Re: Atualizações com o 'aptitude upgrade' [RESOLVIDO]

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 05/09/2013 - 10:10h

Estou usando a testing também neste momento poste seu sources.list pra ver se tem algo conflitando.

Como instalou o testing atualizando do Wheezy ou baixou a iso testing e instalou?


5. Re: Atualizações com o 'aptitude upgrade' [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 05/09/2013 - 14:43h

andrecanhadas escreveu:

Estou usando a testing também neste momento poste seu sources.list pra ver se tem algo conflitando.

Como instalou o testing atualizando do Wheezy ou baixou a iso testing e instalou?


Baixei a testing pelo 'netinst' e fui instalando os pacotes, mas de repente me apareceu esse probleminha, na verdade não é nada que esteja me preocupando pois se eu der um 'upgrade' normal ele simplesmente atualiza os pacotes e mantém os que estão em conflito, É só pra entender problema ...e talvez resolvê-lo.

source.list:


# deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20130715-05:18]/ jessie main
# deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20130715-05:18]/ jessie main

# deb http://ftp.br.debian.org/debian/ experimental non-free contrib main
# deb-src http://ftp.br.debian.org/debian/ experimental non-free contrib main

deb http://ftp.br.debian.org/debian/ testing-proposed-updates non-free contrib main
deb-src http://ftp.br.debian.org/debian/ testing-proposed-updates non-free contrib main

deb http://ftp.br.debian.org/debian/ testing non-free contrib main
deb-src http://ftp.br.debian.org/debian/ testing non-free contrib main

deb http://security.debian.org/ testing/updates non-free contrib main
deb-src http://security.debian.org/ testing/updates non-free contrib main

###

# deb http://http.debian.net/debian testing main contrib non-free
# deb-src http://http.debian.net/debian testing main contrib non-free



6. Re: Atualizações com o 'aptitude upgrade' [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 08/09/2013 - 16:23h

Agora a parada aumentou:


[email protected]:~# apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
libcairo-perl libglib-perl libgtk2-perl libhtml-parser-perl
liblocale-gettext-perl libnet-dbus-perl libnet-ssleay-perl libopengl-perl
libopengl-xscreensaver-perl libpango-perl libpurple0 libsocket-perl
libtext-charwidth-perl libtext-iconv-perl libuuid-perl libxml-libxml-perl
libxml-parser-perl perl perl-base perl-modules perlmagick pidgin
xserver-xorg-core
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 23 não atualizados.


E agora?


7. Re: Atualizações com o 'aptitude upgrade' [RESOLVIDO]

Juliano Vatre
vatrinux

(usa Outra)

Enviado em 08/09/2013 - 16:46h

Não entendi mas tudo bem... Dei um 'apt-get dist-upgrade' 2x e o troço atualizou. Mas antes disso tudo não atualizava nem com o 'dist-upgrade'. Mas já que se resolveu sozinho, tudo certo então...






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts