Openvpn não funcionando

1. Openvpn não funcionando

Jefferson Andre da Silva
xcompbrasil

(usa Debian)

Enviado em 03/10/2014 - 16:44h

Olá pessoal,

Não estou conseguindo fazer funcionar uma openvpn, já tentei vários artigos e nada. Gostaria de ajuda pois o problema não está fácil de ser encontrado.

Quero acessar este servidor com qualquer máquina utilizando o windows.

Agradeço a todos a paciência e as sujestões.

Ip fixo da matriz:
189.111.245.xxx

Segue ifconfig do servidor:
eth0 Link encap:Ethernet Endereço de HW 00:24:1d:f1:b8:6d
inet end.: 192.168.0.119 Bcast:192.168.0.255 Masc:255.255.255.0
endereço inet6: fe80::224:1dff:fef1:b86d/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:35422198 erros:0 descartados:398 excesso:0 quadro:0
Pacotes TX:73940545 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:5609545028 (5.6 GB) TX bytes:103065201058 (103.0 GB)

eth1 Link encap:Ethernet Endereço de HW 00:e0:4c:33:d9:30
UP BROADCAST MULTICAST MTU:1500 Métrica:1
pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:65536 Métrica:1
pacotes RX:297326 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:297326 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:237803771 (237.8 MB) TX bytes:237803771 (237.8 MB)

tun0 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet end.: 10.0.0.1 P-a-P:10.0.0.1 Masc:255.255.255.255
UP POINTOPOINT NOARP MULTICAST MTU:1500 Métrica:1
pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Primeira duvida: o p-a-p: nao deveria estar 10.0.0.2?

matriz.conf:
# Usar como interface o driver TUN
dev tun
# 10.0.0.1 IP que será assumido na matriz
# 10.0.0.2 IP remoto, ou seja, esse será o IP da filial
ifconfig 10.0.0.1 10.0.0.2
# Entra no diretório onde se encontram os arquivos de configuração
cd /etc/openvpn
# Indica que esse túnel possui uma chave de criptografia
secret chave
# OpenVPN usa a porta 5000/UDP por padrão.
# Cada túnel do OpenVPN deve usar
# uma porta diferente.
# O padrão é a porta 5000
port 5000
# Usuário que rodará o daemon do OpenVPN
user nobody
# Grupo que rodará o daemon do OpenVPN
group nobody
#Usa a biblioteca lzo
comp-lzo
# Envia um ping via UDP para a parte
# remota a cada 15 segundos para manter
# a conexão de pé em firewall statefull
# Muito recomendado, mesmo se você não usa
# um firewall baseado em statefull.
ping 15
# Nível de log
verb 3

o que pode estar errado ?


  


2. Re: Openvpn não funcionando

Jefferson Andre da Silva
xcompbrasil

(usa Debian)

Enviado em 06/10/2014 - 13:58h

Ajudem por favor


3. Re: Openvpn não funcionando

Marcus Vinícius Mastelaro
mastellaro

(usa Slackware)

Enviado em 24/10/2014 - 11:21h

A filial é um servidor Linux?


4. Re: Openvpn não funcionando

Jefferson Andre da Silva
xcompbrasil

(usa Debian)

Enviado em 24/10/2014 - 14:08h

Sim é um servidor samba


5. Re: Openvpn não funcionando

Marcus Vinícius Mastelaro
mastellaro

(usa Slackware)

Enviado em 24/10/2014 - 14:12h

posta a configuração da filial.


6. Re: Openvpn não funcionando

Jeferson Coli
jcoli

(usa Debian)

Enviado em 24/10/2014 - 14:24h

boa tarde,

Você dia que quer conectar-se via vpn a esse servidor com qualquer maquina windows.

Esta configuração não vai atende-lo, é para fazer a conexão entre filiais.




7. Re: Openvpn não funcionando

Mackristofer
macks

(usa Outra)

Enviado em 27/10/2014 - 19:05h

Cara aconselho vc a checar as regras no seu firewall e as regras de roteamento.

Por exemplo o servidor de vpn na matriz é o mesmo roteador/gateway da sua rede, pergunto isso pq se n for vc tem duas formas de trabalhar....ou criar as rotas em todos servidores que utilizar manualmente...ou ir no seu roteador/gateway e fazer o apontamento la saca.

Muitas das vezes esbarramos nessas configurações extras que tem que ser feita em ambos os lados.....se uma rota n é conhecida vc consegue ate conectar mas não consegue enxergar as maquinas do outro lado da rede.

Algumas perguntas para tentar ajudar melhor:

Vc deseja configurar uma vpn entre servidores matriz/filial ou cliente/servidor?

Esse servidor de vpn é o mesmo router/gateway da matriz ?

Existe algum firewall na borda da sua rede ?

Nos de mais info para tentar ajudar.

Att.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts