cache do SQUID não funciona... [RESOLVIDO]

1. cache do SQUID não funciona... [RESOLVIDO]

Marcos Meira
oxroll

(usa Debian)

Enviado em 27/01/2008 - 18:06h

galera, faço um download de um programa com 5 ou 12 Megas, mas ele não fica no cache, por q? Por q depois q baixo ele, vou em outra máquina e baixo novamente o mesmo programa mas ele não baixa do cache e sim da internet novamente, lembrando q eu libero 2 MB para a máquina onde faço o segundo download, ele nunca baixa do cache, sei disso por q era para dar 2 MB quando baixasse do cache e continua dando a mesma velocidade q foi feita quando baixei ele pela primeira vez. Segue abaixo as minhas confs do SQUID referente ao cache:

cache_mem 64 MB
maximum_object_size_in_memory 640 KB
maximum_object_size 51200 KB
minimum_object_size 0 KB
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /home/cache 8192 16 256
cache_access_log /var/log/squid/access.log



  


2. Re: cache do SQUID não funciona... [RESOLVIDO]

Isomi Luiz da Silva
clicsis

(usa Debian)

Enviado em 06/02/2008 - 11:44h

Não sei se posso lhe auxiliar, vou dá uma olhada, mas por emquanto veja a configuração do meu SQUID que até o momento está funcionando normal:

# Configuracao do cache
cache_mem 128 MB
maximum_object_size_in_memory 128 KB
maximum_object_size 300 MB
minimum_object_size 0 KB
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /home/squidcache 2048 16 256
cache_access_log /var/log/squid/access.log
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY


3. Re: cache do SQUID não funciona... [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 13/06/2008 - 19:09h

Estou passando por algo parecido, os vídeos do Youtube não estão ficando no cache. Se atualizar a página o vídeo começa a ser baixado novamente, me lembro que em versões anteriores (não estou culpando a versão) os vídeo e downloads ficavam e cache.

Mas estou sem tempo pra pesquisar.
Se alguém sober conta pra gente eheh.


4. Re: cache do SQUID não funciona... [RESOLVIDO]

Bruno Araujo
bjaraujo

(usa Ubuntu)

Enviado em 15/06/2008 - 23:23h

Sobre o youtube. Andei pesquisando e pelo que entendi cada requisição ao vídeo (o flv mesmo) é feita com uma consulta (?ip=123$etc=tal) que inclui informações variáveis e a entrega e feita por servidores aleatórios.
Há uma possibilidade de fazê-lo mas, me perdoem, parece gabiarra e não testei ainda.

Se vc tentar com método antigo seu cache enche à toa.


5. Re: cache do SQUID não funciona... [RESOLVIDO]

Bruno Araujo
bjaraujo

(usa Ubuntu)

Enviado em 15/06/2008 - 23:28h

Faz um teste com essa linha aê.

refresh_pattern ^http:\/\/74\.125 86400 20% 86400 override-expire override-lastmod


6. estou com mesmo problema

Franz Walter Leitão
franz81

(usa Slackware)

Enviado em 14/09/2010 - 20:24h

Amigo voce teve alguma resposta positiva??? resolveu por conta??? pode me ajudar???
Estou com o mesmo problema!!!!!!!!!!!!!!!!

utilizo slackware 13.1 32bits
com squid 3.0

Agradeço desde já sua atenção.


7. Re: cache do SQUID não funciona... [RESOLVIDO]

willian diego do amaral
willian.amaral

(usa Debian)

Enviado em 14/09/2010 - 22:30h

oxroll
qual foi a solução?
willian






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts