Problemas com DNS!

1. Problemas com DNS!

Marcos Meira
oxroll

(usa Debian)

Enviado em 12/02/2008 - 09:31h

Bom dia pessoal! Estou com um probleminha aq, onde já tentei resolver de várias formas mas não obtive resultados, é o seguinte:
Tenho no meu provedor um server Debian usando BIND como server DNS, neste caso eu criei um domínio local, tipo: domínio.local, e criei alguns subdomínios tipo: sub.dominio.local. Bom, aparentemente esta tudo ok com o server, pois consigo pingar para todos os subdomínio e domínio, nos clientes consigo tmb, porém sempre reinicio a máquina cliente, esses subdomínios já não são resolvidos mais, no servidor, pinga normalmente, mas nos clientes não, e o extranho pra mim é que quando aplico o comando IPCONFIG /REGISTERDNS no DOS do windows (máquina cliente) ela passa a obter resposta de todos os subdominios/dominio normalmente, mas é só reiniciar a maquina cliente, que ele para novamente, voltando a obter resposta quando aplico o comando IPCONFIG novamente. Alguém já passou por este problema? Será problema no bind ou no windows??
Vlw


  


2. Re: Problemas com DNS!

Thiago Fernandes de Melo
m4tri_x

(usa Ubuntu)

Enviado em 12/02/2008 - 09:57h

cola ai o resultado dos comandos:

#lsof -i TCP:53
#lsof -i UDP:53

pode ser que ao reiniciar o servidor, tenha perdido configurações de ip e o bind esteja rodando de forma incorreta.

acredito que possa ser isso, me desculpe se eu estiver enganado...

[]´s


3. Re: Problemas com DNS!

Marcos Meira
oxroll

(usa Debian)

Enviado em 12/02/2008 - 10:03h

Olá, Obrigado pela ajuda!

os comando q pediu para fazer retorna o seguinte resultado:

# lsof -i TCP:53
-bash: lsof: command not found

OBS:
O problema não esta quando reinicio o servidor e sim quando reinicio a máquina cliente. VLW

Aguardo retorno.


4. Re: Problemas com DNS!

Thiago Fernandes de Melo
m4tri_x

(usa Ubuntu)

Enviado em 12/02/2008 - 10:28h

o lsof ia mostrar em qual adaptador o bind ta escutando...


sei que isso que eu vou falar é a primeira coisa que agente verifica, mais o dns primario ta o ip do servidor bind?




[]´s


5. Re: Problemas com DNS!

Marcos Meira
oxroll

(usa Debian)

Enviado em 12/02/2008 - 10:31h

Sim está SIM. Uso o ip do servidor BIND para DNS Primário nos clientes.


6. UP??

Marcos Meira
oxroll

(usa Debian)

Enviado em 12/02/2008 - 23:21h

alguém me ajude!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts