Steam não inicia em opensuse leap 15

1. Steam não inicia em opensuse leap 15

Eduardo Avila
Eduamaro

(usa Linux Mint)

Enviado em 29/11/2018 - 16:41h

Olá pessoal do fórum, acabei de instalar o opensuse 15 com o desktop xfce e estou gostando bastante, porém quando tentei instalar a steam pelo zypper, a instalação foi toda normalmente, quando mandei a steam abrir, ela pediu para eu concordar com os termos de uso, quando cliquei em ok, essa tela sumiu e mais nada aconteceu. Esperei mais de uma hora, porque talvez algo estivesse baixando, por mais que tanto a minha máquina quanto o acesso à internet que tenho são rápidos, mas nada mudou.

Toda vez que mando abrir a steam, até aparecem alguns processos dela em segundo plano (2 para ser exato: bash steamtricks e script steamtricks) mas nada acontece, se eu tentar matar esses dois processos, eles somem e outros 3 tomam o seu lugar, e agora não tem como matar eles (reaparecem na hora). Os 3 processos que aparecem são: bash steamtricks e 2 script steamtricks.

Link para os prints: https://imgur.com/a/jsGsW5q

Não sai disso, já tentei baixar do site da steam, mas lá só tem o .deb para ubuntu.

Como fazer a steam funcionar aqui?


  


2. Re: Steam não inicia em opensuse leap 15

-
BiaMonteiro

(usa Arch Linux)

Enviado em 29/11/2018 - 16:54h

Rode o steam através do terminal, digitando o próprio nome steam, e nos informe a saída do comando, irá informar o problema.

Mas sendo mais adiantada, pode ser que o problema seja o driver de vídeo, que não está instalado nem configurado.
A solução, nesse caso, é a seguinte:
1º passo:
Saber qual a placa do computador, usando o comando lspci | grep -i vga.
2º passo:
Caso sua placa de vídeo NVIDIA, siga estes passos: https://pt.opensuse.org/SDB:NVIDIA_drivers.
Para caso seja AMD, siga estes passos: https://pt.opensuse.org/SDB:ATI_drivers
Se for Intel, https://wiki.archlinux.org/index.php/Intel_graphics_(Portugu%C3%AAs). É um artigo do Arch Linux, mas serve para demais distribuições.


3. Re: Steam não inicia em opensuse leap 15

Eduardo Avila
Eduamaro

(usa Linux Mint)

Enviado em 29/11/2018 - 17:07h

Ao rodar o comando STEAM_RUNTIME=0 steam no terminal, a steam começa a atualizar pela interface dela, mas antes de abrir a tela de login, aparece uma mensagem de erro dizendo que me faltam essas bibliotecas 32 bit (mas estranhamente eu marquei para instalar todas as bibliotecas 32bit na instalação do opensuse anteriormente). Eu deveria tentar instalar elas pelo zypper?

ibXtst.so.6
libva.so.1
libvdpau.so.1
libva.so.1
libva-x11.so.1


4. Re: Steam não inicia em opensuse leap 15

Eduardo Avila
Eduamaro

(usa Linux Mint)

Enviado em 29/11/2018 - 17:14h

BiaMonteiro escreveu:

Rode o steam através do terminal, digitando o próprio nome steam, e nos informe a saída do comando, irá informar o problema.

Mas sendo mais adiantada, pode ser que o problema seja o driver de vídeo, que não está instalado nem configurado.
A solução, nesse caso, é a seguinte:
1º passo:
Saber qual a placa do computador, usando o comando lspci | grep -i vga.
2º passo:
Caso sua placa de vídeo NVIDIA, siga estes passos: https://pt.opensuse.org/SDB:NVIDIA_drivers.
Para caso seja AMD, siga estes passos: https://pt.opensuse.org/SDB:ATI_drivers
Se for Intel, https://wiki.archlinux.org/index.php/Intel_graphics_(Portugu%C3%AAs). É um artigo do Arch Linux, mas serve para demais distribuições.


rodando a steam pelo terminal resulta em:
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME is enabled automatically
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Found newer runtime version for 32-bit libdbus-1.so.3. Host: 3.19.4 Runtime: 3.5.8
Found newer runtime version for 32-bit libgtk-x11-2.0.so.0. Host: 0.2400.32 Runtime: 0.2400.10
Found newer runtime version for 64-bit libSDL2-2.0.so.0. Host: 0.8.0 Runtime: 0.9.0
Found newer runtime version for 64-bit libGLU.so.1. Host: 1.3.1 Runtime: 1.3.8004
Found newer runtime version for 64-bit libdbusmenu-glib.so.4. Host: 4.0.12 Runtime: 4.0.13
Found newer runtime version for 64-bit libopus.so.0. Host: 0.6.1 Runtime: 0.7.0
Found newer runtime version for 64-bit libopusfile.so.0. Host: 0.4.3 Runtime: 0.4.4
Found newer runtime version for 64-bit libopusurl.so.0. Host: 0.4.3 Runtime: 0.4.4
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
[2018-11-29 19:08:58] Startup - updater built Nov 26 2018 20:15:21
[2018-11-29 19:08:58] Verifying installation...
[2018-11-29 19:08:58] Unable to read and verify install manifest /home/edu/.local/share/Steam/package/steam_client_ubuntu12.installed
[2018-11-29 19:08:58] Verification complete
[2018-11-29 19:08:58] Downloading update...
[2018-11-29 19:08:58] Checking for available updates...
[2018-11-29 19:08:58] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2018-11-29 19:08:59] Download complete.
[2018-11-29 19:08:59] uninstalled manifest found in /home/edu/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2018-11-29 19:08:59] Extracting package...
[2018-11-29 19:09:09] Installing update...
[2018-11-29 19:09:13] Cleaning up...
[2018-11-29 19:09:13] Update complete, launching Steam...
[2018-11-29 19:09:13] Shutdown
Restarting Steam by request...
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME has been set by the user to: /home/edu/.local/share/Steam/ubuntu12_32/steam-runtime
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)

(steam:19756): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier 'direction', expected character '}'

(steam:19756): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant
sh: lspci: comando não encontrado
Installing breakpad exception handler for appid(steam)/version(1543346820)
[1129/190914.894207:INFO:crash_reporting.cc(216)] Crash reporting enabled for process: browser
[1129/190914.911962:WARNING:crash_reporting.cc(255)] Failed to set crash key: UserID with value: 0
[1129/190914.912053:WARNING:crash_reporting.cc(255)] Failed to set crash key: BuildID with value: 1543263366
[1129/190914.912067:WARNING:crash_reporting.cc(255)] Failed to set crash key: SteamUniverse with value: Public
[1129/190914.912073:WARNING:crash_reporting.cc(255)] Failed to set crash key: Vendor with value: Valve
[1129/190914.919475:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
CAppInfoCacheReadFromDiskThread took 0 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Could not create Vulkan instance :
ERROR_EXTENSION_NOT_PRESENT

E a tela de login da steam abre. Não sei se foi porque rodei o outro comando (o que roda a steam sem runtime), mas parece que ela funcionou normal agora.

rodando o lspci da gpu é retornado isso:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Porém creio que o driver esteja configurado, porque quando tentei rodar o game minecraft para benchmark entre o opensuse e o windows 10, o jogo dizia que o meu driver era o mesa 3 com a second gen intel graphics.




5. Re: Steam não inicia em opensuse leap 15

-
BiaMonteiro

(usa Arch Linux)

Enviado em 29/11/2018 - 17:57h

Eduamaro escreveu:

BiaMonteiro escreveu:

Rode o steam através do terminal, digitando o próprio nome steam, e nos informe a saída do comando, irá informar o problema.

Mas sendo mais adiantada, pode ser que o problema seja o driver de vídeo, que não está instalado nem configurado.
A solução, nesse caso, é a seguinte:
1º passo:
Saber qual a placa do computador, usando o comando lspci | grep -i vga.
2º passo:
Caso sua placa de vídeo NVIDIA, siga estes passos: https://pt.opensuse.org/SDB:NVIDIA_drivers.
Para caso seja AMD, siga estes passos: https://pt.opensuse.org/SDB:ATI_drivers
Se for Intel, https://wiki.archlinux.org/index.php/Intel_graphics_(Portugu%C3%AAs). É um artigo do Arch Linux, mas serve para demais distribuições.


rodando a steam pelo terminal resulta em:
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME is enabled automatically
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Found newer runtime version for 32-bit libdbus-1.so.3. Host: 3.19.4 Runtime: 3.5.8
Found newer runtime version for 32-bit libgtk-x11-2.0.so.0. Host: 0.2400.32 Runtime: 0.2400.10
Found newer runtime version for 64-bit libSDL2-2.0.so.0. Host: 0.8.0 Runtime: 0.9.0
Found newer runtime version for 64-bit libGLU.so.1. Host: 1.3.1 Runtime: 1.3.8004
Found newer runtime version for 64-bit libdbusmenu-glib.so.4. Host: 4.0.12 Runtime: 4.0.13
Found newer runtime version for 64-bit libopus.so.0. Host: 0.6.1 Runtime: 0.7.0
Found newer runtime version for 64-bit libopusfile.so.0. Host: 0.4.3 Runtime: 0.4.4
Found newer runtime version for 64-bit libopusurl.so.0. Host: 0.4.3 Runtime: 0.4.4
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
[2018-11-29 19:08:58] Startup - updater built Nov 26 2018 20:15:21
[2018-11-29 19:08:58] Verifying installation...
[2018-11-29 19:08:58] Unable to read and verify install manifest /home/edu/.local/share/Steam/package/steam_client_ubuntu12.installed
[2018-11-29 19:08:58] Verification complete
[2018-11-29 19:08:58] Downloading update...
[2018-11-29 19:08:58] Checking for available updates...
[2018-11-29 19:08:58] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2018-11-29 19:08:59] Download complete.
[2018-11-29 19:08:59] uninstalled manifest found in /home/edu/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2018-11-29 19:08:59] Extracting package...
[2018-11-29 19:09:09] Installing update...
[2018-11-29 19:09:13] Cleaning up...
[2018-11-29 19:09:13] Update complete, launching Steam...
[2018-11-29 19:09:13] Shutdown
Restarting Steam by request...
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME has been set by the user to: /home/edu/.local/share/Steam/ubuntu12_32/steam-runtime
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)

(steam:19756): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier 'direction', expected character '}'

(steam:19756): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant
sh: lspci: comando não encontrado
Installing breakpad exception handler for appid(steam)/version(1543346820)
[1129/190914.894207:INFO:crash_reporting.cc(216)] Crash reporting enabled for process: browser
[1129/190914.911962:WARNING:crash_reporting.cc(255)] Failed to set crash key: UserID with value: 0
[1129/190914.912053:WARNING:crash_reporting.cc(255)] Failed to set crash key: BuildID with value: 1543263366
[1129/190914.912067:WARNING:crash_reporting.cc(255)] Failed to set crash key: SteamUniverse with value: Public
[1129/190914.912073:WARNING:crash_reporting.cc(255)] Failed to set crash key: Vendor with value: Valve
[1129/190914.919475:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
CAppInfoCacheReadFromDiskThread took 0 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Could not create Vulkan instance :
ERROR_EXTENSION_NOT_PRESENT

E a tela de login da steam abre. Não sei se foi porque rodei o outro comando (o que roda a steam sem runtime), mas parece que ela funcionou normal agora.

rodando o lspci da gpu é retornado isso:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Porém creio que o driver esteja configurado, porque quando tentei rodar o game minecraft para benchmark entre o opensuse e o windows 10, o jogo dizia que o meu driver era o mesa 3 com a second gen intel graphics.


Se o driver está funcionando corretamente, já é um bom passo andado. Tente instalar todos os pacotes que o Steam disser que precisa, como aquelas libs que você apresentou no último comentário, deve ajudar.



6. Re: Steam não inicia em opensuse leap 15

Eduardo Avila
Eduamaro

(usa Linux Mint)

Enviado em 29/11/2018 - 20:21h

BiaMonteiro escreveu:

Eduamaro escreveu:

BiaMonteiro escreveu:

Rode o steam através do terminal, digitando o próprio nome steam, e nos informe a saída do comando, irá informar o problema.

Mas sendo mais adiantada, pode ser que o problema seja o driver de vídeo, que não está instalado nem configurado.
A solução, nesse caso, é a seguinte:
1º passo:
Saber qual a placa do computador, usando o comando lspci | grep -i vga.
2º passo:
Caso sua placa de vídeo NVIDIA, siga estes passos: https://pt.opensuse.org/SDB:NVIDIA_drivers.
Para caso seja AMD, siga estes passos: https://pt.opensuse.org/SDB:ATI_drivers
Se for Intel, https://wiki.archlinux.org/index.php/Intel_graphics_(Portugu%C3%AAs). É um artigo do Arch Linux, mas serve para demais distribuições.


rodando a steam pelo terminal resulta em:
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME is enabled automatically
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Found newer runtime version for 32-bit libdbus-1.so.3. Host: 3.19.4 Runtime: 3.5.8
Found newer runtime version for 32-bit libgtk-x11-2.0.so.0. Host: 0.2400.32 Runtime: 0.2400.10
Found newer runtime version for 64-bit libSDL2-2.0.so.0. Host: 0.8.0 Runtime: 0.9.0
Found newer runtime version for 64-bit libGLU.so.1. Host: 1.3.1 Runtime: 1.3.8004
Found newer runtime version for 64-bit libdbusmenu-glib.so.4. Host: 4.0.12 Runtime: 4.0.13
Found newer runtime version for 64-bit libopus.so.0. Host: 0.6.1 Runtime: 0.7.0
Found newer runtime version for 64-bit libopusfile.so.0. Host: 0.4.3 Runtime: 0.4.4
Found newer runtime version for 64-bit libopusurl.so.0. Host: 0.4.3 Runtime: 0.4.4
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
[2018-11-29 19:08:58] Startup - updater built Nov 26 2018 20:15:21
[2018-11-29 19:08:58] Verifying installation...
[2018-11-29 19:08:58] Unable to read and verify install manifest /home/edu/.local/share/Steam/package/steam_client_ubuntu12.installed
[2018-11-29 19:08:58] Verification complete
[2018-11-29 19:08:58] Downloading update...
[2018-11-29 19:08:58] Checking for available updates...
[2018-11-29 19:08:58] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2018-11-29 19:08:59] Download complete.
[2018-11-29 19:08:59] uninstalled manifest found in /home/edu/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2018-11-29 19:08:59] Extracting package...
[2018-11-29 19:09:09] Installing update...
[2018-11-29 19:09:13] Cleaning up...
[2018-11-29 19:09:13] Update complete, launching Steam...
[2018-11-29 19:09:13] Shutdown
Restarting Steam by request...
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME has been set by the user to: /home/edu/.local/share/Steam/ubuntu12_32/steam-runtime
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)

(steam:19756): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier 'direction', expected character '}'

(steam:19756): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant
sh: lspci: comando não encontrado
Installing breakpad exception handler for appid(steam)/version(1543346820)
[1129/190914.894207:INFO:crash_reporting.cc(216)] Crash reporting enabled for process: browser
[1129/190914.911962:WARNING:crash_reporting.cc(255)] Failed to set crash key: UserID with value: 0
[1129/190914.912053:WARNING:crash_reporting.cc(255)] Failed to set crash key: BuildID with value: 1543263366
[1129/190914.912067:WARNING:crash_reporting.cc(255)] Failed to set crash key: SteamUniverse with value: Public
[1129/190914.912073:WARNING:crash_reporting.cc(255)] Failed to set crash key: Vendor with value: Valve
[1129/190914.919475:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
CAppInfoCacheReadFromDiskThread took 0 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Installing breakpad exception handler for appid(steam)/version(1543346820)
Could not create Vulkan instance :
ERROR_EXTENSION_NOT_PRESENT

E a tela de login da steam abre. Não sei se foi porque rodei o outro comando (o que roda a steam sem runtime), mas parece que ela funcionou normal agora.

rodando o lspci da gpu é retornado isso:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Porém creio que o driver esteja configurado, porque quando tentei rodar o game minecraft para benchmark entre o opensuse e o windows 10, o jogo dizia que o meu driver era o mesa 3 com a second gen intel graphics.


Se o driver está funcionando corretamente, já é um bom passo andado. Tente instalar todos os pacotes que o Steam disser que precisa, como aquelas libs que você apresentou no último comentário, deve ajudar.


Vlw pela ajuda! resolveu! Agora a steam abre normalmente.
Para quem também estiver com o problema, não conseguí achar 2 pacotes:

libva.so.1
libva-x11.so.1

Instalei os seguintes pacotes (e dois que aparentemente eram versões mais novas que esses):
libXtst.so.6
Mesa-libva (para substituir o libva.so.1 me parecia o mais próximo dos disponíveis)
libva2-32bit
libvdpau.so.1
libva-x11-2-32bit (para substituir a libva-x11.so.1)

Se eu rodar a steam pelo terminal ela ainda dá uns erros dizendo que não achou algo relacionado a alguns temas, mas acho que isso é irrelevante.






7. Re: Steam não inicia em opensuse leap 15

Perfil removido
removido

(usa Nenhuma)

Enviado em 30/11/2018 - 20:31h

A solução que eu encontrei foi esse comando:
LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts