Opensuse n atualiza pacotes.

1. Opensuse n atualiza pacotes.

Manu
ManuOnline

(usa Debian)

Enviado em 07/05/2021 - 17:28h


As seguintes 15 atualizações de pacote NÃO serão instaladas:
gettext-runtime gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang libgstphotography-1_0-0 liblzma5 libvlc5 libvlccore9 vlc
vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt vlc-vdpau xz xz-lang
Nada a fazer.



  


2. Re: Opensuse n atualiza pacotes.

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 07/05/2021 - 19:24h

Qual comando utilizou?

# zypper up ou # zypper dup?

Quais repositórios está usando? Poste o resultado com o comando:

#zypper repos



3. Re: Opensuse n atualiza pacotes.

Manu
ManuOnline

(usa Debian)

Enviado em 09/05/2021 - 00:18h

~> sudo zypper up
Carregando dados do repositório...
Lendo os pacotes instalados...

As seguintes 15 atualizações de pacote NÃO serão instaladas:
gettext-runtime gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang libgstphotography-1_0-0 liblzma5 libvlc5 libvlccore9 vlc vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt vlc-vdpau xz
xz-lang
Nada a fazer.

~> sudo zypper dup
Carregando dados do repositório...
Lendo os pacotes instalados...
Aviso: Você está prestes a fazer uma atualização da distribuição com todos os repositórios habilitados. Certifique-se de que esses repositórios são compatíveis antes de continuar. Consulte 'man zypper' para mais informações sobre este comando.
Calculando a atualização da distribuição...
Nada a fazer.


4. Re: Opensuse n atualiza pacotes.

Luiz Cantarino
Cantarino

(usa Debian)

Enviado em 09/05/2021 - 08:13h

Provavelmente é algum repositório habilitado, que está provocando isso... Pode ser que ele tenha pacotes que são incompatíveis, com a versão que está usando, então o zypper mostra que tem atualizações, mas não atualiza para não quebrar o sistema.

Por isso que lhe foi pedido também, o resultado de: "sudo zypper repos"


5. Re: Opensuse n atualiza pacotes.

Manu
ManuOnline

(usa Debian)

Enviado em 09/05/2021 - 10:05h


      90 (maior prioridade)  :  1 repositório
99 (prioridade padrão) : 10 repositórios

# | Alias | Name | Enabled | GPG Check | Refresh
---+---------------------------+--------------------------------------+------------+-----------------+----------
1 | Google-Chrome | Google-Chrome | Sim | (r ) Sim | Não
2 | google-chrome | google-chrome | Sim | (r ) Sim | Sim
3 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1 | Sim | (r ) Sim | Sim
4 | openSUSE_Leap_15.1 | wine | Sim | (r ) Sim | Sim
5 | packman | packman | Sim | (r ) Sim | Sim
6 | repo-debug | Debug Repository | Não | ---- | ----
7 | repo-debug-non-oss | Debug Repository (Non-OSS) | Não | ---- | ----
8 | repo-debug-update | Update Repository (Debug) | Não | ---- | ----
9 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | Não | ---- | ----
10 | repo-non-oss | Repositório Non-OSS | Sim | (r ) Sim | Sim
11 | repo-oss | Repositório principal | Sim | (r ) Sim | Sim
12 | repo-source | Repositório fonte | Sim | (r ) Sim | Sim
13 | repo-source-non-oss | Source Repository (Non-OSS) | Não | ---- | ----
14 | repo-update | Repositório principal de atualização | Sim | (r ) Sim | Sim
15 | repo-update-non-oss | Repositório de atualização (Non-OSS) | Sim | (r ) Sim | Sim
16 | sublime-text | Sublime Text - x86_64 - Stable | Sim | (r ) Sim | Sim




6. Re: Opensuse n atualiza pacotes.

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 09/05/2021 - 10:44h

ManuOnline escreveu:


      90 (maior prioridade)  :  1 repositório
99 (prioridade padrão) : 10 repositórios

# | Alias | Name | Enabled | GPG Check | Refresh
---+---------------------------+--------------------------------------+------------+-----------------+----------
1 | Google-Chrome | Google-Chrome | Sim | (r ) Sim | Não
2 | google-chrome | google-chrome | Sim | (r ) Sim | Sim
3 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1 | Sim | (r ) Sim | Sim
4 | openSUSE_Leap_15.1 | wine | Sim | (r ) Sim | Sim
5 | packman | packman | Sim | (r ) Sim | Sim
6 | repo-debug | Debug Repository | Não | ---- | ----
7 | repo-debug-non-oss | Debug Repository (Non-OSS) | Não | ---- | ----
8 | repo-debug-update | Update Repository (Debug) | Não | ---- | ----
9 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | Não | ---- | ----
10 | repo-non-oss | Repositório Non-OSS | Sim | (r ) Sim | Sim
11 | repo-oss | Repositório principal | Sim | (r ) Sim | Sim
12 | repo-source | Repositório fonte | Sim | (r ) Sim | Sim
13 | repo-source-non-oss | Source Repository (Non-OSS) | Não | ---- | ----
14 | repo-update | Repositório principal de atualização | Sim | (r ) Sim | Sim
15 | repo-update-non-oss | Repositório de atualização (Non-OSS) | Sim | (r ) Sim | Sim
16 | sublime-text | Sublime Text - x86_64 - Stable | Sim | (r ) Sim | Sim



Você tem 2 repositórios para o Google Chrome e o primeiro deles está habilitado para não atualizar automaticamente. Verifique pois somente um é necessário.
Você tem um repositório do openSUSE 15.1 para o Wine. Se usa o wine procure o repositório específico para o openSUSE 15.2. Pode dar conflitos usando repositórios de outras versões.
Repositórios 6,7,8,9,12 e 13 podem ser desabilitados ou excluídos a não ser que você realmente precise deles. São repositórios que contem os fontes dos programas.

As atualizações que não foram instaladas diz respeito a codecs e ao vlc. Essas atualizações são provavelmente do repositório packman e o vlc que você tem instalado provavelmente é do repositório do openSUSE. Por isso os sistema não atualiza para não causar problemas. Seria necessário trocar o vlc pelo que consta no repositório packman.


7. Re: Opensuse n atualiza pacotes.

Manu
ManuOnline

(usa Debian)

Enviado em 17/05/2021 - 17:49h


Desculpe a demora
sudo zypper repos
Prioridades de repositório em vigor: (Veja 'zypper lr -P' para detalhes)
90 (maior prioridade) : 1 repositório
99 (prioridade padrão) : 8 repositórios

# | Alias | Name | Enabled | GPG Check | Refresh
---+---------------------------+--------------------------------------+------------+-----------------+----------
1 | Emulators_Wine | Wine (openSUSE_Leap_15.2) | Sim | (r ) Sim | Sim
2 | google-chrome | google-chrome | Sim | (r ) Sim | Sim
3 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1 | Sim | (r ) Sim | Sim
4 | packman | packman | Sim | (r ) Sim | Sim
5 | repo-debug | Debug Repository | Não | ---- | ----
6 | repo-debug-non-oss | Debug Repository (Non-OSS) | Não | ---- | ----
7 | repo-debug-update | Update Repository (Debug) | Não | ---- | ----
8 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | Não | ---- | ----
9 | repo-non-oss | Repositório Non-OSS | Sim | (r ) Sim | Sim
10 | repo-oss | Repositório principal | Sim | (r ) Sim | Sim
11 | repo-source | Repositório fonte | Não | ---- | ----
12 | repo-source-non-oss | Source Repository (Non-OSS) | Não | ---- | ----
13 | repo-update | Repositório principal de atualização | Sim | (r ) Sim | Sim
14 | repo-update-non-oss | Repositório de atualização (Non-OSS) | Sim | (r ) Sim | Sim
15 | sublime-text | Sublime Text - x86_64 - Stable | Sim | (r ) Sim | Sim


Retornaram outros pacotes
sudo zypper up
Carregando dados do repositório...
Lendo os pacotes instalados...

As seguintes 6 atualizações de pacote NÃO serão instaladas:
gettext-runtime libFAudio0 libFAudio0-32bit liblzma5 xz xz-lang
Nada a fazer.



8. Re: Opensuse n atualiza pacotes.

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 17/05/2021 - 20:55h

Retornaram outros pacotes
sudo zypper up
Carregando dados do repositório...
Lendo os pacotes instalados...

As seguintes 6 atualizações de pacote NÃO serão instaladas:
gettext-runtime libFAudio0 libFAudio0-32bit liblzma5 xz xz-lang
Nada a fazer.


Essa atualização não será instalada pelo fato que esse pacote consta no repositório do Wine com uma versão superior ao que consta no repositório oficial da distro. Na postagem dos repositórios indica que existe um repositório com prioridade maior que os demais e embora não mostre qual seja imagino que seja o repositório oficial do openSUSE. Sendo assim, como existe uma prioridade nesse repositório, pacotes de outros repositórios não são instalados mesmo que tenham versões mais atuais. Nesse caso aqui também é necessário usar o comando #zypper up --from "nome do repositório" (sem as apas) para instalar essas atualizações.



9. Re: Opensuse n atualiza pacotes.

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 18/05/2021 - 08:22h

É recomendável que deixe todos os repositórios com a mesma prioridade (padrão 99) para que mensagens como essas não aconteçam. Além disso não é recomendável usar repositórios de versões anteriores como esse do Wine que é para o openSUSE 15.1 para evitar conflitos ente os pacotes.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts