Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

1. Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

Marciano Santos
Marteano

(usa openSUSE)

Enviado em 04/09/2018 - 11:26h

Bom dia a todos,

Estamos migrando as máquinas aqui da empresa para o Opensuse 15 Leap e há uma máquina que está bugando a tela do KDE.
https://drive.google.com/file/d/1pWKGGsRv7BnUemzrHQQZzOd0cCdJeXxa/view?usp=sharing 


Tudo continua funcionando mas não dá de ler nada, fica tudo assim travado. Se eu reiniciar a parte gráfica do sistema (CTRL + ALT + BACKSPACE) volta a funcionar mas isso acontece várias vezes ao dia causando irritação no usuário.

A placa mãe é uma Asus H81M-E com vídeo onboard. Vi que o sistema está usando o driver de vídeo genérico Nouveau.
Acessei o site da Asus e não tem driver de vídeo para Linux. Acessei o manual da placa de vídeo e não dá detalhes do vídeo:

https://drive.google.com/file/d/1HL3K_9J9TZfLcKmUPiu2Ckil-zBurVpD/view?usp=sharing 


Alguém já passou por isso e poderia me dar um norte do que fazer?
Obrigado pela atenção.




  


2. Re: Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

Luiz Cantarino
Cantarino

(usa Debian)

Enviado em 04/09/2018 - 20:24h

Tente ir em no Compositor e selecionar XRender...


3. Re: Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 04/09/2018 - 20:26h

Você não pode (ou pelo menos não deveria poder) usar o nouveau com uma placa integrada da intel. Qual o resultado de lspci -k?


4. Re: Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

Marciano Santos
Marteano

(usa openSUSE)

Enviado em 05/09/2018 - 09:06h

Cantarino escreveu:

Tente ir em no Compositor e selecionar XRender...


Bom dia,
Ele veio originalmente como OpenGL 2.0 e até alterei para 3.1 mas não lembrei de mudar para XRender.
Agora Alterei para XRender e já solicitei para a pessoa me informar se resolveu o problema ou se continua.


5. Re: Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

Marciano Santos
Marteano

(usa openSUSE)

Enviado em 05/09/2018 - 09:11h

pylm escreveu:

Você não pode (ou pelo menos não deveria poder) usar o nouveau com uma placa integrada da intel. Qual o resultado de lspci -k?


Bom dia,
Segue o resultado do comando lspci -k
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: hsw_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:02.0 VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: i915
Kernel modules: i915
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: xhci_hcd
Kernel modules: xhci_pci
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: mei_me
Kernel modules: mei_me
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8576
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d5)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: lpc_ich
Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: ahci
Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: i801_smbus
Kernel modules: i2c_i801
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller
Kernel driver in use: r8169
Kernel modules: r8169
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
Subsystem: ASUSTeK Computer Inc. Device 8554
Kernel driver in use: r8169
Kernel modules: r8169


Interessante...
00:02.0 VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: i915
Kernel modules: i915

Isso significa que ele está usando o driver de vídeo original da Intel?
Obrigado pela atenção




6. Re: Opensuse 15 Leap com KDE bugando a tela

Marciano Santos
Marteano

(usa openSUSE)

Enviado em 05/09/2018 - 09:33h

Marteano escreveu:

Cantarino escreveu:

Tente ir em no Compositor e selecionar XRender...


Bom dia,
Ele veio originalmente como OpenGL 2.0 e até alterei para 3.1 mas não lembrei de mudar para XRender.
Agora Alterei para XRender e já solicitei para a pessoa me informar se resolveu o problema ou se continua.


Infelizmente o problema ocorreu uns 15 minutos após alterar o compositor para XRender.
https://drive.google.com/file/d/1Z2hjoUzB3iThZE7yODOrhEHwrVyihgjy/view?usp=sharing

Lembrando que o sistema não trava, se ela clicar nas janelas lá na barra inferior, o sistema irá responder. Esse bug é só visual mesmo mas fica impossível de ver o que as telas apresentam.


7. Re: Opensuse 15 Leap com KDE bugando a tela [RESOLVIDO]

Marciano Santos
Marteano

(usa openSUSE)

Enviado em 13/09/2018 - 10:56h

Agradeço a ajuda de todos mas como o problema persistiu, achei melhor reinstalar o Opensuse Leap 15 novamente.
Após esse procedimento, o problema parou de ocorrer.
Obrigado a todos.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts