ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak [RESOLVIDO]

1. ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak [RESOLVIDO]

Celio Dellamo
rhus

(usa openSUSE)

Enviado em 22/12/2021 - 11:49h

Olá!

Como diz o título deste tópico o "ONVIFViewer" parou de rodar no openSUSE Leap 15.3 - flatpak.

Executo no terminal o seguinte comando, mas o programa não abre.
$ flatpak run net.meijn.onvifviewer

Antes eu controlava as câmeras wifi com o "ONVIFViewer", mas depois de algumas atualizações ele não rodou mais.

Podem me ajudar?

Muito obrigado!!


  


2. MELHOR RESPOSTA

Bruh
Bruuh

(usa Arch Linux)

Enviado em 25/12/2021 - 15:13h


rhus escreveu:


caffilhobr escreveu:

E somente este aplicativo ou mais algum flatpak parou de rodar?

Tente a dica abaixo caso seja mais de um aplicativo.

https://diolinux.com.br/tutoriais/corrigindo-flatpaks-nao-iniciando-no-opensuse-leap.html

Olá!!! Muito obrigado por responder!

Tentei a dica Diolinux, mas não resolveu o problema.

Não sei sobre outras aplicações flatpak, não conheço nenhuma outra além dessa que controla as câmeras wifi.
O que posso dizer é que antes retornava alguns erros dizendo que era qualquer coisa com o qt5 , mas isso não tá aparecendo mais.

Se eu rodar isto 2 vezes:
flatpak run net.meijn.onvifviewer &

Retorna o seguinte no terminal:
Fim da execução com status 139 flatpak run net.meijn.onvifviewer

Muito obrigado!


o código de status 139 te diz que a aplicação crashou antes de abrir. Esse erro pode estar ocorrendo por ter deletado algum arquivo de I/O do pacote acidentalmente.

Faz assim, desinstala e instala de novo o onvifviewer, sempre um santo remédio:

flatpak uninstall net.meijn.onvifviewer 

flatpak install flathub net.meijn.onvifviewer 

flatpak run net.meijn.onvifviewer 


"A emoção mais antiga e mais forte da humanidade é o medo, e o mais antigo e mais forte de todos os medos é o medo do desconhecido."


3. Re: ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 25/12/2021 - 06:25h

E somente este aplicativo ou mais algum flatpak parou de rodar?

Tente a dica abaixo caso seja mais de um aplicativo.

https://diolinux.com.br/tutoriais/corrigindo-flatpaks-nao-iniciando-no-opensuse-leap.html




4. Re: ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak [RESOLVIDO]

Celio Dellamo
rhus

(usa openSUSE)

Enviado em 25/12/2021 - 10:00h


caffilhobr escreveu:

E somente este aplicativo ou mais algum flatpak parou de rodar?

Tente a dica abaixo caso seja mais de um aplicativo.

https://diolinux.com.br/tutoriais/corrigindo-flatpaks-nao-iniciando-no-opensuse-leap.html

Olá!!! Muito obrigado por responder!

Tentei a dica Diolinux, mas não resolveu o problema.

Não sei sobre outras aplicações flatpak, não conheço nenhuma outra além dessa que controla as câmeras wifi.
O que posso dizer é que antes retornava alguns erros dizendo que era qualquer coisa com o qt5 , mas isso não tá aparecendo mais.

Se eu rodar isto 2 vezes:
flatpak run net.meijn.onvifviewer &

Retorna o seguinte no terminal:
Fim da execução com status 139 flatpak run net.meijn.onvifviewer

Muito obrigado!


5. Re: ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak [RESOLVIDO]

Celio Dellamo
rhus

(usa openSUSE)

Enviado em 25/12/2021 - 10:30h


caffilhobr escreveu:

E somente este aplicativo ou mais algum flatpak parou de rodar?

Tente a dica abaixo caso seja mais de um aplicativo.

https://diolinux.com.br/tutoriais/corrigindo-flatpaks-nao-iniciando-no-opensuse-leap.html

Outra coisa... o meu irmão tinha instalado no computador dele o Ubuntu 20,04 LTS e o ONVIFViewer parou de rodar lá também.

Mais uma vez, muto obrigado!



6. Re: ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak

Bruh
Bruuh

(usa Arch Linux)

Enviado em 25/12/2021 - 15:46h

rhus escreveu:


caffilhobr escreveu:

E somente este aplicativo ou mais algum flatpak parou de rodar?

Tente a dica abaixo caso seja mais de um aplicativo.

https://diolinux.com.br/tutoriais/corrigindo-flatpaks-nao-iniciando-no-opensuse-leap.html

Outra coisa... o meu irmão tinha instalado no computador dele o Ubuntu 20,04 LTS e o ONVIFViewer parou de rodar lá também.

Mais uma vez, muto obrigado!


Hmm, se parou rodar em outro computador, que tem outro SO, isso me cheira a problemas com o próprio aplicativo. E tu disse que o problema começou depois de uma atualização?
Nesse caso, delete o app como eu disse, reinstale e faça um downgrade. Nunca usei esse app, mas pelo que vi no flathub está na versão 0.13.
Tente fazer um downgrade pra versão 0.12.

sudo flatpak update \
--commit=4173c1c73929126274a3c45f86bdc8427bf6b547e17432165bf64afb0fc6609d \
net.meijn.onvifviewer


Tenha o cuidado de verificar se esse é o código correto para o commit da versão 0.12. Verifique com o comando:
flatpak remote-info --log flathub net.meijn.onvifviewer 


Também aconselho, se não der certo com essa versão a ir testando outras. Quando/se der certo com uma, é recomendável dar um
flatpak mask net.meijn.onvifviewer 

Para evitar que dê um update no onvifviewer se por acaso tu atualizar teu flatpak com um flatpak update.

"A emoção mais antiga e mais forte da humanidade é o medo, e o mais antigo e mais forte de todos os medos é o medo do desconhecido."



7. Re: ONVIFViewer parou de rodar no openSUSE Leap 15.3 - flatpak [RESOLVIDO]

Celio Dellamo
rhus

(usa openSUSE)

Enviado em 25/12/2021 - 17:16h


Bruuh escreveu:


rhus escreveu:


caffilhobr escreveu:

E somente este aplicativo ou mais algum flatpak parou de rodar?

Tente a dica abaixo caso seja mais de um aplicativo.

https://diolinux.com.br/tutoriais/corrigindo-flatpaks-nao-iniciando-no-opensuse-leap.html

Olá!!! Muito obrigado por responder!

Tentei a dica Diolinux, mas não resolveu o problema.

Não sei sobre outras aplicações flatpak, não conheço nenhuma outra além dessa que controla as câmeras wifi.
O que posso dizer é que antes retornava alguns erros dizendo que era qualquer coisa com o qt5 , mas isso não tá aparecendo mais.

Se eu rodar isto 2 vezes:
flatpak run net.meijn.onvifviewer &

Retorna o seguinte no terminal:
Fim da execução com status 139 flatpak run net.meijn.onvifviewer

Muito obrigado!


o código de status 139 te diz que a aplicação crashou antes de abrir. Esse erro pode estar ocorrendo por ter deletado algum arquivo de I/O do pacote acidentalmente.

Faz assim, desinstala e instala de novo o onvifviewer, sempre um santo remédio:

flatpak uninstall net.meijn.onvifviewer 

flatpak install flathub net.meijn.onvifviewer 

flatpak run net.meijn.onvifviewer 


"A emoção mais antiga e mais forte da humanidade é o medo, e o mais antigo e mais forte de todos os medos é o medo do desconhecido."
Funcionou!!!

As duas câmeras estão aparecendo direitinho.

Muito obrigado!!!