Montando Servidor de Internet com Ubuntu Server

1. Montando Servidor de Internet com Ubuntu Server

Lusmar
lusmar

(usa Ubuntu)

Enviado em 29/10/2018 - 09:35h

Bom dia/Boa tarde/Boa noite,
Link referencia: https://www.vivaolinux.com.br/artigo/Montando-Servidor-de-Internet-com-Ubuntu-Server?pagina=1

Estou tentando desenvolver um Servidor de internet com Ubuntu server, porem estou com alguns problemas.
CONSIDERAÇÕES:
1- Diferente do que mandei no link acima, eu só tenho uma conexão com a internet então não vou fazer o processo de "Failover"
2- Estou utilizando o sistema Ubuntu Server 14.04

PROBLEMA:
1° problema:quando tento alterar o /etc/network/interfaces para a placa que vai se conectar a internet, a internet cai, mas em DHCP funciona normalmente.
#Link da Internet
auto eth0
iface eth0 inet static
address 192.168.0.254
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.10

#Rede Local
# Rede Local
auto eth1
iface eth1 inet static
address 10.10.10.254
netmask 255.255.255.0
network 10.10.10.0
broadcast 10.10.10.255
gateway 10.10.10.10

2° problema, eu estou conseguindo ja controlar o IP das ouras maquinas e mandar as informações pela outra placa, mas não envia a internet

OBS¹: Acredito que o erro esta nesta parte, pois da mesma forma que não tenho internet quando configuro o eth0 talbem deve haver algum erro no eth1.
OBS²: Como disse antes o "/etc/default/isc-dhcp-server" e "/etc/dhcp/dhcpd.conf" estão (aparentemene) funcionando normalmente, ja que as outras maquinas estão reebendo o IP novo mas não a internet.
OBS³: todo o restante da rede é Windows 7 e 10.


Desde já muito obrigado.


  


2. Re: Montando Servidor de Internet com Ubuntu Server

3. Re: Montando Servidor de Internet com Ubuntu Server

Lusmar
lusmar

(usa Ubuntu)

Enviado em 29/10/2018 - 11:04h


vlw pela dica,
acabi de fazer o que esta descrito ai, porem ainda sem internet nas maquinas. o erro é que:

qualquer coisa que eu coloque aqui
auto eth0
iface eth0 inet static
address 192.168.0.254
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.10


ate pelo
auto eth0
iface eth0 inet dhcp


a net cai, so funciona se eu deixo totalmente em branco.

mas ainda assim não partilha a net


4. Re: Montando Servidor de Internet com Ubuntu Server

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 29/10/2018 - 12:27h

Ola,

saindo um pouco do assunto, porque o Ubuntu Server 14.04? Em 6 meses esta versão irá perder o suporte, e pode ser um risco de segurança para a sua rede! Por que não usar as versões 16.04 (perde o suporte em 04/2021) ou 18.04 (perde o suporte em 04/2023)?


5. Re: Montando Servidor de Internet com Ubuntu Server

Lusmar
lusmar

(usa Ubuntu)

Enviado em 29/10/2018 - 15:21h

StanislausK escreveu:

Ola,

saindo um pouco do assunto, porque o Ubuntu Server 14.04? Em 6 meses esta versão irá perder o suporte, e pode ser um risco de segurança para a sua rede! Por que não usar as versões 16.04 (perde o suporte em 04/2021) ou 18.04 (perde o suporte em 04/2023)?


sem problema em sair um pouco, é que inicialmente tentei com o xubunutu 18 depois o ubunutu e depois o ubunutu server mais novo, vim regredindo e sempre topndo com o mesmo erro.



6. Re: Montando Servidor de Internet com Ubuntu Server

Lusmar
lusmar

(usa Ubuntu)

Enviado em 29/10/2018 - 16:31h

meianoite escreveu:

Servidor com algo derivado é uma aventura.


até sou fã de RPG de mesa, mas aqui é um pouco mais serio rs.

emfim, alguma dica? por que ainda to pedidaço rsrs



7. Re: Montando Servidor de Internet com Ubuntu Server

Patrick Ernandes
patrickernandes

(usa Debian)

Enviado em 29/10/2018 - 18:51h

vamos la,

- você está colocando seu servidor conectado com a internet com ip fixo, correto!
Pode acontecer de seu modem está distribuindo ips via dhcp, então pode ocorrer conflito e vc perder a conexão, é uma possibilidade..

- voce precisa ativar o ip_forward pra distribuir a conexão te internet para a rede local. isso deve resolver.

* Sugestão de sistema para roteador, Vyos.
Qualquer coisa, a disposição..

att,