Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

1. Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 08/02/2014 - 13:21h

Olá pinguins.

Venho pedir uma ajuda.

Fiz o upgrade do sistema Mageia da versão 3 para a 4.
Deixei fazendo o upgrade ontem a noite e fui dormi pois o sono foi mais forte.

Depois do upgrade, reiniciei o sistema e o mesmo reiniciou de boa.

Notei que algumas anomalias no sistema, como o Centro de Controle Mageia (MMC), após clicar no mesmo ele não abre.

Ícones no navegador (firefox) e gerenciador de email (thunderbird) estão com um 'x' vermelho no lugar de alguns ícone que deveria estar ali, isso não em todos.

Ou seja, como 'são linux' não estava presente, acho que deu alguma zica na hora do upgrade, mais como deixei rolando de madrugada e no final quando acordei as 4 da matina, o mesmo já estava atualizado parado no curso do terminal não apresentando nenhum erro aparente.

Segui essa orientação do wiki:

https://wiki.mageia.org/en/Mageia_4_Release_Notes#Upgrading_from_Mageia_3

Removi primeiro as medias com o comando:


# urpmi.removemedia -a


Logo depois adicionei a media no modo automático:


# urpmi.addmedia --distrib --mirrorlist http://mirrors.mageia.org/api/mageia.4.x86_64.list


Em seguida, após ter adicionado as medias, rodei o comando para o upgrade:


# urpmi --replacefiles --auto-update --auto


Depois desse último comando, que demorou bastante (ficou madrugada a dentro, rs) reiniciei o sistema.

dando continuidade rodei o comando:


# urpmi --auto-update


Esse me retornou que tinha 340 pacotes orfãns, pedindo então para remover. Executei:


# urpme --auto-orphans


Agora peço uma ajuda aos pinguins mais assíduos do Mageia para me dar uma ajuda.

O centro de controle do mageia não abre. Como posso tentar fazer uma instalação dele novamente?

Vou ficar observando mais o que pode estar acontecendo e verificar se tem mais anomalias.

Sei que muitos já vão falar para instalar do zero para ter a instalação toda limpa, mais o aprendizado fica mais aguçado fazendo o upgrade.

Já tenho a ISO do Mageia 4 DVD e se isso ajuda a tentar resolver o problema!

Desde já agradeço a atenção dada.



  


2. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 08/02/2014 - 14:00h

Para um complemento.


[[email protected] ~]$ cat /etc/issue
Mageia release 4 (Official) for x86_64
Kernel 3.12.8-desktop-2.mga4 on a 4-processor x86_64 / \l
[[email protected] ~]$


Vemos que já foi atualizado para o Mageia 4 com o kernel 3.12.8.

Agora estou no processo de atualização novamente para ver se resolve os problemas percebidos.

Adicionei novamente a mídia, pois no update relatou que não tinha nada a atualizar pedindo para adicionar mídia:


[[email protected] mcnd2]# urpmi.update -a
nada a atualizar (use urpmi.addmedia para adicionar uma mídia)
[[email protected] mcnd2]# urpmi.addmedia --distrib --mirrorlist http://mirrors.mageia.org/api/mageia.4.x86_64.list


... no processo de atualização de 493 pacotes, removendo mga3 e atualizando para mga4 ...


3. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 08/02/2014 - 14:51h

Acabou a atualização e sem fazer nada fui logo abrir o CCM e o Firefox onde notei as anomalias...

Xuxexo... logo ao clicar no Centro de Controle Mageia o mesmo pediu senha de root e abriu sua interface gráfica. O mesmo aconteceu com o Firefox, ao abrir os ícones estavam todos lá como deveria estar desde o primeiro momento.

Como dito, deve ter dado alguma zica. Como fui dormi e 'são linux' não estava de plantão ontem aconteceu esse inesperado problema.

Uma grande observação.

Antes do processo de upgrade meu sistema mageia 3 estava todo atualizado com as últimas atualizações disponíveis instaladas.

Então a possibilidade de fazer o upgrade do Mageia 3 para o 4 é 100%.

Fica aqui minha experiência para que sirva de ajuda para outros que venham ter problemas semelhantes.

Vlw...


4. Odisséia...

Glauber GF
mcnd2

(usa Debian)

Enviado em 08/02/2014 - 15:45h

Os problemas ainda continuam ao explorar o sistema, rS!

Agora, com o Centro de Controle Mageia aberto, em adicionar e remover programas me retorna erro:


O programa "drakrpm" foi finalizado com o seguinte erro:

undefined value for mandatory argument 'is_active' encountered at /usr/libexec/drakrpm line 704.
Perl's trace:
standalone::bug_handler() called from /usr/lib/perl5/5.18.1/Carp.pm:100
Carp::croak() called from /usr/lib/perl5/vendor_perl/5.18.1/x86_64-linux-thread-multi/Glib/Object/Introspection.pm:59
Glib::Object::Introspection::__ANON__() called from /usr/libexec/drakrpm:704
main::run_treeview_dialog() called from /usr/libexec/drakrpm:846

tema usado: oxygen-gtk

Para reportar um problema, clique no botão Enviar.
Isto abre uma janela no navegador web em Bugzilla com um formulário para preencher. Estas Informações serão transferidas para este servidor
É muito útil adicionar ao seu relatório do problema a saída do seguinte comando : 'lspcidrake -v'.


Vou deixar a imagem da janela de erro com a mensagem acima.

Imagem:

http://sdrv.ms/1cfH5EU

Pelo terminal, ao tentar abrir com o drakrpm:


[[email protected] mcnd2]# drakrpm
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 296.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Use of uninitialized value $value in numeric eq (==) at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 545.
Impossible to set by_group view as default
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.18.1/Gtk3.pm line 296.
Error creating proxy: A conexão está fechada (g-io-error-quark, 18)


Assim aparecendo a imagem postada.

???


5. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 08/02/2014 - 20:55h

-por principio eu não faço atualização de uma versão p/ outra em distros não rolling releases
-sempre faço instalaço limpa do ubuntu, linuxmint, mageia
-por isso sempre deixo partição BKP seperada p/ evitar aborrecimentos


6. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 08/02/2014 - 21:21h

clodoaldops escreveu:

-por principio eu não faço atualização de uma versão p/ outra em distros não rolling releases
-sempre faço instalaço limpa do ubuntu, linuxmint, mageia
-por isso sempre deixo partição BKP seperada p/ evitar aborrecimentos


Então clodô...

Tenho também partição de backup sem problema, mais caso perca algo que esta na distro, não é de deixar em desespero, rS!

Mais o negócio e não fazer estilo janelas. Se temos a opção de um upgrade, o porque não o fazer?

Mais tudo deu certo apesar de eu não acompanhar o upgrade de perto.

'São linux' estava de folga e eu acabei 'caindo' no sono, rS!

Mais tá rolando bonitinho o Mageia depois do upgrade do 3 para o 4.

Alguns probleminhas iniciais que já foram sanados. Sanados alguns, encontrado outro...

Assim a mente fica aguçada a saber de como resolver o problema.

Meu problema é com o "drakrpm" que esta me retornando erro de 'perl' e 'gtk3'.

'Vamo q vamo' atrás dos objetivos...

UUhhhhuuuu... Isso é GNU/linux...


7. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 09/02/2014 - 00:16h

UP ^ ...

Alguém com alguma ideia de como posso sanar esse problema?

O Mageia já atualizou o kernel para o 3.12.9 mais ainda continua com o problema.

Já tentei fazer o downgrade do pacote perl5 referenciado, mais não obtive sucesso pois o urpmi fez um clean no cache.

Baixei o perl-base-5.16.3-1.mga3.x86_64.rpm para tentar fazer a instalação mais acusa que tem uma versão mais nova!

Tentei desinstalar a versão atual com urpme --allow-nodeps perl mais acusa que deverá desinstalar 196 pacotes.

Tô doido, tô doido, tô doido...

Metade do sábado tentando resolver mais sem sucesso.

drakrpm e perl f*lh*s d* p*t*...

Valeu a atenção dada...



8. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 09/02/2014 - 12:42h

Como não obtive nenhum resultado satisfatório nas minhas pesquisas e não tive nenhuma resposta também aqui, estou pensando em desinstalar toda interface gráfica e depois dar um clean no cahe e fazer a instalação da interface novamente para ver se o problema foi por causa do upgrade na interface gráfica ou se esta relacionado mesmo o bug com perl e drakrpm.

O sistema esta todo funcional. Instalação de programas pelo terminal e todos os programas que testei como navegador, player, efeitos 3D, etc, funcionam sem problema. A única coisa que notei foi esse problema com o drakrpm. As outras funções dentro do Centro de Controle Mageia (CCM) abrem numa boa, só esse bendito instalar e remover programas (drakrpm/rpmdrake) que esta me deixando com fios de cabelos a menos, rS!

...


9. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 09/02/2014 - 15:57h

Por essa semana, chega!

Vou esperar para ver se com alguma atualização, o problema se resolva.

Reportei o bug ao bugzilla do mageia:

https://bugs.mageia.org/show_bug.cgi?id=12688

Se alguém tiver alguma dica, estou a disposição de enfrentar essa odisseia.

Afinal, se não acertar e só piorar as coisas, o Mageia-4-x86_64-DVD.iso vai te que ser utilizado, rs!

...


10. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 11/02/2014 - 23:18h

Caros amigos, acabei de instalar o Mageia 4 DVD KDE, pois tentei algumas coisas para sanar o problema do bug, mais nada.

Então retirei o Mageia 4 upgrade que fiz, e como ja ouvi muitos dizerem, fiz uma instalação limpa.

Vou explorar o sistema como estava explorando com o do upgrade para verificar as diferenças.

Deixarei o tópico como resolvido, mais sem ter realmente resolvido o problema.

Quem sabe o upgrade do 4 para o 5 ocorra tudo bem!?...

Até...


11. Mesmo problema, com solução

Jonas Oliveira Francisco
jonasof

(usa Mageia)

Enviado em 12/02/2014 - 00:32h

Tive o mesmo problema ao atualizar para o Mageia 4.

O tópico oficial deste bug está disponível neste endereço:https://bugs.mageia.org/show_bug.cgi?id=12390#c11

O último comentário de Thierry Vignaud indica que o bug foi corrigido no pacote "perl-Glib-Object-Introspection-0.18.0-2.mga4". Procurei este pacote nos repositóios oficiais e o encontrei dentro da pasta update. Achei um pouco estranho o Mageia não tê-lo atualizado automaticamente mesmo após urpmi --update --auto-select e urpmi --auto select.



Instruções para corrigir bug:

Baixe o pacote para sua arquitetura:

i586: http://mageia.c3sl.ufpr.br/distrib/4/i586/media/core/updates/perl-Glib-Object-Introspection-0.18.0-2...

X86_64: http://mageia.c3sl.ufpr.br/distrib/4/x86_64/media/core/updates/perl-Glib-Object-Introspection-0.18.0...

Após isto, com o terminal localizado no diretório de download do arquivo .rpm e com super usuário, instale-o via urpmi:

urpmi <nome do arquivo baixado>

Logo após instalá-lo, o rpmdrake estará funcionando corretamente (caso não acontecido algum erro).


12. Re: Upgrade Mageia - da versão 3 para 4 [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 12/02/2014 - 14:54h

mcnd2 escreveu:

Caros amigos, acabei de instalar o Mageia 4 DVD KDE, pois tentei algumas coisas para sanar o problema do bug, mais nada.

Então retirei o Mageia 4 upgrade que fiz, e como ja ouvi muitos dizerem, fiz uma instalação limpa.

Vou explorar o sistema como estava explorando com o do upgrade para verificar as diferenças.

Deixarei o tópico como resolvido, mais sem ter realmente resolvido o problema.

Quem sabe o upgrade do 4 para o 5 ocorra tudo bem!?...

Até...


-minha filosofia: em distro não rolling-release faça instalação limpa e evite aborrecimentos!




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts