APT-GET da erro

1. APT-GET da erro

Allan Marcello
allanmarcello

(usa KUbuntu)

Enviado em 25/11/2014 - 20:14h

Boa noite pessoal, estou com alguns problemas não consigo atualizar meu linux estou usando backtrank 5 kde 32bits
Não sei nada de linux estou começando a usar ele agora mas queria ja começar com essa versão pois é a mais bonita que eu acho. Claro não é uma versao para usuarios comum sei disso. enfim ai vai o erro:

root@bt:~# sudo apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (2: No such file or directory)
E: Unable to lock the list directory
root@bt:~# sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-webkit (>= 4:4.6.1); however:
Package libqt4-webkit is not installed.
dpkg: error processing skype (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of google-chrome-stable:
google-chrome-stable depends on gconf-service; however:
Package gconf-service is not installed.
google-chrome-stable depends on libasound2 (>= 1.0.23); however:
Version of libasound2 on system is 1.0.22-0ubuntu7.
google-chrome-stable depends on libgconf-2-4 (>= 2.31.1); however:
Package libgconf-2-4 is not installed.
google-chrome-stable depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
Package libgdk-pixbuf2.0-0 is not installed.
google-chrome-stable depends on libglib2.0-0 (>= 2.28.0); however:
Version of libglib2.0-0 on system is 2.24.1-0ubuntu1.
google-chrome-stable depends on libgtk2.0-0 (>= 2.24.0); however:
Version of libgtk2.0-0 on system is 2.20.1-0ubuntu2.
google-chrome-stable depends on libnspr4 (>= 1.8.0.10); however:
Package libnspr4 is not installed.
google-chrome-stable depends on libnss3 (>= 3.14.3); however:
Package libnss3 is not installed.
google-chrome-stable depends on libstdc++6 (>= 4.6); however:
Version of libstdc++6 on system is 4.4.3-4ubuntu5.
google-chrome-stable depends on libx11-6 (>= 2:1.4.99.1); however:
Version of libx11-6 on system is 2:1.3.2-1ubuntu3.
google-chrome-stable depends on libxfixes3 (>= 1:5.0); however:
Version of libxfixes3 on system is 1:4.0.4-1.
google-chrome-stable depends on libappindicator1; however:
Package libappindicator1 is not installed.
dpkg: error processing google-chrome-stable (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
skype
google-chrome-stable



  


2. Re: APT-GET da erro

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/11/2014 - 20:27h

sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade


3. Re: APT-GET da erro

Pedro
px

(usa Debian)

Enviado em 25/11/2014 - 21:35h

Nem tenta leke, o BT foi descontinuado até onde eu sei... agora a distro de pen teste da "modinha" deles é o Kali linux ^^


4. Re: APT-GET da erro

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/11/2014 - 21:45h

px escreveu:

Nem tenta leke, o BT foi descontinuado até onde eu sei... agora a distro de pen teste da "modinha" deles é o Kali linux ^^


-é vero... backtrack foi descontinuado em 2013... agora é kali linux



5. Re: APT-GET da erro

Janis joplin
Joplin

(usa Slackware)

Enviado em 26/11/2014 - 00:21h

tente os comandos a seguir
$ apt-get clean
$ apt-get clean all
$ apt-get autoclean

se nada resolver tente mudar seus repositorios
faça um teste com os repositorios do kali

$ leafpad /etc/apt/source.list

adicione as linhas a seguir

deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

boa sorte


6. Re: APT-GET da erro

Thiago Henrique Hüpner
Thihup

(usa Linux Mint)

Enviado em 26/11/2014 - 11:31h

allanmarcello escreveu:

Boa noite pessoal, estou com alguns problemas não consigo atualizar meu linux estou usando backtrank 5 kde 32bits
Não sei nada de linux estou começando a usar ele agora mas queria ja começar com essa versão pois é a mais bonita que eu acho. Claro não é uma versao para usuarios comum sei disso. enfim ai vai o erro:

root@bt:~# sudo apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (2: No such file or directory)
E: Unable to lock the list directory
root@bt:~# sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-webkit (>= 4:4.6.1); however:
Package libqt4-webkit is not installed.
dpkg: error processing skype (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of google-chrome-stable:
google-chrome-stable depends on gconf-service; however:
Package gconf-service is not installed.
google-chrome-stable depends on libasound2 (>= 1.0.23); however:
Version of libasound2 on system is 1.0.22-0ubuntu7.
google-chrome-stable depends on libgconf-2-4 (>= 2.31.1); however:
Package libgconf-2-4 is not installed.
google-chrome-stable depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
Package libgdk-pixbuf2.0-0 is not installed.
google-chrome-stable depends on libglib2.0-0 (>= 2.28.0); however:
Version of libglib2.0-0 on system is 2.24.1-0ubuntu1.
google-chrome-stable depends on libgtk2.0-0 (>= 2.24.0); however:
Version of libgtk2.0-0 on system is 2.20.1-0ubuntu2.
google-chrome-stable depends on libnspr4 (>= 1.8.0.10); however:
Package libnspr4 is not installed.
google-chrome-stable depends on libnss3 (>= 3.14.3); however:
Package libnss3 is not installed.
google-chrome-stable depends on libstdc++6 (>= 4.6); however:
Version of libstdc++6 on system is 4.4.3-4ubuntu5.
google-chrome-stable depends on libx11-6 (>= 2:1.4.99.1); however:
Version of libx11-6 on system is 2:1.3.2-1ubuntu3.
google-chrome-stable depends on libxfixes3 (>= 1:5.0); however:
Version of libxfixes3 on system is 1:4.0.4-1.
google-chrome-stable depends on libappindicator1; however:
Package libappindicator1 is not installed.
dpkg: error processing google-chrome-stable (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
skype
google-chrome-stable


Digite :


sudo apt-get remove --purge skype google-chrome-stable
sudo apt-get update
sudo apt-get upgrade


Espero ter ajudado

[]'s

T+







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts