Rede não funciona - Manjaro XFCE [RESOLVIDO]

1. Rede não funciona - Manjaro XFCE [RESOLVIDO]

hauck
hauck

(usa Nenhuma)

Enviado em 09/01/2021 - 11:09h

Vi que pode ser um problema do Network Manager no Manjaro XFCE, mas depois de rodar uns 2 comandos depois de ligar a máquina a rede volta a funcionar.
Ligando o NetworkManager manualmente pelo comando systemctl start NetworkManager a rede volta.
Executei o comando systemctl list-unit-files --state=enabled e o resultado é mostrado na imagem.
Eu vi também que o nome da placa de rede wireless foi mudado de wlp2s0 para wlan0.
Um downgrade do Network Manager resolve?

Atualização, antes de postar essa pergunta achei o systemd-networkd e ele está parado.
Eu só preciso executar ele para a rede funcionar já no boot? Poderiam me ajudar?
systemctl status systemd-networkd



  


2. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

hauck
hauck

(usa Nenhuma)

Enviado em 09/01/2021 - 11:11h

Não quero fazer cagada no meu sistema, então antes eu pergunto


3. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 09/01/2021 - 11:15h

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


4. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

hauck
hauck

(usa Nenhuma)

Enviado em 09/01/2021 - 11:25h


leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Você ta certo, mas ele já está habilitado para iniciar junto com o sistema e é mostrado um erro.
Eu inicio ele com systemctl start NetworkManager
Veja a imagem anexa


5. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

Luc
LckLinux

(usa Arch Linux)

Enviado em 09/01/2021 - 11:56h

hauck escreveu:


leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Você ta certo, mas ele já está habilitado para iniciar junto com o sistema e é mostrado um erro.
Eu inicio ele com systemctl start NetworkManager
Veja a imagem anexa


Bom dia. Tua wireless/roteador está usando 2,4 GHZ ou 5? Há relatos de problemas similares com 5 GHZ. Dá uma olhada aqui: https://forum.manjaro.org/t/dell-xps-9560-wifi-connection-breaks-continuously/15585/5


6. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

hauck
hauck

(usa Nenhuma)

Enviado em 09/01/2021 - 15:23h


LckLinux escreveu:

hauck escreveu:


leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Você ta certo, mas ele já está habilitado para iniciar junto com o sistema e é mostrado um erro.
Eu inicio ele com systemctl start NetworkManager
Veja a imagem anexa


Bom dia. Tua wireless/roteador está usando 2,4 GHZ ou 5? Há relatos de problemas similares com 5 GHZ. Dá uma olhada aqui: https://forum.manjaro.org/t/dell-xps-9560-wifi-connection-breaks-continuously/15585/5


O roteador tem suporte as duas bandas, não tenho acesso a configuração dele.
Vou pedir para a operadora deixar apenas com 2.4Ghz, e eu acredito que já está em 2.4
Eu acho que não é esse o problema, já que a máquina inicia com a rede desativada e consigo ligar depois - o gerenciador de rede do Xfce diz que a rede está desabilitada.



7. Re: Rede não funciona - Manjaro XFCE

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 09/01/2021 - 15:43h

leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Tente então
sudo systemctl unmask NetworkManager
E depois o enable


8. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

hauck
hauck

(usa Nenhuma)

Enviado em 09/01/2021 - 16:15h


leandropscardua escreveu:

leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Tente então
sudo systemctl unmask NetworkManager
E depois o enable



Executei, reiniciei a máquina e sem sucesso.
Eu já vi avisos no terminal dizendo para executar systemctl unmask .. mas nesse caso não apareceu.
Conhece um bom substituto, pra remover o networkmanager e usar outro?


9. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

Luc
LckLinux

(usa Arch Linux)

Enviado em 10/01/2021 - 11:52h

hauck escreveu:


leandropscardua escreveu:

leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Tente então
sudo systemctl unmask NetworkManager
E depois o enable



Executei, reiniciei a máquina e sem sucesso.
Eu já vi avisos no terminal dizendo para executar systemctl unmask .. mas nesse caso não apareceu.
Conhece um bom substituto, pra remover o networkmanager e usar outro?


Sim, Wicd é um. Mas, eu ainda leria com atenção demorada o tópico sobre as bandas, 2,4 e 5.
Saúde\o/



10. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

hauck
hauck

(usa Nenhuma)

Enviado em 10/01/2021 - 15:52h


LckLinux escreveu:

hauck escreveu:


leandropscardua escreveu:

leandropscardua escreveu:

Não uso manjaro, mas seria
sudo systemctl enable NetworkManager


Tente então
sudo systemctl unmask NetworkManager
E depois o enable



Executei, reiniciei a máquina e sem sucesso.
Eu já vi avisos no terminal dizendo para executar systemctl unmask .. mas nesse caso não apareceu.
Conhece um bom substituto, pra remover o networkmanager e usar outro?


Sim, Wicd é um. Mas, eu ainda leria com atenção demorada o tópico sobre as bandas, 2,4 e 5.
Saúde\o/



Obrigado pela ajuda gente, vou ver o que consigo fazer.


11. Solução: sistema base Debian

hauck
hauck

(usa Nenhuma)

Enviado em 14/01/2021 - 14:42h

Mudei para o Linux Mint - baseado em Debian/Ubuntu - e até agora está tudo funcionando muito bem.
E ainda estou usando XFCE.

Lenovo Ideapad S145 com AMD Ryzen 7 3700U


12. Re: Rede não funciona - Manjaro XFCE [RESOLVIDO]

Luc
LckLinux

(usa Arch Linux)

Enviado em 14/01/2021 - 14:45h

hauck escreveu:

Mudei para o Linux Mint - baseado em Debian/Ubuntu - e até agora está tudo funcionando muito bem.
E ainda estou usando XFCE.

Lenovo Ideapad S145 com AMD Ryzen 7 3700U


Valeu, pelo feedback, hauck.

Saúde
\o/






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts