eu não consigo instalar wine na distro artix linux baseado em Arch linux

1. eu não consigo instalar wine na distro artix linux baseado em Arch linux

rodrigoneto
covd2021

(usa Outra)

Enviado em 09/10/2020 - 20:08h

pacman -U wine-5.18-2-x86_64.pkg.tar.zst

a resolver dependências...
atenção: não é possível resolver "lib32-fontconfig", uma dependência de "wine"
atenção: não é possível resolver "lib32-lcms2", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxml2", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxcursor", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxrandr", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxdamage", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxi", uma dependência de "wine"
atenção: não é possível resolver "lib32-gettext", uma dependência de "wine"
atenção: não é possível resolver "lib32-freetype2", uma dependência de "wine"
atenção: não é possível resolver "lib32-glu", uma dependência de "wine"
atenção: não é possível resolver "lib32-libsm", uma dependência de "wine"
atenção: não é possível resolver "lib32-libpcap", uma dependência de "wine"
atenção: não é possível resolver "lib32-faudio", uma dependência de "wine"
O seguinte pacote não pode ser atualizado devido a dependências não resolvidas:
wine

:: Deseja ignorar o pacote acima para esta atualização? [s/N] s
a procurar pacotes em conflito...
nada a fazer

não existe nos repositórios também para baixar


  


2. Re: eu não consigo instalar wine na distro artix linux baseado em Arch linux

toh
nemuru

(usa Outra)

Enviado em 10/10/2020 - 13:26h

Tente instalar com pacote do AUR,
lá tem:
aur/wine-git 5.15.r0.g019fcaa3641-1


3. Re: eu não consigo instalar wine na distro artix linux baseado em Arch linux

rodrigoneto
covd2021

(usa Outra)

Enviado em 10/10/2020 - 16:08h

covd2021 escreveu:

pacman -U wine-5.18-2-x86_64.pkg.tar.zst

a resolver dependências...
atenção: não é possível resolver "lib32-fontconfig", uma dependência de "wine"
atenção: não é possível resolver "lib32-lcms2", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxml2", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxcursor", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxrandr", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxdamage", uma dependência de "wine"
atenção: não é possível resolver "lib32-libxi", uma dependência de "wine"
atenção: não é possível resolver "lib32-gettext", uma dependência de "wine"
atenção: não é possível resolver "lib32-freetype2", uma dependência de "wine"
atenção: não é possível resolver "lib32-glu", uma dependência de "wine"
atenção: não é possível resolver "lib32-libsm", uma dependência de "wine"
atenção: não é possível resolver "lib32-libpcap", uma dependência de "wine"
atenção: não é possível resolver "lib32-faudio", uma dependência de "wine"
O seguinte pacote não pode ser atualizado devido a dependências não resolvidas:
wine

:: Deseja ignorar o pacote acima para esta atualização? [s/N] s
a procurar pacotes em conflito...
nada a fazer

não existe nos repositórios também para baixar

conitnua com mesmo error

erro: alvo não encontrado: lib32-giflib
erro: alvo não encontrado: lib32-libpng
erro: alvo não encontrado: lib32-gnutls
erro: alvo não encontrado: lib32-libxinerama
erro: alvo não encontrado: lib32-libxcomposite
erro: alvo não encontrado: lib32-libxmu
erro: alvo não encontrado: lib32-libxxf86vm
erro: alvo não encontrado: lib32-libldap
erro: alvo não encontrado: lib32-mpg123
erro: alvo não encontrado: lib32-openal
erro: alvo não encontrado: lib32-v4l-utils
erro: alvo não encontrado: lib32-alsa-lib
erro: alvo não encontrado: lib32-libxcomposite
erro: alvo não encontrado: lib32-mesa
erro: alvo não encontrado: lib32-libgl
:: Existem 2 fornecedores disponíveis para opencl-icd-loader:

Escolha um número (padrão=1): 1
erro: alvo não encontrado: lib32-opencl-icd-loader
erro: alvo não encontrado: lib32-libxslt
erro: alvo não encontrado: lib32-libpulse
erro: alvo não encontrado: lib32-libva
erro: alvo não encontrado: lib32-gtk3
erro: alvo não encontrado: lib32-gst-plugins-base-libs
erro: alvo não encontrado: lib32-vulkan-icd-loader
erro: alvo não encontrado: lib32-sdl2
erro: alvo não encontrado: lib32-vkd3d
erro: alvo não encontrado: lib32-libcups
erro: alvo não encontrado: lib32-attr
erro: alvo não encontrado: lib32-fontconfig
erro: alvo não encontrado: lib32-lcms2
erro: alvo não encontrado: lib32-libxml2
erro: alvo não encontrado: lib32-libxcursor
erro: alvo não encontrado: lib32-libxrandr
erro: alvo não encontrado: lib32-libxdamage
erro: alvo não encontrado: lib32-libxi
erro: alvo não encontrado: lib32-gettext
erro: alvo não encontrado: lib32-freetype2
erro: alvo não encontrado: lib32-glu
erro: alvo não encontrado: lib32-libsm
erro: alvo não encontrado: lib32-libpcap
erro: alvo não encontrado: lib32-faudio
==> ERRO: 'pacman' falhou a instalação das dependências em falta.
==> Dependências em falta:
-> fontforge
-> mingw-w64-gcc
-> lib32-giflib
-> lib32-libpng
-> lib32-gnutls
-> lib32-libxinerama
-> lib32-libxcomposite
-> lib32-libxmu
-> lib32-libxxf86vm
-> lib32-libldap
-> mpg123
-> lib32-mpg123
-> lib32-openal
-> lib32-v4l-utils
-> lib32-alsa-lib
-> lib32-libxcomposite
-> lib32-mesa
-> lib32-libgl
-> opencl-icd-loader
-> lib32-opencl-icd-loader
-> lib32-libxslt
-> lib32-libpulse
-> lib32-libva
-> lib32-gtk3
-> lib32-gst-plugins-base-libs
-> lib32-vulkan-icd-loader
-> lib32-sdl2
-> vkd3d
-> lib32-vkd3d
-> lib32-libcups
-> sane
-> libgphoto2
-> samba
-> opencl-headers
-> vulkan-headers
-> lib32-attr
-> lib32-fontconfig
-> lib32-lcms2
-> lib32-libxml2
-> lib32-libxcursor
-> lib32-libxrandr
-> lib32-libxdamage
-> lib32-libxi
-> lib32-gettext
-> lib32-freetype2
-> lib32-glu
-> lib32-libsm
-> lib32-gcc-libs
-> lib32-libpcap
-> faudio
-> lib32-faudio
==> ERRO: Não foi possível resolver todas as dependências.




4. Re: eu não consigo instalar wine na distro artix linux baseado em Arch linux

toh
nemuru

(usa Outra)

Enviado em 10/10/2020 - 17:53h

Eu tinha chutado..

Se não deu certo, o correto é seguir a Arch Wiki.
Eu vi que seu sistema é o Artix, não sei se é igual.

Mas na wiki do Arch fala que eles tem o wine
nos repositórios OFICIAIS, porém vc vai ter que
habilitar o repositório MULTILIB .

É até bom que tu não instalou nada até agora..
Se instalou algo, remova antes..

Edite o arquivo
/etc/pacman.conf 


Descomente a seção:
[multilib]
Include = /etc/pacman.d/mirrorlist


Rode
pacman -Sy
pacman -S wine


Deve instalar a versão 5.18
Não recomendo o pacote wine-staging

Refs:
https://wiki.archlinux.org/index.php/wine
https://wiki.archlinux.org/index.php/Official_repositories#multilib





5. Re: eu não consigo instalar wine na distro artix linux baseado em Arch linux

rodrigoneto
covd2021

(usa Outra)

Enviado em 11/10/2020 - 20:09h

nemuru escreveu:

Eu tinha chutado..

Se não deu certo, o correto é seguir a Arch Wiki.
Eu vi que seu sistema é o Artix, não sei se é igual.

Mas na wiki do Arch fala que eles tem o wine
nos repositórios OFICIAIS, porém vc vai ter que
habilitar o repositório MULTILIB .

É até bom que tu não instalou nada até agora..
Se instalou algo, remova antes..

Edite o arquivo
/etc/pacman.conf 


Descomente a seção:
[multilib]
Include = /etc/pacman.d/mirrorlist


Rode
pacman -Sy
pacman -S wine


Deve instalar a versão 5.18
Não recomendo o pacote wine-staging

Refs:
https://wiki.archlinux.org/index.php/wine
https://wiki.archlinux.org/index.php/Official_repositories#multilib





eu consegui resolver

agora estou com problema com winetricks



warning: This package (dotnet45) is broken in wine-5.18. Broken since 5.18. See https://bugs.winehq.org/show_bug.cgi?id=49897 for more info. Use --force to try anyway.

ja usei --force não resolver nada. eu não entendi muito bem esse bug



6. Re: eu não consigo instalar wine na distro artix linux baseado em Arch linux

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 12/10/2020 - 21:23h


nemuru escreveu:

Eu tinha chutado..

Se não deu certo, o correto é seguir a Arch Wiki.
Eu vi que seu sistema é o Artix, não sei se é igual.

Mas na wiki do Arch fala que eles tem o wine
nos repositórios OFICIAIS, porém vc vai ter que
habilitar o repositório MULTILIB .

É até bom que tu não instalou nada até agora..
Se instalou algo, remova antes..

Edite o arquivo
/etc/pacman.conf 


Descomente a seção:
[multilib]
Include = /etc/pacman.d/mirrorlist


Rode
pacman -Sy
pacman -S wine


Deve instalar a versão 5.18
Não recomendo o pacote wine-staging

Refs:
https://wiki.archlinux.org/index.php/wine
https://wiki.archlinux.org/index.php/Official_repositories#multilib





Bom, não sabia dessa do arch de ter que habilitar o multilib. Valeu a informação.

___________________________________________________________
Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts