Problema no WINE

1. Problema no WINE

Pythonux
bielinux

(usa Ubuntu)

Enviado em 26/02/2017 - 10:31h

Estou tentando executar um programa específico no WINE. Quando o rodo, infelizmente aparece o seguinte erro:

err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": libmpg123.so.0: cannot open shared object file: No such file or directory


Como contornar o problema?


  


2. Problema no WINE

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 28/02/2017 - 12:35h

Esse problema pode ter muitas razões:
Sugiro começar verificando se os codecs de MP3 estão instalados no Linux.

Não sei como instalar os codecs no Fedora., mas pode começar instalando os gstreamer
e o pulse áudio completo.

Depois pode-se copiar o dll faltante do Windows para em
cd /home/sue_login/

cd ./wine/drive_c/windows/system32
Note-se que o ./wine é um diretório oculto

Sei que não foi o que você perguntou, mas se você é fã de multi media eu sugiro o Ubuntu Studio,
que é uma distro especial para multi media e está muito a frente de qualquer outra para essa finalidade.
Abraços


3. Re: Problema no WINE

Pythonux
bielinux

(usa Ubuntu)

Enviado em 28/02/2017 - 17:39h

O Fedora está no meu PC principal.
Uso o WINE no PC secundário (Arch Linux), pois desconfio da "segurança" dos programas que eu rodo.

Poderia passar o link da DLL pra download?


4. Re: Problema no WINE

Eric
Grinder

(usa Slackware)

Enviado em 28/02/2017 - 19:06h

Pela msg parece que você não tem o mpg123 instalado, como o wine usa 32bits, certifique-se do seu multilibs
- - - - -
www.github.com/ericfernandesferreira


5. Re: Problema no WINE

Pythonux
bielinux

(usa Ubuntu)

Enviado em 01/03/2017 - 07:47h

Sou um cara muito ocupado, logo não tenho tanto tempo assim para pesquisar.
Não me vejam como preguiçoso, mas gostaria de uma sequência de comandos (script) no terminal pra resolver o problema =/


6. Re: Problema no WINE

Guilherme
Ghost_Shell

(usa Arch Linux)

Enviado em 01/03/2017 - 18:50h

bielinux escreveu:

Sou um cara muito ocupado, logo não tenho tanto tempo assim para pesquisar.
Não me vejam como preguiçoso, mas gostaria de uma sequência de comandos (script) no terminal pra resolver o problema =/


1- vai no arquivo /etc/pacman.conf

vim /etc/pacman.conf

2- descomenta (tira o joguindo da velha do servidor multilib)

3- salva o arquivo

4- sudo pacman -Ss mpg123

5- procura o nome do arquivo versão 32bits

6- instala o arquivo

sudo pacman -S mpg123[versão 32 bits]


Keep it simple stupid!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts