wpa_supplicant não estabelece conexão [RESOLVIDO]

1. wpa_supplicant não estabelece conexão [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/03/2011 - 21:33h

Olá amigos do vol,

Boa noite a todos!!!

Estou aqui postando meu problema com wpa_supplicant para se conectar em um acess point.

vamos ao problema...


- PROBLEMA: TENHO UMA PLACA DE REDE WIRELESS ATHEROS COM O DRIVER ATH9K CARREGADO E PLACA JÁ ESTÁ RECONHECIDA E TRABALHANDO, PORÉM ELA SÓ SE CONECTA AO ACESS POINTR VIA KNETWORK-MANAGER, QUANDO TENTO CONECTAR VIA WPA_SUPPLICANT DÁ ERRO E FICA EM LOOP INFINITO. LOGO ABAIXO MOSTRO COMO PROCEDI:

- O QUE FOI FEITO: gerei o arquivo de configuração wpa_supplicant.conf e coloquei o ssid dentro do arquivo junto com a chave Pré-compartilhada.

# /etc/wpa_supplicant/wpa_supplicant.conf

# wpa_passphrase ssid minhapassprase > /etc/wpa_supplicant/wpa_supplicant.conf

#### Após feito tudo isso rodei o comando wpa_supplicant com seus paramentros. #######

wpa_supplicat -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -d -D wext

OBS: a saida deste comando foi esse loop, que mostrou que chegou a se autenticou com sucesso porém não estabelece a conexão e fica em loop, saida do comando abaixo:

Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
Priority group 0
id=0 ssid='GNU'
Initializing interface (2) 'wlan0'
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
capabilities: key_mgmt 0xf enc 0xf flags 0x0
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 1c:4b:d6:b6:2c:85
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=8
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 932 bytes of scan results (3 BSSes)
CTRL-EVENT-SCAN-RESULTS
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 1c:af:f7:5a:6f:ee ssid='GNU' wpa_ie_len=26 rsn_ie_len=24 caps=0x11
selected based on RSN IE
selected WPA AP 1c:af:f7:5a:6f:ee ssid='GNU'
Try to find non-WPA AP
Trying to associate with 1c:af:f7:5a:6f:ee (SSID='GNU' freq=2412 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
RSN: using IEEE 802.11i/D9.0
WPA: Selected cipher suites: group 8 pairwise 24 key_mgmt 2 proto 2
WPA: set AP WPA IE - hexdump(len=28): dd 1a 00 50 f2 01 01 00 00 50 f2 02 02 00 00 50 f2 02 00 50 f2 04 01 00 00 50 f2 02
WPA: set AP RSN IE - hexdump(len=26): 30 18 01 00 00 0f ac 02 02 00 00 0f ac 02 00 0f ac 04 01 00 00 0f ac 02 00 00
WPA: using GTK TKIP
WPA: using PTK CCMP
WPA: using KEY_MGMT WPA-PSK
WPA: not using MGMT group cipher
WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
No keys have been configured - skip key clearing
wpa_driver_wext_set_drop_unencrypted
State: SCANNING -> ASSOCIATING
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
wpa_driver_wext_associate
wpa_driver_wext_set_psk
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
RSN: Ignored PMKID candidate without preauth flag
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b1a len=11
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8c08 len=33
AssocResp IE wireless event - hexdump(len=25): 01 08 82 84 8b 96 12 24 48 6c 32 04 0c 18 30 60 dd 07 00 0c 43 07 00 00 00
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 1c:af:f7:5a:6f:ee
Association info event
resp_ies - hexdump(len=25): 01 08 82 84 8b 96 12 24 48 6c 32 04 0c 18 30 60 dd 07 00 0c 43 07 00 00 00
State: ASSOCIATING -> ASSOCIATED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
Associated to a new BSS: BSSID=1c:af:f7:5a:6f:ee
No keys have been configured - skip key clearing
Associated with 1c:af:f7:5a:6f:ee
WPA: Association event - clear replay counter
WPA: Clear old PTK
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: SUPP_BE entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Cancelling scan request
RX EAPOL from 1c:af:f7:5a:6f:ee
Setting authentication timeout: 10 sec 0 usec
IEEE 802.1X RX: version=1 type=3 length=95
EAPOL-Key type=2
key_info 0x8a (ver=2 keyidx=0 rsvd=0 Pairwise Ack)
key_length=16 key_data_length=0
replay_counter - hexdump(len=8): 00 00 00 00 00 00 00 01
key_nonce - hexdump(len=32): 0a 5f ba 84 9a 19 0c bc 51 c8 39 a8 a6 82 ca ea 66 06 4e 82 76 40 7e 9a cb c8 ad 5b 41 14 b6 8d
key_iv - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
key_rsc - hexdump(len=8): 00 00 00 00 00 00 00 00
key_id (reserved) - hexdump(len=8): 00 00 00 00 00 00 00 00
key_mic - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
State: ASSOCIATED -> 4WAY_HANDSHAKE
WPA: RX message 1 of 4-Way Handshake from 1c:af:f7:5a:6f:ee (ver=2)
RSN: msg 1/4 key data - hexdump(len=0):
WPA: Renewed SNonce - hexdump(len=32): 0a 6f 47 03 b4 36 0b 1f e9 b4 9c 3a 97 28 cf 1e c6 37 f3 2e fe 2f b8 67 ef 79 71 56 6e 61 c6 77
WPA: PTK derivation - A1=1c:4b:d6:b6:2c:85 A2=1c:af:f7:5a:6f:ee
WPA: PMK - hexdump(len=32): [REMOVED]
WPA: PTK - hexdump(len=64): [REMOVED]
WPA: WPA IE for msg 2/4 - hexdump(len=22): 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
WPA: Sending EAPOL-Key 2/4
RX EAPOL from 1c:af:f7:5a:6f:ee
IEEE 802.1X RX: version=1 type=3 length=175
EAPOL-Key type=2
key_info 0x13ca (ver=2 keyidx=0 rsvd=0 Pairwise Install Ack MIC Secure Encr)
key_length=16 key_data_length=80
replay_counter - hexdump(len=8): 00 00 00 00 00 00 00 02
key_nonce - hexdump(len=32): 0a 5f ba 84 9a 19 0c bc 51 c8 39 a8 a6 82 ca ea 66 06 4e 82 76 40 7e 9a cb c8 ad 5b 41 14 b6 8d
key_iv - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
key_rsc - hexdump(len=8): 00 00 00 00 00 00 00 00
key_id (reserved) - hexdump(len=8): 00 00 00 00 00 00 00 00
key_mic - hexdump(len=16): f7 24 c9 49 b6 5c 4e ea 62 e2 09 5f 01 15 cc c6
RSN: encrypted key data - hexdump(len=80): 4e 3a 08 73 c6 f8 59 57 3c f2 c6 b3 3f 60 51 69 1f e6 d6 84 2f 0b 0d 16 7f 22 50 6c bf 76 c9 0d 5c 60 26 19 52 83 09 ff 50 fc 35 4a ef db e1 f9 18 96 69 3e 14 9c 1c b0 65 25 36 a3 95 4f d6 2b 51 ed 31 dd 49 74 86 d2 75 10 a7 5c 90 7b d9 bd
WPA: decrypted EAPOL-Key key data - hexdump(len=72): [REMOVED]
State: 4WAY_HANDSHAKE -> 4WAY_HANDSHAKE
WPA: RX message 3 of 4-Way Handshake from 1c:af:f7:5a:6f:ee (ver=2)
WPA: IE KeyData - hexdump(len=72): 30 18 01 00 00 0f ac 02 02 00 00 0f ac 02 00 0f ac 04 01 00 00 0f ac 02 00 00 dd 26 00 0f ac 01 01 00 23 4b 42 da 6d 4e ba 65 8d 22 b4 47 cd 67 2a 79 fa 58 0a 2c 46 96 96 2e f0 f1 35 cc e0 16 4f a2 dd 00 00 00 00 00
WPA: Sending EAPOL-Key 4/4
WPA: Installing PTK to the driver.
wpa_driver_wext_set_key: alg=3 key_idx=0 set_tx=1 seq_len=6 key_len=16
EAPOL: External notification - portValid=1
State: 4WAY_HANDSHAKE -> GROUP_HANDSHAKE
RSN: received GTK in pairwise handshake - hexdump(len=34): [REMOVED]
WPA: Group Key - hexdump(len=32): [REMOVED]
WPA: Installing GTK to the driver (keyidx=1 tx=0 len=32).
WPA: RSC - hexdump(len=6): 00 00 00 00 00 00
wpa_driver_wext_set_key: alg=2 key_idx=1 set_tx=0 seq_len=6 key_len=32
WPA: Key negotiation completed with 1c:af:f7:5a:6f:ee [PTK=CCMP GTK=TKIP]
Cancelling authentication timeout
State: GROUP_HANDSHAKE -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 1c:af:f7:5a:6f:ee completed (auth) [id=0 id_str=]
wpa_driver_wext_set_operstate: operstate 0->1 (UP)
WEXT: Operstate: linkmode=-1, operstate=6
EAPOL: External notification - portValid=1
EAPOL: External notification - EAP success=1
EAPOL: SUPP_PAE entering state AUTHENTICATING
EAPOL: SUPP_BE entering state SUCCESS
EAP: EAP entering state DISABLED
EAPOL: SUPP_PAE entering state AUTHENTICATED
EAPOL: SUPP_BE entering state IDLE
EAPOL authentication completed successfully
RTM_NEWLINK: operstate=1 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
EAPOL: startWhen --> 0
EAPOL: disable timer tick
^CCTRL-EVENT-TERMINATING - signal 2 received
Removing interface wlan0
State: COMPLETED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 1->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
wpa_driver_wext_deauthenticate
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures

- NOTA: JÁ TENTEI ME CONECTAR PARANDO O NETWORK-MANAGER, MAS NÃO DEU CERTO, CONTINUOU DA MESMA FORMA, OLHA LÁ EM CIMA DESTACADO A AUTENTICAÇÃO FEITA.

######### E quando uso outro driver no comando, ( o driver que está controlando a placa de rede wireless ele dá essa saida ai o:

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -d -D ath9k
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'ath9k' ctrl_interface 'N/A' bridge 'N/A'
Unsupported driver 'ath9k'.

Failed to add interface wlan0
Cancelling scan request
Cancelling authentication timeout.


Aguardo uma solução postada por alguns dos amigos da vol, pois preciso mesmo de uma solução.

obrigado mais uma vez ao vol pelo espaço reservado.
eabreu
Novato






  


2. Re: wpa_supplicant não estabelece conexão [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/03/2011 - 22:10h

reveja seus passos que este trabalho: http://va.mu/A1I


dê retorno.



3. Re: wpa_supplicant não estabelece conexão [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/03/2011 - 23:10h

claro amigo, já revisei sim. mas é como descrevi anteriormente


4. Olá pessoal da vol..

Perfil removido
removido

(usa Nenhuma)

Enviado em 20/03/2011 - 20:02h

Problema resolvido...

causa: após ativar o wpa_supplicant faltava configurar a rede com ip fixo ou via dhcp, e foi isso que fiz.

Obrigado a vol pelo espaço reservado.


5. Re: wpa_supplicant não estabelece conexão [RESOLVIDO]

Lucas Bezerra
lb941990

(usa Debian)

Enviado em 08/02/2012 - 23:18h

Conta como vc fez! Estou com o mesmo problema!


6. Re: wpa_supplicant não estabelece conexão [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/02/2012 - 23:34h

rsrsrs, esse tópico é muito velho abre um novo aqui para começar o suporte ao seu problema.


abraço...


7. Re: wpa_supplicant não estabelece conexão [RESOLVIDO]

Lucas Bezerra
lb941990

(usa Debian)

Enviado em 08/02/2012 - 23:47h

Velho ou não, é um dos primeiros que aparecem para quem quer resolver algum problema relacionado a "wpa_supplicant.conf". Mas, ok! Obrigado por me "ajudar".


8. Re: wpa_supplicant não estabelece conexão [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/02/2012 - 23:57h

Abre um novo tópico ai cara, que receberá ajuda não só de mim como de outros colaboradores da vol.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts