Adaptador TP-Link TL-WN721N não conecta ao Wifi no Debian 9.

1. Adaptador TP-Link TL-WN721N não conecta ao Wifi no Debian 9.

Francisco da Silva Segundo
igniz187

(usa Debian)

Enviado em 10/12/2018 - 16:23h

Acabei de instalar o Debian 9.6 Cinnamon 64 bits num desktop e tive problemas com o Adaptador tp link tl-wn721n. Inicialmente, não era reconhecido. Ao fazer uma pesquisa pela internet, descobri que tinha que instalar o driver proprietário. Então, instalei os pacotes firmware-ath9k-htc_1.4.0-97-g75b3e59+dfsg-1_all.deb e wireless-tools_30~pre9-12+b1_amd64.deb. Depois disso, o adaptador começou a funcionar parcialmente, pois ele identifica as várias internet sem fio, contudo ao tentar conectar, após colocar a senha e esperar um bom tempo, ele não conecta.

Alguém tem alguma ideia do que mais eu posso fazer para resolver este problema?


  


2. Re: Adaptador TP-Link TL-WN721N não conecta ao Wifi no Debian 9.

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 10/12/2018 - 17:36h

Se for adaptador USB poste saída comando: lsusb

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




3. lsusb

Francisco da Silva Segundo
igniz187

(usa Debian)

Enviado em 10/12/2018 - 19:41h

Sim, é usb. Eis a resposta ao comando lsusb:

Bus 005 Device 005: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 001 Device 002: ID 04d9:1605 Holtek Semiconductor, Inc.
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub





4. Re: Adaptador TP-Link TL-WN721N não conecta ao Wifi no Debian 9.

Patrick
Patrick03

(usa Linux Mint)

Enviado em 10/12/2018 - 19:49h

Tente esse método aqui:
https://linuxforums.org.uk/index.php?topic=10851.15;PHPSESSID=jv0ac1kprutmojm4qus77k6m82 

---------------------------------------
Corrija-me quando necessário!
Entra lá: https://nerdki.blogspot.com/
---------------------------------------



5. Re: Adaptador TP-Link TL-WN721N não conecta ao Wifi no Debian 9.

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 10/12/2018 - 20:08h

Ative repositórios free non-free e bakports
Depois usando synaptic instale firmware atheros


----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




6. Ainda sem conectividade

Francisco da Silva Segundo
igniz187

(usa Debian)

Enviado em 11/12/2018 - 01:45h

Ativei os repositórios non-free e os backports. Em seguida fiz a instalação da Firmware Atheros pelo Synaptic, porém ainda não consigo conexão à internet.

Aproveitei para seguir a dica do outro usuário que tinha a ver com a atualização do kernel. Instalei a versão 4.18, a mais recente. Contudo, ainda na mesma situação.


7. Re: Adaptador TP-Link TL-WN721N não conecta ao Wifi no Debian 9.

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 11/12/2018 - 09:43h

-aqui eu usei live-dvd -debian-9 e reconheceu minha wifi do laptop e adaptador-usb do desktop
https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/

-mas no live-dvd-debian-8 eu tive que instalar manualmente minha realtek e ralink

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts