Não dá vídeo após reiniciar pc [RESOLVIDO]

1. Não dá vídeo após reiniciar pc [RESOLVIDO]

Osama Jr.
/bin/laden

(usa Void Linux)

Enviado em 04/04/2018 - 00:47h

Salve povo! Recentemente instalei o Void (excelente distro por sinal!) num PC que tava parado aqui. Instalei sem interface gráfica mesmo, pois pretendo montar um pequeno servidor nesta máquina. Até aí tudo bem, o problema ocorre quando reinicio ou desligo essa máquina. A bronca é a seguinte:

Se eu desligo o PC e desconecto o cabo VGA do monitor nessa máquina, e depois ligo ela e conecto novamente o cabo, o monitor não dá mais sinal de vídeo. Daí só reiniciando o PC com o cabo conectado é que o vídeo volta a funfar. Entenderam essa parada estranha?!

Tentando explicar melhor:

1 - Desligo o PC e desconecto o cabo VGA dele.
2 - Religo o PC MAS não conecto o cabo VGA nele.
3 - Com o PC já ligado e o SO já carregado (pois pingo nele de outro PC) aí sim conecto o cabo VGA, PORÉM o monitor não dá sinal de vídeo. Daí tenho que reiniciar a máquina com o cabo VGA conectado pra poder ter sinal de vídeo.

Alguém já passou por isso?

>> LEMBRANDO QUE NESSA MÁQUINA NÃO HÁ INTERFACE GRÁFICA <<


  


2. MELHOR RESPOSTA

Sandro Marcell
SMarcell

(usa Slackware)

Enviado em 06/04/2018 - 13:10h

Passei por problema parecido ao seu. Pra resolver, você deve passar um dos seguintes parâmetros (vá testando cada um) ao kernel durante o boot:

video=VGA-1:e
ou
video=VGA-4:e
ou
video=VGA-8:e

Isso fará com que o kernel ative a porta VGA mesmo o cabo não estando conectado nela.

Como o Void utiliza o grub como gerenciador de boot, então edite o arquivo "/etc/default/grub" e procure pela linha "GRUB_CMDLINE_LINUX_DEFAULT". Adicione ao final dela o parâmetro correto e depois atualize as definições para o grub.

# update-grub

3. Re: Não dá vídeo após reiniciar pc [RESOLVIDO]

André Luiz Rodrigues dos Santos
Loook185

(usa Slackware)

Enviado em 04/04/2018 - 19:40h

Imagino que o Kernel esteja tendo problemas de reconhecer o monitor depois dele ser reconectado, mas realmente é muito estranho.
Slackware 14.2
XFCE <3



4. Re: Não dá vídeo após reiniciar pc [RESOLVIDO]

Osama Jr.
/bin/laden

(usa Void Linux)

Enviado em 08/04/2018 - 13:20h

Deu certo smarcell. :) Valeu pela dica cara.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts