Dicas sobre o Void Linux [RESOLVIDO]

1. Dicas sobre o Void Linux [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 25/08/2019 - 11:57h

Bom dia,

Lá no Mundo GNU fiz duas dicas recentes para o Void Linux.

A primeira trata da compilação manual de kernel, incluindo a criação de initrd:

https://edpsblog.wordpress.com/2019/08/23/how-to-compilacao-manual-de-kernel-no-void-linux/

A segunda sobre como obter o mirror (espelho) mais rápido, dentre os espelhos oficiais:

https://edpsblog.wordpress.com/2019/08/24/how-to-escolhendo-espelhos-mais-rapidos-no-void-linux/

Pode ser que envie os mesmos como dicas para o VOL.

EDIT:

Hoje, 26 Ago, fiz um novo artigo de instalação por meio de chroot:

https://edpsblog.wordpress.com/2019/08/26/how-to-instalacao-do-void-linux-chroot/



  


2. Re: Dicas sobre o Void Linux

Izaias
izaias

(usa Ubuntu)

Enviado em 25/08/2019 - 12:26h

edps escreveu:

Bom dia,

Lá no Mundo GNU fiz duas dicas recentes para o Void Linux.

A primeira trata da compilação amnual de kernel, incluindo a criação de initrd:

https://edpsblog.wordpress.com/2019/08/23/how-to-compilacao-manual-de-kernel-no-void-linux/

A segunda sobre como obter o mirror (espelho) mais rápido, dentre os espelhos oficiais:

https://edpsblog.wordpress.com/2019/08/24/how-to-escolhendo-espelhos-mais-rapidos-no-void-linux/

Pode ser que envie os mesmos como dicas para o VOL.


Faça isso, meu caro!


3. Re: Dicas sobre o Void Linux [RESOLVIDO]

Giovanni  M
Giovanni_Menezes

(usa Void Linux)

Enviado em 25/08/2019 - 12:29h

Estou usando já a algum tempo e estou bastante surpreso com a estabilidade, não sei se deve-se ao fato de eu ter adotado aplicativos simples como o fluxbox e pcmanfm mas no geral esta tudo funcionando muito bem.

Só tive 2 problemas:

Não consigo dar suporte ao vlc a skins, o pacote correspondente no debian seria vlc-plugin-skins2
No libre passo por situação semelhante, não encontrei nenhum pacote com o nome parecido ao libreoffice-gtk do debian e dar aspecto em gtk.





--------------------------------------------------------------------------
Somente o Software Livre lhe garante as 4 liberdades.
Open Source =/= Free Software.
https://encurtador.com.br/CGNU5
http://www.anahuac.eu/contrarrevolucao-osi/




***Twitter***
https://twitter.com/Giovanni_Ann88

***Pensando em investir em bitcoins ? veja este vídeo***
https://www.youtube.com/watch?v=jhBE3MUFxQU


4. Re: Dicas sobre o Void Linux [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 25/08/2019 - 12:40h


Giovanni_Menezes escreveu:

Estou usando já a algum tempo e estou bastante surpreso com a estabilidade, não sei se deve-se ao fato de eu ter adotado aplicativos simples como o fluxbox e pcmanfm mas no geral esta tudo funcionando muito bem.


Eu estava usando o BSPWM, mas ontem instalei o XFCE e entre todas as distros é o que vem mais completo, muito bom!


Só tive 2 problemas:

Não consigo dar suporte ao vlc a skins, o pacote correspondente no debian seria vlc-plugin-skins2
No libre passo por situação semelhante, não encontrei nenhum pacote com o nome parecido ao libreoffice-gtk do debian e dar aspecto em gtk.


Sobre o VLC eu não sei, porque não uso, costumo usar SMPlayer, MPV ou QMPlay2.

Quanto ao pacote do libreoffice não seria o libreoffice-gnome (Productivity suite - GNOME integration)?, veja todas as alternativas em:

https://voidlinux.org/packages/

ou com:

$ xbps-query -Rs libreoffice 



5. Re: Dicas sobre o Void Linux [RESOLVIDO]

Giovanni  M
Giovanni_Menezes

(usa Void Linux)

Enviado em 25/08/2019 - 14:30h

Obrigado Edps, funcionou perfeitamente aqui, não sei como eu não chutei esse pacotes antes : S

E sobre o Void, gostei da simplicidade do runit.


--------------------------------------------------------------------------
Somente o Software Livre lhe garante as 4 liberdades.
Open Source =/= Free Software.
https://encurtador.com.br/CGNU5
http://www.anahuac.eu/contrarrevolucao-osi/




***Twitter***
https://twitter.com/Giovanni_Ann88

***Pensando em investir em bitcoins ? veja este vídeo***
https://www.youtube.com/watch?v=jhBE3MUFxQU


6. Re: Dicas sobre o Void Linux

edps
edps

(usa Slackware)

Enviado em 25/08/2019 - 17:21h

Giovanni_Menezes escreveu:

Obrigado Edps, funcionou perfeitamente aqui, não sei como eu não chutei esse pacotes antes : S

E sobre o Void, gostei da simplicidade do runit.


O Void é simples, o runit idem, mas tem certas coisas que não dá para entender, veja quando tento instalar o elefante, digo, LibreOffice:


~ » pkg install libreoffice libreoffice-i18n-pt-BR
[*] Updating `https://mirrors.servercentral.com/voidlinux/current/x86_64-repodata' ...
[*] Updating `https://mirrors.servercentral.com/voidlinux/current/nonfree/x86_64-repodata' ...
58 packages will be downloaded:
...
58 packages will be installed:
hunspell-1.7.0_1 hyphen-2.8.8_2 mythes-1.2.4_4
openldap-tools-2.4.48_1 openldap-2.4.48_1 boost-1.69.0_5
libboost_system1.69-1.69.0_5 libboost_chrono1.69-1.69.0_5
libboost_thread1.69-1.69.0_5 libboost_locale1.69-1.69.0_5
librasqal-0.9.33_2 librdf-1.0.17_4 libtommath-1.1.0_1
libfbclient3-3.0.4.33054_3 libboost_date_time1.69-1.69.0_5
libcmis-0.5.2_2 clucene-2.3.3.4_7
libboost_program_options1.69-1.69.0_5 libboost_filesystem1.69-1.69.0_5
libixion-0.14.1_2 libboost_iostreams1.69-1.69.0_5 liborcus-0.14.1_2
librevenge-0.0.4_3 libcdr-0.1.5_2 libfreehand-0.1.2_2
libmspub-0.1.4_5 libmwaw-0.3.15_1 libodfgen-0.1.7_2
libpagemaker-0.0.4_2 libqxp-0.0.2_3 libvisio-0.1.7_1
libwpd-0.10.3_1 libwpg-0.3.3_1 xmlsec1-1.2.28_2
libnumbertext-1.0.5_1 libmysqlclient-5.6.43_3 libexttextcat-3.4.5_2
liblangtag-0.6.2_3 libreoffice-common-6.2.5.2_2
libreoffice-base-6.2.5.2_2 libreoffice-calc-6.2.5.2_2
libreoffice-draw-6.2.5.2_2 libreoffice-fonts-6.2.5.2_2
libreoffice-gnome-6.2.5.2_2 libreoffice-impress-6.2.5.2_2
libreoffice-math-6.2.5.2_2 libreoffice-postgresql-6.2.5.2_2
libreoffice-writer-6.2.5.2_2 libreoffice-xtensions-6.2.5.2_2
libreoffice-i18n-en-US-6.2.5.2_2 libreoffice-i18n-de-6.2.5.2_2
libreoffice-i18n-es-6.2.5.2_2 libreoffice-i18n-fr-6.2.5.2_2
libreoffice-i18n-it-6.2.5.2_2 libreoffice-i18n-pl-6.2.5.2_2
libreoffice-i18n-pt-6.2.5.2_2 libreoffice-6.2.5.2_2
libreoffice-i18n-pt-BR-6.2.5.2_2

Size to download: 212MB
Size required on disk: 1220MB
Space available on disk: 31GB

Do you want to continue? [Y/n] n
Aborting!
~ »


Ou seja, 212MB de pacotes inúteis (os de linguagem), daí se como em outras distros eu ponho somente o pacote de linguagem esperando que ele puxe o "core" do programa, isto é: base, calc, draw, impress, etc ele instalará somente o pacote de linguagem kkkk (isso também vale para o SlackBuild do AlienBob).

A solução é especificar o que se quer, preciso de no mínimo Calc, Impress e Writer, daí segue o comando de instalação, o total de download cai para 168MB (46 pacotes) e ainda inclui na jogada: Base, Draw, e o pacote de integração GTK:


~ » pkg install libreoffice-calc libreoffice-impress libreoffice-writer libreoffice-i18n-pt-BR libreoffice-gnome libreoffice-base libreoffice-draw
[*] Updating `https://mirrors.servercentral.com/voidlinux/current/x86_64-repodata' ...
[*] Updating `https://mirrors.servercentral.com/voidlinux/current/nonfree/x86_64-repodata' ...
46 packages will be downloaded:
...
46 packages will be installed:
hunspell-1.7.0_1 hyphen-2.8.8_2 mythes-1.2.4_4
openldap-tools-2.4.48_1 openldap-2.4.48_1 boost-1.69.0_5
libboost_system1.69-1.69.0_5 libboost_chrono1.69-1.69.0_5
libboost_thread1.69-1.69.0_5 libboost_locale1.69-1.69.0_5
librasqal-0.9.33_2 librdf-1.0.17_4 libtommath-1.1.0_1
libfbclient3-3.0.4.33054_3 libboost_date_time1.69-1.69.0_5
libcmis-0.5.2_2 clucene-2.3.3.4_7
libboost_program_options1.69-1.69.0_5 libboost_filesystem1.69-1.69.0_5
libixion-0.14.1_2 libboost_iostreams1.69-1.69.0_5 liborcus-0.14.1_2
librevenge-0.0.4_3 libcdr-0.1.5_2 libfreehand-0.1.2_2
libmspub-0.1.4_5 libmwaw-0.3.15_1 libodfgen-0.1.7_2
libpagemaker-0.0.4_2 libqxp-0.0.2_3 libvisio-0.1.7_1
libwpd-0.10.3_1 libwpg-0.3.3_1 xmlsec1-1.2.28_2
libnumbertext-1.0.5_1 libmysqlclient-5.6.43_3 libexttextcat-3.4.5_2
liblangtag-0.6.2_3 libreoffice-common-6.2.5.2_2
libreoffice-calc-6.2.5.2_2 libreoffice-impress-6.2.5.2_2
libreoffice-writer-6.2.5.2_2 libreoffice-i18n-pt-BR-6.2.5.2_2
libreoffice-gnome-6.2.5.2_2 libreoffice-base-6.2.5.2_2
libreoffice-draw-6.2.5.2_2

Size to download: 168MB
Size required on disk: 892MB
Space available on disk: 31GB

Do you want to continue? [Y/n]

[*] Downloading packages
...

[*] Verifying package integrity
...

[*] Collecting package files
...

[*] Unpacking packages
...

[*] Configuring unpacked packages
...

46 downloaded, 46 installed, 0 updated, 46 configured, 0 removed.
~ »


Ou seja, com menos pacotes... mas completo.



7. Re: Dicas sobre o Void Linux [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 26/08/2019 - 16:11h

Hoje, um novo artigo de instalação do Void Linux em sistema UEFI e por meio de chroot:

https://edpsblog.wordpress.com/2019/08/26/how-to-instalacao-do-void-linux-chroot/






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts