VM não liga com comando [RESOLVIDO]

1. VM não liga com comando [RESOLVIDO]

André Bartels
Bartels

(usa Ubuntu)

Enviado em 10/05/2019 - 15:50h

Boa tarde, estou com um Ubuntu Server 16.04 LTS com virtual box 6.0.

Porem preciso iniciar a VM com o servidor e não estou conseguindo...cheguei a pensar que era o servidor, mas instalei o virtualbox em outro servidor e ocorre a mesma coisa.
Abaixo os comandos com erros:
teste 1
VBoxManage startvm vm

VBoxManage: error: Could not find a registered machine named 'vm'
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBoxWrap, interface IVirtualBox, callee nsISupports
VBoxManage: error: Context: "FindMachine(Bstr(pszVM).raw(), machine.asOutParam())" at line 721 of file VBoxManageMisc.cpp

teste 2
VirtualBox --startvm vm

--startvm é uma opção para o executor de VMs do VirtualBox (VirtualBoxVM), não para o Gerenciador do VirtualBox.

teste 3
VirtualBoxVM --startvm vm

Could not find a registered machine named 'vm'.
Código de Resultado:
VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)
Componente:
VirtualBoxWrap
Interface:
IVirtualBox {d0a0163f-e254-4e5b-a1f2-011cf991c38d}

Com base no ocorrido acima executei :
VBoxManage list vms

Nada retornou.



Por acaso algume tem ideia do que pode estar ocorrendo, vale ressaltar que isso é em 2 equipamentos distintos.




  


2. Re: VM não liga com comando [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 10/05/2019 - 15:55h


o comando é


VBoxHeadless -startvm vm




3. Re: VM não liga com comando

André Bartels
Bartels

(usa Ubuntu)

Enviado em 10/05/2019 - 16:07h

Boa tarde Danniel, tambem deu erro

root@srv01:/home/server# VBoxHeadless -startvm vm
Oracle VM VirtualBox Headless Interface 6.0.6
(C) 2008-2019 Oracle Corporation
All rights reserved.

Invalid machine name or UUID!



4. Re: VM não liga com comando [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 10/05/2019 - 16:16h


qual é o nome da sua maquina virtual ?
tem que colocar o nome que foi criado a VM





5. Re: VM não liga com comando [RESOLVIDO]

André Bartels
Bartels

(usa Ubuntu)

Enviado em 10/05/2019 - 16:18h

Estou colocando o nome, já até criei outra maquina com outro nome e dá o mesmo resultado.

O mais estranho é que não localiza nenhum nome.


6. Re: VM não liga com comando [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 10/05/2019 - 16:38h


nome com espaço ? tem espaço no nome ?



7. Re: VM não liga com comando [RESOLVIDO]

André Bartels
Bartels

(usa Ubuntu)

Enviado em 10/05/2019 - 17:48h

estou usando nomes simples como:

vm
maq
w7
w10


8. Re: VM não liga com comando

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 10/05/2019 - 21:52h

Clica com o botão direito do mouse em cima da maquine e vaiem "criar atalho na área de trabalho"
Vai na sua "área de trabalho" e acessa o atalho criado vai em propriedade veja o comando de execução do atalho.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


9. Re: VM não liga com comando [RESOLVIDO]

André Bartels
Bartels

(usa Ubuntu)

Enviado em 11/05/2019 - 08:34h

bom dia abaixo de cada maquina

usr/lib/virtualbox/VirtualBoxVM --comment "maq1" --startvm "{5f90b033-0656-4a1a-be86-5b3905ff47b0}"
/usr/lib/virtualbox/VirtualBoxVM --comment "vm" --startvm "{4d2ef77d-270c-46fd-b5d9-5af79ca2fd4e}"

eu já tentei usar :
VBoxHeadless -startvm maq1
ou
VBoxHeadless -startvm 5f90b033-0656-4a1a-be86-5b3905ff47b0

VBoxHeadless -startvm vm
ou
VBoxHeadless -startvm 4d2ef77d-270c-46fd-b5d9-5af79ca2fd4e

em todos os casos aparecem as mesmas msgs
Oracle VM VirtualBox Headless Interface 6.0.6
(C) 2008-2019 Oracle Corporation
All rights reserved.

Invalid machine name or UUID!



o mais estranho é o porque qdo executo
sudo VBoxManage list vms

nada me retorna...ou estou executando de forma erronea


10. Re: VM não liga com comando [RESOLVIDO]

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 11/05/2019 - 10:01h

Abra o terminal e copie e cole esta linha:
/usr/lib/virtualbox/VirtualBoxVM --comment "vm" --startvm "{4d2ef77d-270c-46fd-b5d9-5af79ca2fd4e}"
E de enter.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


11. Re: VM não liga com comando [RESOLVIDO]

André Bartels
Bartels

(usa Ubuntu)

Enviado em 11/05/2019 - 10:12h

SHOWWWW...

Abriu a VM...

por favor poderia detalhar o comando

Inicialmente muito obrigado pela ajuda






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts