Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

1. Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

Mateus Boni Dias
MateusDias

(usa Ubuntu)

Enviado em 28/04/2019 - 13:38h

Boa tarde pessoal!
Tenho um notebook Asus i5, 6GB, placa de vídeo híbrida Intel e Nvidia 720M. Meu problema esta na instalação do driver proprietário da Nvidia, visto que após sua instalação o sistema trava um pouco antes de solicitar o login e senha para iniciar a sessão, ficando parado em uma tela preta listando os módulos carregados, ou seja não carrega o ambiente gráfico. Antes da instalação do driver proprietário o driver da nouveau funciona normal. Observação no Ubuntu 18.04 o driver proprietário funciona normal.
Desde já obrigado.


  


2. MELHOR RESPOSTA

3. Re: Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

Jessé Borges Filho
Jbaf

(usa KUbuntu)

Enviado em 28/04/2019 - 13:47h


MateusDias escreveu:

Boa tarde pessoal!
Tenho um notebook Asus i5, 6GB, placa de vídeo híbrida Intel e Nvidia 720M. Meu problema esta na instalação do driver proprietário da Nvidia, visto que após sua instalação o sistema trava um pouco antes de solicitar o login e senha para iniciar a sessão, ficando parado em uma tela preta listando os módulos carregados, ou seja não carrega o ambiente gráfico. Antes da instalação do driver proprietário o driver da nouveau funciona normal. Observação no Ubuntu 18.04 o driver proprietário funciona normal.
Desde já obrigado.



Boa tarde,

O que você instalou e como o fez?


Usuário de Ubuntu 19.04 (Disco)


4. Re: Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

Mateus Boni Dias
MateusDias

(usa Ubuntu)

Enviado em 28/04/2019 - 13:55h

O que você instalou e como o fez?


Primeiramente instalei o sistema normalmente e por definição utilizou o driver Nouveau. Posteriormente utilizei estes comandos para instalar os driver proprietários:
sudo apt-add-repository ppa:graphics-drivers/ppa && sudo apt update
sudo ubuntu-drivers autoinstall
sudo reboot

Ao iniciar o sistema trava conforme comentado.




5. Re: Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 28/04/2019 - 14:13h

Ue eu achava que o driver Nvidia chamasse nvidia.
No meu é assim que chama nvidia-384
E no PPA que voce mensiono chama nvidia-graphics-drivers.
se instalaria assim
$ sudo apt-get install nvidia-graphics-drivers-430
Que estranho você instalar de outra maneira.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


6. Re: Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

Mateus Boni Dias
MateusDias

(usa Ubuntu)

Enviado em 28/04/2019 - 14:33h

aguamole escreveu:

Ue eu achava que o driver Nvidia chamasse nvidia.
No meu é assim que chama nvidia-384
E no PPA que voce mensiono chama nvidia-graphics-drivers.
se instalaria assim
$ sudo apt-get install nvidia-graphics-drivers-430
Que estranho você instalar de outra maneira.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


Pelo que eu sei, (mas posso estar errado kkk) o driver proprietário chama mesmo desta maneira, o driver que eu citei o Nouveau é um driver genérico para placas de vídeo Nvidea desenvolvido pela comunidade linux e não tem o mesmo desempenho do driver da nvidia, por isso quero atualizar.
Da maneira que você instala é selecionado a versão do driver no caso mencionado a 430, e da maneira que instalei é selecionado a versão recomentada (testada), seu não me engado é também a 430. Mas você me deu a idea de de tentar outras versões do driver. Vlw vou tentar conforme vc comentou.
.


7. Re: Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 28/04/2019 - 16:46h

-no ubuntu eu sempre uso o drivers-adicionais p/ ativar/desativar um driver proprietário




8. Re: Ubuntu 19.04 não inicia após instalação do driver proprietário da Nvidia [RESOLVIDO]

Mateus Boni Dias
MateusDias

(usa Ubuntu)

Enviado em 30/05/2019 - 00:10h



Realmente essa foi a única solução! Mas resolveu, está funcionando liso! Ao instalar ele automaticamente configurou o prime como gerenciador de vídeo, o que resolveu tudo. Só falta acostumar com a nova gui.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts