Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

1. Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

Alvaro Carnielo e Silva
alcarnielo

(usa Ubuntu)

Enviado em 06/03/2015 - 18:47h

Boa noite. Instalei meu linux recentemente após formatar minha máquina. Contudo, quando tentei realizar a instalação do python-pyside, não consigo obter o QtDesigner (que já deveria vir instalado nele).

Quando tentei instalar o QtDesigner manualmente, obtive a seguinte mensagem:

"""
Os seguintes pacotes têm dependências não satisfeitas:

libcheese-gtk23: Depends: cheese-common (= 3.10.2-0ubuntu2) mas a 3.10.2-0ubuntu2 será instalada
libcheese7: Depends: libgudev-1.0-0 (>= 146) mas a 1:204-5ubuntu20.10 será instalada
Depends: cheese-common (= 3.10.2-0ubuntu2) mas a 3.10.2-0ubuntu2 será instalada
libclutter-1.0-0: Depends: libatk1.0-0 (>= 2.5.3) mas a 2.10.0-2ubuntu2 será instalada
Depends: libc6 (>= 2.14) mas a 2.19-0ubuntu6.6 será instalada
Depends: libfontconfig1 (>= 2.9.0) mas a 2.11.0-0ubuntu4.1 será instalada
Depends: libglib2.0-0 (>= 2.37.3) mas a 2.40.2-0ubuntu1 será instalada
Depends: libgtk-3-0 (>= 3.3.18) mas a 3.10.8-0ubuntu1.4 será instalada
Depends: libpango-1.0-0 (>= 1.30) mas a 1.36.3-1ubuntu1.1 será instalada
Depends: libpangocairo-1.0-0 (>= 1.30) mas a 1.36.3-1ubuntu1.1 será instalada
Depends: libpangoft2-1.0-0 (>= 1.30) mas a 1.36.3-1ubuntu1.1 será instalada
Depends: libx11-6 (>= 2:1.2.99.901) mas a 2:1.6.2-1ubuntu2 será instalada
Depends: libxcomposite1 (>= 1:0.3-1) mas a 1:0.4.4-1 será instalada
Depends: libxdamage1 (>= 1:1.1) mas a 1:1.1.4-1ubuntu1 será instalada
Depends: libxi6 (>= 2:1.2.99.4) mas a 2:1.7.1.901-1ubuntu1 será instalada
"""

Uma mensagem similar é retornada quando eu tento instalar outros softwares. Quando instalei o OpenFoam, na parte de instalar o paraviewopenfoam (segui este tutorial: http://www.openfoam.org/download/ubuntu.php), obtive como retorno esta mensagem:

"""
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
libcheese-gtk23 : Depende: libclutter-gtk-1.0-0 (>= 0.91.8) mas não será instalado
Depende: libcogl15 (>= 1.15.8) mas não será instalado
libcheese7 : Depende: libclutter-gst-2.0-0 (>= 0.10.0) mas não será instalado
Depende: gstreamer1.0-clutter mas não será instalado
libclutter-1.0-0 : Depende: libcogl-pango15 (>= 1.15.8) mas não será instalado
Depende: libcogl15 (>= 1.15.8) mas não será instalado
E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).
"""
A questão é que infelizmente não consigo acertar esses problemas. Re-instalei o UBUNTU, coloquei uma versão anterior (que não possibilitava atualizações) e retornei para esta. Infelizmente não sei o que fazer.
Alguém pode ajudar?

Abraços,


  


2. MELHOR RESPOSTA

Ruan
ru4n

(usa Fedora)

Enviado em 07/03/2015 - 11:47h

Isso não é instalação mal feita, é um BUG ainda não resolvido pela Canonical!

Este BUG só existe na versão 14.04.2. O motivo desse BUG é porque o Ubuntu 14.02.2 usa alguns pacotes do buguento 14.10 utopic (basta ver estes pacotes com o comando dpkg -l | grep utopic).

Eu resolvi da seguinte forma:

sudo apt-get install libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0


Esse comando vai remover os pacotes buguentos do utopic e vai instalar outros. Pode confirmar sem medo pois segui este mesmo procedimento e aqui ta funcionando normal...

Fonte: http://askubuntu.com/questions/588695/cant-install-libglew-dev-because-libcheese-and-libclutter-dont...
-----------------------------------------------------------------------------
Uma vida não questionada não merece ser vivida - Platão

3. Re: Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 06/03/2015 - 21:05h

QtDesigner parece fazer parte dos repositorios do Ubuntu e poder ser instaldo pela central de programas
Qual Ubuntu vc está usando??


4. Re: Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 06/03/2015 - 21:43h

clodoaldops escreveu:

QtDesigner parece fazer parte dos repositorios do Ubuntu e poder ser instaldo pela central de programas
Qual Ubuntu vc está usando??



Boa noite,

Pelo que parece, trusty

https://launchpad.net/ubuntu/+source/anjuta/2:3.10.2-0ubuntu2

Agora, está esquisito!! Instalação mal feita ai, algum pacote "quebrado"

Até...


5. Re: Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

Alvaro Carnielo e Silva
alcarnielo

(usa Ubuntu)

Enviado em 07/03/2015 - 11:37h

Existe alguma forma de corrigir isso?

Tentei baixar o QtDesigner pela Central de programas do UBUNTU, e obtive a mesma resposta.

Antes de formatar o UNUNTU, tentei instalar o Qt inteiro também, porém não deu certo. Ocorreu o mesmo erro.



6. Re: Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

Ruan
ru4n

(usa Fedora)

Enviado em 07/03/2015 - 11:54h

Pra quem for instalar o Ubuntu 14.04, recomendo o Ubuntu 14.04.01 que não esta com esse problema.
-----------------------------------------------------------------------------
Uma vida não questionada não merece ser vivida - Platão


7. Quase resolvido!

Alvaro Carnielo e Silva
alcarnielo

(usa Ubuntu)

Enviado em 07/03/2015 - 12:47h

O problema está quase resolvido! Mas vou marcar como resolvido. Agora é só resolver o probleminha do OpenFoam.

Na instalação do paraFoam deu tudo certo, sem mensagem de erro, porém ao rodar o caso teste com o comando paraFoam, ele retorna esse erro:

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV4Readers
./Allwclean
./Allwmake

Esse erro é de outro tópico. Então vou marcar como resolvido!

Obrigado pela ajuda!


8. Re: Problema com instalação de pacotes no UBUNTU [RESOLVIDO]

Ruan
ru4n

(usa Fedora)

Enviado em 07/03/2015 - 13:13h

Marque a melhor resposta se o problema do apt-get foi resolvido completamente. :-)
-----------------------------------------------------------------------------
Uma vida não questionada não merece ser vivida - Platão


9. Obrigado!

Alvaro Carnielo e Silva
alcarnielo

(usa Ubuntu)

Enviado em 07/03/2015 - 13:46h

Desculpe meu desleixo. Este é a minha primeira questão nestes forums.