Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

1. Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Flávia Gieseler de Assis
pedrinhaf

(usa Ubuntu)

Enviado em 04/06/2015 - 13:55h

Ao tentar instalar o GIMP pelo terminal recebo a mesnagem de que existem pacotes quebrados. Tentei dar um sudo apt-get install -f, mas não funcionou. Pelo repositório do linux a instalação apresenta o seguinte eroo:
The following packages have unmet dependencies:

gimp: Depends: libc6 (>= 2.15) but 2.19-0ubuntu6.6 is to be installed
Depends: libfontconfig1 (>= 2.9.0) but 2.11.0-0ubuntu4.1 is to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.30.7-0ubuntu1 is to be installed
Depends: libglib2.0-0 (>= 2.39.4) but 2.40.2-0ubuntu1 is to be installed
Depends: libgs9 (>= 8.61.dfsg.1) but 9.10~dfsg-0ubuntu10.2 is to be installed
Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.24-0ubuntu1~trusty1 is to be installed
Depends: libgudev-1.0-0 (>= 146) but 1:204-5ubuntu20.12 is to be installed
Depends: libjpeg8 (>= 8c) but 8c-2ubuntu8 is to be installed
Depends: librsvg2-2 (>= 2.14.4) but 2.40.2-1 is to be installed
Depends: libtiff5 (>= 4.0.3) but 4.0.3-7ubuntu0.3 is to be installed
Depends: libwebkitgtk-1.0-0 (>= 1.3.10) but it is not going to be installed
Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package
Tentei alterar o espelho, mas não funcionou. Não sei o que fazer. Mudei para o linux há apenas uma semana e entendo muito pouco. Preciso muito do GIMP.


  


2. MELHOR RESPOSTA

josinaldo
josinaldo-

(usa Debian)

Enviado em 14/06/2015 - 22:23h

Rode os comandos em ordem sequencial ( e sem errar, você pode cola-los no terminal)

sudo rm /etc/apt/sources.list.d/*
sudo rm /etc/apt/sources.list
sudo rm /var/lib/apt/lists/*
sudo rm /var/lib/apt/lists/partial/*


sudo nano /etc/apt/sources.list
(seŕa aberta uma janela no terminal, geralmente preta, é nela onde iremos adicionar as linhas abaixo - *até playtdeb)

### Repositórios Oficiais ###

### Ubuntu Main Repos
deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse

### Ubuntu Update Repos
deb http://us.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu trusty partner

### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu trusty main

### Repositórios de Terceiros ###

#### GetDeb - http://www.getdeb.net
deb http://archive.getdeb.net/ubuntu trusty-getdeb apps

#### Gimp PPA - https://launchpad.net/~otto-kesselgulasch/+archive/gimp
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu trusty main

#### GNOME3 Extra Apps PPA - https://launchpad.net/~gnome3-team/+archive/gnome3
deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu trusty main

#### PlayDeb - http://www.playdeb.net/
deb http://archive.getdeb.net/ubuntu trusty-getdeb games


Salve o arquivo com Crtl+o (tecle enter) e feche o mesmo com Ctrl+x

Rode via terminal:

wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 614C4B38
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3B1510FD
wget -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

sudo apt-get update

3. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Ivan
ivaniuni

(usa Slackware)

Enviado em 04/06/2015 - 18:50h

rebelvis escreveu:

Olá! galera, instalei o lubuntu 14.04 achei muito bom mais quando vou acessar meu portal de aulas da faculdade nao aparece os videos fica tudo preto,já instalei o flash, digitei os comandos e nada, o youtube também fica assim mais quando desativo o flash ele funciona mais meu portal de aulas não. alguem que tenha conhecimento neste sistema poderia me ajudar ? obrigado...........


tentou pelo Synaptic no menu dele ,pelo que me lembr, tem um recurso de corrigir pacotes quebrados.






4. Re: Não consigo instalar o Gimp no Ubunto 14.04

Patrick
Freud_Tux

(usa Outra)

Enviado em 04/06/2015 - 19:30h

pedrinhaf escreveu:

Ao tentar instalar o GIMP pelo terminal recebo a mesnagem de que existem pacotes quebrados. Tentei dar um sudo apt-get install -f, mas não funcionou. Pelo repositório do linux a instalação apresenta o seguinte eroo:
The following packages have unmet dependencies:

gimp: Depends: libc6 (>= 2.15) but 2.19-0ubuntu6.6 is to be installed
Depends: libfontconfig1 (>= 2.9.0) but 2.11.0-0ubuntu4.1 is to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.30.7-0ubuntu1 is to be installed
Depends: libglib2.0-0 (>= 2.39.4) but 2.40.2-0ubuntu1 is to be installed
Depends: libgs9 (>= 8.61.dfsg.1) but 9.10~dfsg-0ubuntu10.2 is to be installed
Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.24-0ubuntu1~trusty1 is to be installed
Depends: libgudev-1.0-0 (>= 146) but 1:204-5ubuntu20.12 is to be installed
Depends: libjpeg8 (>= 8c) but 8c-2ubuntu8 is to be installed
Depends: librsvg2-2 (>= 2.14.4) but 2.40.2-1 is to be installed
Depends: libtiff5 (>= 4.0.3) but 4.0.3-7ubuntu0.3 is to be installed
Depends: libwebkitgtk-1.0-0 (>= 1.3.10) but it is not going to be installed
Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package
Tentei alterar o espelho, mas não funcionou. Não sei o que fazer. Mudei para o linux há apenas uma semana e entendo muito pouco. Preciso muito do GIMP.


Tá tentando instalar via apt-get, ou, usando o synaptic? Atualizou o sistema antes de tentar instalar o Gimp?
Esse problema das dependências é que as versões que estão no sistema são antigas e ele precisa de versões mais novas.

T+






5. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Flávia Gieseler de Assis
pedrinhaf

(usa Ubuntu)

Enviado em 04/06/2015 - 21:05h


É o Ubunto 14.04. Tentei instalar com o apt-get e também pelo repositório. Já fiz upgrade, update, autoremove, autoclean install -f... Enfim, tudo que vi pelos fóruns como possível solução. Sempre que termino esses procedimentos ainda aparece que possuo 50 atualizações não instaladas. E não importa quantos upgrades eu faça, essa mensagem permanece. Não tentei pelo synaptic. Na verdade, nem sei bem o que é isso. Algumas pessoas comentaram por ele em fóruns. Entretanto, não o encontrei. Tentei instala-lo, mas o comando não foi reconhecido.


6. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Flávia Gieseler de Assis
pedrinhaf

(usa Ubuntu)

Enviado em 05/06/2015 - 12:00h


Bem eu consegui instalar (e entender o que é) o Synaptic e descobri que um dos pacotes tem algumas dependências, como o "libavcodec53" e por isso não pode ser instalado. O problema é que este pacote não está no repositório. Quando busco no synaptic aparece o "libavcodec54", mas o 53 não. O "libbabl-0.1-0" também não está disponível... :/


7. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Flávia Gieseler de Assis
pedrinhaf

(usa Ubuntu)

Enviado em 05/06/2015 - 12:04h

ivaniuni escreveu:

rebelvis escreveu:

Olá! galera, instalei o lubuntu 14.04 achei muito bom mais quando vou acessar meu portal de aulas da faculdade nao aparece os videos fica tudo preto,já instalei o flash, digitei os comandos e nada, o youtube também fica assim mains quando desativo o flash ele funciona mais meu portal de aulas não. alguem que tenha conhecimento neste sistema poderia me ajudar ? obrigado...........


tentou pelo Synaptic no menu dele ,pelo que me lembr, tem um recurso de corrigir pacotes quebrados.




Você instalou os codecs?
Veja essas dicas:

http://www.edivaldobrito.com.br/instale-o-java-codecs-e-suporte-reproducao-de-dvd-criptografado/



8. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Patrick
Freud_Tux

(usa Outra)

Enviado em 06/06/2015 - 09:39h

pedrinhaf escreveu:


Bem eu consegui instalar (e entender o que é) o Synaptic e descobri que um dos pacotes tem algumas dependências, como o "libavcodec53" e por isso não pode ser instalado. O problema é que este pacote não está no repositório. Quando busco no synaptic aparece o "libavcodec54", mas o 53 não. O "libbabl-0.1-0" também não está disponível... :/


Desculpe a demora em retornar.

É por isso que ele não está sendo instalado. As depêndências que o Gimp precisa estão "obsoletas" no seu sistema.
Qual é a versão do Gimp que está tentando instalar? Aqui no Debian Jessie a mais novas nos reposítórios backports é essa: 2.8.14.
Escrevendo sobre repositórios, me lembrei de uma coisa.
Você tem todos os repositórios habilitados ai no seu Ubuntu? Qual é a versão do Gimp que pretende instalar? Segundo o link:

https://apps.ubuntu.com/cat/applications/gimp/

Até a versão 13, era a versão 2.8.6

Qual é a versão que o sistemas está tentando instalar?

T+









9. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Ivan
ivaniuni

(usa Slackware)

Enviado em 06/06/2015 - 11:26h

É importante saber se vc desabilitou algum repositório do ubuntu, pois o normal do ubuntu qundo atualizado é deixar o gimp instalar normalmente. Tentou instalar o gimp pelo synaptic? clica no menu do synaptic e vai em repositório e da uma olhada se estão habilitados. Você está com arquivos novos e antigos na máquina e por isso ele não instala. Caso vc esteja com muitas dificuldades para instalar programas no ubuntu te recomendo usar somente pelo synaptic ou mudar para o linux mint que já traz o gimp e um monte de software já instalado e pronto para usar..



10. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Patrick
Freud_Tux

(usa Outra)

Enviado em 07/06/2015 - 10:40h

ivaniuni escreveu:

É importante saber se vc desabilitou algum repositório do ubuntu, pois o normal do ubuntu qundo atualizado é deixar o gimp instalar normalmente. Tentou instalar o gimp pelo synaptic? clica no menu do synaptic e vai em repositório e da uma olhada se estão habilitados. Você está com arquivos novos e antigos na máquina e por isso ele não instala. Caso vc esteja com muitas dificuldades para instalar programas no ubuntu te recomendo usar somente pelo synaptic ou mudar para o linux mint que já traz o gimp e um monte de software já instalado e pronto para usar..


Eu tinha feito o mesmo questionamento para ele, sobre alguma alteração na source.lists, isso pode explicar o conflito de dependências.
Pra ser sincero, não sei se o synaptic iria funcionar nesse caso. Como é um problema de dependências antigas no sistema e por alguma maneira (suspeito da source.lists), o synaptic talvés não resolva. Nem se der um apt-get -f install talvés resolva, pois poderá quebrar o sistema.
O jeito é esperar e ver o ele retorna.

T+






11. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Thiago Henrique Hüpner
Thihup

(usa Manjaro Linux)

Enviado em 07/06/2015 - 12:13h

Muito estranho o.0

O melhor seria compilar do código fonte, dai funcionará com certeza!

Espero ter ajudado.

[]'s

T+

--

Programador encontrado morto na banheira cinco dias após ter sido dado como desaparecido. Junto a ele foi encontrado um shampoo com as seguintes instruções:

LAVAR;
ENXAGUAR;
REPETIR;




12. Re: Não consigo instalar o Gimp no Ubunto 14.04 [RESOLVIDO]

Flávia Gieseler de Assis
pedrinhaf

(usa Ubuntu)

Enviado em 07/06/2015 - 14:21h

A versão do Gimp que aparecepara mim é também a 2.8.14 e os repositórios estão todos habilitados. De fato o comando "sudo apt-get install -f" não funciona, mas não sei diyer se fiz alguma alteração na source.list. Acredito que não, pois minhas únicas ações após a instalação do ubunto foi instalar o java, os codecs e alguns programas sempre seguindo a risca instruções de sites para principiantes. O único programa que tive realmente dificuldade de instalar foi o Gimp. Instalei sem problemas o syfig, inkscape, tupi, mypaint, kdelive, blender e audacity. Minha luta começou com o gimp mesmo.
Quanto à compilar o código fonte não sei nem para onde que isso vai, mas vou estudar a respeito.
Penso seriamente em mudar de distribuição, meu receio é que outra distribuição seja muito complexa para os meus conhecimentos limitados. Vou pesquizar sobre o Mint.