Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

1. Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Vel
BrotherVel

(usa Debian)

Enviado em 13/06/2012 - 19:15h

Olá amigos.
Há dois dias tenho notado uma coisa...
Toda vez que instalo um programa seja via terminal ou central de programas aparece erro no final.
No caso da central vem a mensagem falha ao instalar o pacote.
Mas o programa instalado roda perfeitamente (pelo menos aparentemente).

O q seria isto o meu ubuntu 12.04 estaria me enganando?

Como resolver?


  


2. MELHOR RESPOSTA

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/06/2012 - 23:25h

brother vel escreveu:

Nunca tinha usado o dpkg...
Mas deu algo, veja:http://i.imgur.com/N8zPe.png
E tb não sei o q fazer!!!

Vc entende?


o DPKG alisó está pesquisando, nada demais ou perigoso, se quiser simule a remoção desses pacotes:

$ sudo apt-get --purge remove zram-config zramswap-enabler -s

e cola o resultado aqui.


3. rsrsrs

Perfil removido
removido

(usa Nenhuma)

Enviado em 13/06/2012 - 19:34h

brother vel escreveu:

Olá amigos.
Há dois dias tenho notado uma coisa...
Toda vez que instalo um programa seja via terminal ou central de programas aparece erro no final.
No caso da central vem a mensagem falha ao instalar o pacote.
Mas o programa instalado roda perfeitamente (pelo menos aparentemente).

O q seria isto o meu ubuntu 12.04 estaria me enganando?

Como resolver?


torça pra mãe Diná ver esse post, pois só sendo vidente para adivinhar o que ocorre! não tem log, não tem imagem, ou seja: nada!

* desculpe a brincadeira.


4. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 13/06/2012 - 19:35h

terias como postar o erro ai para podemos de ajudar


5. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Vel
BrotherVel

(usa Debian)

Enviado em 13/06/2012 - 22:42h

danniel-lara escreveu:

terias como postar o erro ai para podemos de ajudar


Tá na paz!!!

Pode zoar mesmo eu mereci!!!

Aqui vão as fotos são dois programas diferentes...
Mas tá acontecendo com qualquer um, mas depois o programa roda normal
mesmo apresentando estas mensagens.

http://i.imgur.com/IRZWU.png
http://i.imgur.com/jvQqI.png
http://i.imgur.com/2e18c.png
http://i.imgur.com/qXuSd.jpg

Vejam aí!!!



6. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 13/06/2012 - 22:55h

Aparentemente você está com o ZRAM instalado no seu sistema, mas o mesmo não está configurado, tente:

$ sudo dpkg --configure -a
$ sudo apt-get -f install

Sobre o ZRAM veja esse meu artigo:

http://www.vivaolinux.com.br/artigo/ZRAM-(Compressed-RAM)-no-Debian/

* mas a instalação referia-se ao Debian (SystemV), que usa um sistema de inicialização diferente do Ubuntu (UpStart).

a parte referente ao Ubuntu e outras distros é esta:

http://www.vivaolinux.com.br/artigo/ZRAM-(Compressed-RAM)-no-Debian/?pagina=3


7. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Vel
BrotherVel

(usa Debian)

Enviado em 14/06/2012 - 07:29h

edps escreveu:

Aparentemente você está com o ZRAM instalado no seu sistema, mas o mesmo não está configurado, tente:

$ sudo dpkg --configure -a
$ sudo apt-get -f install

Sobre o ZRAM veja esse meu artigo:

http://www.vivaolinux.com.br/artigo/ZRAM-(Compressed-RAM)-no-Debian/

* mas a instalação referia-se ao Debian (SystemV), que usa um sistema de inicialização diferente do Ubuntu (UpStart).

a parte referente ao Ubuntu e outras distros é esta:

http://www.vivaolinux.com.br/artigo/ZRAM-(Compressed-RAM)-no-Debian/?pagina=3


Antes de mexer nisto.
Naõ sei se fui claro mas o problema não esta relacionado a este programa.
Mas a qualquer um que eu instale...
No final vem a mensagem..."erro"!!!
No segundo caso por exemplo, wallch. Veio a mensagem mas ele funciona.

Seria então o ZRAM o causador disso?
Eu posso desisntala-lo, pq tenho swap e meu not tem 2gb de memoria.






8. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/06/2012 - 19:03h

brother vel escreveu:

Antes de mexer nisto.
Naõ sei se fui claro mas o problema não esta relacionado a este programa.
Mas a qualquer um que eu instale...
No final vem a mensagem..."erro"!!!
No segundo caso por exemplo, wallch. Veio a mensagem mas ele funciona.

Seria então o ZRAM o causador disso?
Eu posso desisntala-lo, pq tenho swap e meu not tem 2gb de memoria.


simples brother, isso é um addon, nada essencial para o sistema, basta removê-lo e deve resolver seu problema.

* só não sei o nome do programa, tente aí:

$ sudo apt-get --purge remove zram-enabler

se não for, caçe-o com o DPKG:

$ dpkg -l | grep zram
$ sudo apt-get --purge remove nome-correto-do-programa


9. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Vel
BrotherVel

(usa Debian)

Enviado em 14/06/2012 - 23:13h

edps escreveu:

simples brother, isso é um addon, nada essencial para o sistema, basta removê-lo e deve resolver seu problema.

* só não sei o nome do programa, tente aí:

$ sudo apt-get --purge remove zram-enabler

se não for, caçe-o com o DPKG:

$ dpkg -l | grep zram
$ sudo apt-get --purge remove nome-correto-do-programa


Nunca tinha usado o dpkg...
Mas deu algo, veja:http://i.imgur.com/N8zPe.png
E tb não sei o q fazer!!!

Vc entende?







10. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Vel
BrotherVel

(usa Debian)

Enviado em 14/06/2012 - 23:41h

edps escreveu:

o DPKG alisó está pesquisando, nada demais ou perigoso, se quiser simule a remoção desses pacotes:

$ sudo apt-get --purge remove zram-config zramswap-enabler -s

e cola o resultado aqui.


Deu isto:http://i.imgur.com/3vnWQ.png

Fui na central de programas busquei por ZRAM e encontrei o segundo destes dois instalados: http://i.imgur.com/imify.png
Ele sobrou após a execução do comando acima. Desinstalei pela central e pronto.

edps, obrigado mesmo, vc foi show!!!

Deus te abençõe!!!


11. zram

Antonio Francisco Martins
afrancisco

(usa Ubuntu)

Enviado em 15/06/2012 - 21:07h

Tive este mesmo problema e, seguindo o seus procedimentos resolvi o meu problema com o tal do Zram....
xoudebola...



12. Re: Falha ao instalar pacote de ZRAM!?! [RESOLVIDO]

Vel
BrotherVel

(usa Debian)

Enviado em 18/06/2012 - 22:14h

afrancisco escreveu:

Tive este mesmo problema e, seguindo o seus procedimentos resolvi o meu problema com o tal do Zram....
xoudebola...


Beleza...
Um abraço!!!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts