Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

1. Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 11:53h

Olá pessoal.
Estou tendo problemas ao tentar atualizar o sistema. Ao abrir o Discover ele algumas vezes fecha inesperadamente. Ao tentar abrir o Synaptic ele exibe a seguinte mensagem:E: O pacote code precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.
E: Erro interno ao abrir o cache (1). Por favor reporte.

Ao dar um sudo apt-get upgrade aparece a seguinte mensagem no terminal:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: O pacote code precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.

Alguém poderia ajudar-me com este problema ?



  


2. MELHOR RESPOSTA

Xerxes Lins
xerxeslins

(usa Void Linux)

Enviado em 09/04/2019 - 17:25h


Então troca o comando por:

sudo dpkg --remove --force-all code

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds


3. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Xerxes Lins
xerxeslins

(usa Void Linux)

Enviado em 09/04/2019 - 13:30h


Já tentou remover o pacote code pra ver?



--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds



4. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 13:31h

Ainda não, mas vou tentar.


5. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 13:33h

xerxeslins escreveu:


Já tentou remover o pacote code pra ver?



--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds


Tentei mas a mensagem continua.


6. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 09/04/2019 - 15:39h

sudo apt-get install -f

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


7. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 17:06h

aguamole escreveu:

sudo apt-get install -f

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: O pacote code precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.

O problema persiste.


8. Vamos apelar

Xerxes Lins
xerxeslins

(usa Void Linux)

Enviado em 09/04/2019 - 17:18h


Ele não quis remover o pacote???

Então vamos usar todas as armas!!!

Execute:

sudo dpkg --remove -force --force-remove-reinstreq code

sudo apt-get --fix-broken install

sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

sudo apt-get update

sudo apt-get autoclean

sudo apt-get autoremove

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds



9. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 17:21h

xerxeslins escreveu:


Ele não quis remover o pacote???

Então vamos usar todas as armas!!!

Execute:

sudo dpkg --remove -force --force-remove-reinstreq code

sudo apt-get --fix-broken install

sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

sudo apt-get update

sudo apt-get autoclean

sudo apt-get autoremove

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds


Ao digitar o primeiro comando a saída foi:
sudo dpkg --remove -force --force-remove-reinstreq code
dpkg: erro: ações conflitantes -f (--field) e -r (--remove)

Escreva dpkg --help para ajuda sobre instalar e desinstalar pacotes [*];
Utilize 'apt' ou 'aptitude' para gestão de pacotes amigável;
Escreva dpkg -Dhelp para uma lista de valores de flags de debug do dpkg;
Escreva dpkg --force-help para uma lista de opções para forçar operações;
Escreva dpkg-deb --help para ajuda sobre manipular ficheiros *.deb;

Opções marcadas com [*] produzem muita saída de texto - utilize pipes com 'less' ou 'more' !



10. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 17:26h

xerxeslins escreveu:


Ele não quis remover o pacote???

Então vamos usar todas as armas!!!

Execute:

sudo dpkg --remove -force --force-remove-reinstreq code

sudo apt-get --fix-broken install

sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

sudo apt-get update

sudo apt-get autoclean

sudo apt-get autoremove

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds


Os demais comandos levaram a o mesmo resultado anterior, ou seja:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: O pacote code precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.




11. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Xerxes Lins
xerxeslins

(usa Void Linux)

Enviado em 09/04/2019 - 17:34h


viana3 escreveu:

xerxeslins escreveu:


Ele não quis remover o pacote???

Então vamos usar todas as armas!!!

Execute:

sudo dpkg --remove -force --force-remove-reinstreq code

sudo apt-get --fix-broken install

sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

sudo apt-get update

sudo apt-get autoclean

sudo apt-get autoremove

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds


Os demais comandos levaram a o mesmo resultado anterior, ou seja:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: O pacote code precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.



executou:

sudo dpkg --remove --force-all code

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds



12. Re: Erro ao tentar atualizar o KDE Neon. [RESOLVIDO]

Moises Viana Felipe
viana3

(usa openSUSE)

Enviado em 09/04/2019 - 18:19h

xerxeslins escreveu:


Então troca o comando por:

sudo dpkg --remove --force-all code

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds


Muito obrigado, deu certo.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts